Posts created by madstitcher54

 
 
 posted in MatchVentures on Oct 18, 17 7:02 PM
Level 61 loads with only clouds. The level never appears or it if does, it is frozen.
Windows 10. I have tried everything I can think of including reinstalling. I too am disappointed that I cannot play the game. How about a refund?!
 
 
 posted in Fetch on Jan 24, 17 8:56 AM
Is this old game the best you can come up with??? I lasted less than 2 minutes before I deleted it.
 
 
I agree that this game is beautiful to look at. Boring to play. And what's with the end? Looks like they needed to end it.
 
 
 posted in Dark Parables: Queen of Sands Collector's Edition on Jun 27, 15 9:09 AM
Lost the key to the book in the perfume shop. When I tried to put it in the book, it disappeared. End of game!! Sorry I bought it to have it end in a "bug".
 
 
 posted in Ominous Objects: Phantom Reflection on May 20, 15 3:56 PM
I too am having problems with the SE. Now I get the message that it has stopped working. Windows 8. Installed it on the May 17. Disappointed that it happened when I am almost finished. Like planned to die.
 
 
 posted in House of 1000 Doors: Evil Inside Collector's Edition on Mar 23, 15 1:54 PM
Adding my disappointment with this game. All of the graphics are outdated. Are you sure this isn't the first one rather than the fourth. I loved the others and foolishly bought this one. At least it was a buy one get one.

It is so slow and my cursor floats. Will uninstall now. Didn't even finish the first two scenes. Will not buy **** games after this.
 
 
 posted in Crime Solitaire 2: The Smoking Gun on Aug 4, 14 10:28 AM
Dumb, dumb game. Why pay for solitaire when there are many better games elsewhere. It did not close (of course I couldn't fine a menu to quit the game on the play screen) so I had to restart my computer to stop it and uninstall. Not even the "task master" could get it to close. What a mess.

My advice--DON'T BOTHER.
 
 
 posted in Crime Solitaire 2: The Smoking Gun on Aug 4, 14 10:24 AM
Has anybody had trouble shutting down this game? There seems to be no "quit" on the play screen or the settings screen or anyplace else I could find. Esc didn't work. I tried shutting it down with the task master and I wouldn't shut down. I tried to uninstall but was told that it was still running.
Finally, had to restate my computer to get it to stop running. Then uninstalled it.

MY ADVICE--DO NOT INSTALL THIS GAME. It is a silly one and why pay for solitaire and a game that "gums up the works."
 
 
 posted in Haunted Hotel: Ancient Bane Collector's Edition on Jun 30, 14 8:08 AM
Did anyone lose the valve handle for the well after they got the star? The hint button keeps taking me there, but I don't have the valve. Also, lost the sand timer from the plant. Where did it go? Stuck until I find both. Don't want to restart the game. It is not that good.
 
 
 posted in Antique Shop: Journey of the Lost Souls on Jun 14, 14 9:08 PM
What or where is the third part?
 
 
 posted in Antique Shop: Journey of the Lost Souls on Jun 10, 14 5:52 PM
Anybody have trouble with the game deciding you should start over? I had almost finished and the game started me over. Don't really want to do that.
 
 
 posted in Haunted Manor: Painted Beauties Collector's Edition on May 31, 14 2:09 PM
I found this game really disjointed. Finding one thing in an area and having to remember where it went before you can do anything else. Why is the player led back to the painting to put in one piece before they can continue. The map is worthless. Too bad the CE is so lacking. Sorry I bought it.
 
 
 posted in 100% Hidden Objects on Apr 20, 14 8:43 AM
Guess no one knows. I am having the same complaint that you are.
 
 
 posted in Cruel Collections: The Any Wish Hotel on Apr 1, 14 6:21 PM
Did the developers run debug programs? There is no reason for the many times I have had the game freeze. Each time, I have had to start at a point before where I was before the freeze.
 
 
 posted in Grim Legends: The Forsaken Bride Collector's Edition on Mar 10, 14 5:17 PM
While the game is okay, there are so many technical issues with it. Have been unable to find objects (some because the descriptions are wrong, English again). Now I am stuck on the brooch that is supposed to be under a letter by the entry to the city. Not there and can't get any further. Guide shows a heart. There isn't one in my game.
I'm sorry I bought this game. Will now delete it without finishing.
 
 
 posted in Grim Legends: The Forsaken Bride Collector's Edition on Mar 10, 14 5:13 PM
I have the same problem. Also have the CE and the guide shows a heart. I don't have one. There seem to be other problems with this game too. If anyone can get beyond the missing brooch, please advise.
 
 
Usually enjoy the Mystery Trackers games. This one is a bust. Illogical and the morfing objects don't. End seems like the programmers were bored.
 
 
 posted in Crystals of Time on Dec 31, 13 11:56 AM
Too many problems. The tree is always blocking the way even when you use the lift to bring it up. There is no way to get to the face of the fountain in the greenhouse--whatever you are supposed to do there. Sorry I bought this one even after my free hour.
 
 
 posted in Crystals of Time on Dec 31, 13 11:50 AM
I agree. If they are for the American market, they should be in proper English!!
 
 
 posted in Crystals of Time on Dec 26, 13 7:15 PM
Wouldn't have purchased the game. Had a free game credit. The spelling is a give-away that English is not the developers' first language. I keep getting hints to do something then can't do anything. A very frustrating game.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator