Posts created by chicken_good

 
 
 posted in Midnight Castle on Sep 2, 16 4:44 PM
The Samurai is still my favourite, but with 20 minutes to spare, I got the mermaid. Those silver chests were almost the death of me! I love my little cook pet even more now, though, as it brought me two of them!
 
 
 posted in Midnight Castle on Sep 2, 16 10:38 AM
The dwarf quests, feeding pets, buying them with gems from the crafting menu... that's the ones I know of
 
 
 posted in Midnight Castle on Sep 1, 16 5:02 PM
Haha, I will be quarantining myself until I stop coughing. With asthma I get used to constant colds, so I already have ginger and camomille tea, two tubes of vitamin c and plenty of water I actually don't feel very sick as long as I don't try to do anything, so this game is perfect for this kind of days!

Also: GOT THE SAMURAI!!!!

(I cheated a bit and bought some gems to get those pet medals, but with so little time left I didn't want to risk missing out on him. Now let's see how close I can get to the mermaid... Doubt I'll get her, but it's worth a shot.)
 
 
 posted in Midnight Castle on Sep 1, 16 4:08 PM
Thank you gohill!

Took playing through quite a few episodes of Bondi Beach, but I JUST finished it. The dice game will be child's play after that marathon! XD
 
 
 posted in Midnight Castle on Sep 1, 16 2:25 PM
Yeah, I'm level 14, so got quite a while to go for the pets (they're level 69 or something, iirc). At least being home with a cold gives me a chance to do this. So far: 43/100
 
 
 posted in Midnight Castle on Sep 1, 16 12:54 PM
Darn. I was really hoping there was an easy, obvious way that I just didn't know about XD Well, here's to grinding!
 
 
 posted in Midnight Castle on Sep 1, 16 12:14 PM
I joined the game a few days ago, and I've got my eyes set on that samurai in the challenge. Only problem is that time is running out and I now have 5/100 airship items. Is there any way to get them besides doing HO scenes?
 
 
 posted in Midnight Castle on Aug 30, 16 11:17 AM
That would be fantastic! It's not that I mind the tournaments, but the notification system is so in your face it's become my biggest annoyance with the game. Either turning them off after I've visited the tournament page once, or having the ability to turn them off in the options would be great!
 
 
 posted in Midnight Castle on Aug 30, 16 8:47 AM
Is there any way to turn off the tournament notice? The constant messages and the sparkles around the task bar are so annoying, and makes it a lot more difficult for me to focus on the actual game.
 
 
 posted in Midnight Castle on Aug 29, 16 8:29 AM
Too many friends to return all gifts in a day, so I'll be removing this atm
 
 
 posted in Asian Riddles on Jul 29, 13 8:46 AM
I have a really odd problem; the game seems to forget me. Every time I enter the game after having exited it, the game forgets who I am and I have to register my name and start on level 1. This makes the game completely unplayable. I have tried deleting it and reinstalling it twice, but that didn't change anything. Is there anything I can do?
 
 
 posted in New Yankee in King Arthur's Court 2 on Mar 20, 13 4:40 AM
I can manage to get down to two trees, but the moment I cut down one of them, the worker is released and the level is completed. It's probably possible if you can get your workers to chop down the last two trees at the exact same time, but that's beyond my capabilities. Annoying, as it's the only achievement I don't have.
 
 
 posted in Hero of the Kingdom on Jan 24, 13 3:47 PM
I would say both <a href="http://www.bigfishgames.com/download-games/17962/city-of-fools/index.html">City of Fools</a> and the two Three Musketeers games <a href="http://www.bigfishgames.com/download-games/7753/the-three-musketeers-queen-annes-diamonds/index.html">Queen Anne's Diamonds (1)</a> and <a href="http://www.bigfishgames.com/download-games/8668/the-three-musketeers-miladys-vengeance/index.html">Milady's Vengeance (2)</a> are both similar, if it's the point and click adventure / questing type of games you like. The two three musketeer games are really one game split into two halves, but for me it was worth the money.

Really hope the links works, because I almost couldn't find the three musketeer games using the search function
 
 
 posted in Whispered Stories: Sandman on May 25, 12 11:18 AM
cherbtoo wrote:
chicken_good wrote:When I started the game in Sleepwalker mode, the inventory was gone. It was there in Dreamer mode, but nothing in sleepwalker mode. Makes it impossible to play, so that was a setback.


IMO they are two separate modes and therefore your inventory should not transfer over and I think you would have to start again from the beginning.


Problem wasn't that the items in my inventory was gone. My whole inventory was gone. There's just a blank spot where it was in Dreamer mode, and when I pick up items, they disappear completely.
 
 
 posted in Whispered Stories: Sandman on May 21, 12 11:53 AM
When I started the game in Sleepwalker mode, the inventory was gone. It was there in Dreamer mode, but nothing in sleepwalker mode. Makes it impossible to play, so that was a setback.
 
 
 posted in Runaway With The Circus on Apr 29, 12 2:12 PM
For some reason I can't type my name in after I've selected a character. No matter what I write, the game don't seem to recognize it, and the only thing I can do is to click ok to go back to the scene where I pick between the man, woman or circus tent. I have never had a keyboard issue, so I have no idea what the problem is.
 
 
This is the first time I've actually bothered to review a game, so that should say something! Just played through the demo, and the only reason I'm not buying the game tonight is that I need to sleep! If I did, I know I would be up all night playing.

For me, this is one of the few games I can compare favourably to the Mystery Case Files games. The setting is creepy and a bit unsettling, the music perfect for keeping the suspense and the hidden scenes are not too hard, yet a bit challenging (perfect difficulty for me, as I play games to relax).

I love the idea with the cards, and how the suits can be found almost everywhere. Also how the objects you need to find actually makes sense to the character. I loved when the player character refused to walk down a hallway before the light was turned brighter because it was creepy down there. First time I can say I've agreed with their assessment of the place. Also love that he/she's got a reason to be there (finding a friend who s/he knows is still alive) since many suspense games could be solved by just running away and never turning back, like a sensible person would. Logic? In MY suspense game? I LOVE it!
 
 
 posted in Classic Adventures: The Great Gatsby on Nov 28, 10 7:47 AM
I have the same problem. The game freezes completely, most of the time when I have found every item in the scene as well as the hidden word, and I have to restart the game to move on. It seems it's the dialogue that's the issue, since turning it off and on again helped once, but for some reason the "level complete" screen just won't show up when I have finished a scene.

This problem didn't arise before my 60 minutes were up and I bought the game. At first it was only once every few levels, but right now it is every level, making it completely impossible for me to play the game. I feel cheated, to be honest.
 
 
 posted in Where's Waldo: The Fantastic Journey on Jan 5, 10 3:59 PM
I have the same problem. It downloads ok, but is stuck on activation for hours at end. It would be odd if it was the firewall that was the problem, considering how other games are downloaded and activated with no fuss. I've tried twice, just in case it was a buggy download, and it didn't work either time, with the same flaw. Can anyone give me any advice as to how to install the game?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator