Posts created by taniamorse85

 
 
 posted in Samantha Swift and the Fountains of Fate on Mar 7, 11 1:12 PM
I am so frustrated! I've been using the walkthrough to help myself through difficult spots so far, but I can't seem to get past a certain part. I am at Midas Palace--Outside the Back, and I have collected all list items. I have also put the gold dancer in place and opened the slot for the gold star. I tried putting the gold star in its place, but it would not go into place. I tried several more times, but it still wouldn't go in. Has anyone else had this problem? If so, how do I fix this issue?
 
 
 posted in Samantha Swift and the Fountains of Fate on Mar 7, 11 11:29 AM
hydrogibbon wrote:I was excited when this game came up because I have enjoyed the series until this one. It seems very hard to find the spot to use your inventory items. The objects are hard to find as well. It's even hard to find the swifts and lightening bolts. Many of the clues are much too obscure. For example a suitcase behind you. HUH! I got that by accidently clicking on the wrong thing. Writers are trying to be much too cutesy. This will be the first Samantha Swift that I pass up. Maybe I will be more in the mood when it comes up as a DD but for now it's a pass for me.



I will admit that some of the clues are odd, but if you think hard about them, they make sense. In the case of 'suitcase behind you,' the correct item is a backpack. A backpack is similar to a suitcase because you use it to carry things, and you wear it on your back, behind you.

Because of the difficulty of some of these clues, I am definitely glad there is no timer in this game. I have spent several minutes finding each of some of these items with particularly weird clues.
 
 
 posted in World Mosaics 4 on Feb 20, 11 2:42 AM
I just finished the free trial, and I had one major problem with it. In previous versions, you could change between the two tools by using the right mouse button. In this version, you use the left mouse button for one tool and the right mouse button for the other. I prefer the previous way of changing tools because I use a laptop, and it is rather awkward using the tools in this manner. Because of this difference, I made a lot more mistakes than I would have otherwise. Other than that, I liked the game. I don't think I'll be buying it, though. I have the original World Mosaics, and I think I'll stick to that for now.
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 21, 11 3:06 AM
I'm on the train and cannot figure out how to get the key to unlock the box. I have found the key, but the game is telling me it is out of reach. What do I need to do to reach the key?

I love this game, but I've been stuck at this point for a while, and I'm starting to get frustrated.
 
 
 posted in Midnight Mysteries: Salem Witch Trials on Jan 14, 11 3:03 AM
Thank you so much for the walkthrough! I finally completed the game after many, often frustrating, hours of trying to complete it. I didn't quite get all the clovers, but I'm going to look over the walkthrough again to see if I can determine which ones I missed. I love this game!
 
 
 posted in Magic Encyclopedia on Jan 28, 09 5:25 PM
I am stuck in a portion where you have to do some archery. I don't remember where this is exactly, but you have to use a bow and arrow to hit a target on a scarecrow. My problem is that I cannot figure out how to get enough power to send the arrow more than a short distance. Does anybody have tips to get the arrow to hit the target?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator