Posts created by moojelly

 
 
do you know where I can find the second key in this puzzle? I can't find it and it's making me insane
 
 
In this puzzle you need 2 keys to turn. I got the one key by turning the 4 skulls to release it. For the other key, I only have half of it - and I can't figure out where the other half comes from! the walkthrough is not helping me at all Please, someone smarter than me out there, help me!
 
 
 posted in Pahelika: Revelations on Jun 25, 12 1:52 PM
This game is seriously difficult. I was so thankful to see a skip button on some of the puzzles, but there needs to be a hint option for other portions of the game play. It was quite maddening, and I never would have finished the game without referring to the walkthrough quite a few times. I'm glad I completed the game, and I know for sure I wouldn't play it again - too frustrating!
 
 
 posted in Pahelika: Revelations on Jun 12, 12 6:19 AM
Okay I put in the correct combination on the door in Ch 5, then went to speak with the little girl. I must not have answered the questions properly because she did not give me the iron rod. Now when I go back to her, she just keeps saying "have you opened the door yet?" and I have no rod. I'm stuck! What can I do?
 
 
thanks so much for posting this! it totally worked for me because i had used the nexus tubes out of order as well
 
 
omg thank you! i didn't realize that you had to watch the dial colors on the security screen as well. i waited until the arrow was in the green zone, copied down the code and then went right to the right side door and it worked
 
 
i got the code for the door on the right by looking at the very small security screen in the office. but when i enter it, the code doesn't work! aghh!! i don't know if that will help you out or not, but i hope so!
 
 
okay i got it after i read the book in the chest! thx mr russ
 
 
yes, i did each number separately and it still is telling me that i don't yet have all the information i need
 
 
okay I put the fuse in place, have rotated all the numbers so that they reveal the correct solution according to the strategy guide, and it still tells me 'i feel like i don't have all the information i need'. what the heck am i missing?
 
 
 posted in Creepy Tales: Lost in Vasel Land on Nov 9, 11 8:31 PM
I actually thought this game was okay - it certainly isn't the caliber of the mystery case file series or other games in its genre, but still an allright play. The hidden object scenes were challenging. There are spelling and grammatical errors throughout, which make it seem more amateurish. Also, I found the book on the lower right with the map in it somewhat frustrating - pointing you to scenes to complete without indicating that you had to complete several steps before you could access those scenes. I uninstalled the game once I beat it - it's not one I would play over and over.
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Oct 23, 11 8:32 AM
nope i just restarted under a different profile - annoying!! but so far i'm almost done and no other bugs
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Oct 21, 11 2:33 PM
in chapter 3 'the cave' it will not allow me to pick up the emerald - i can't move forward in the game until this problem is fixed
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Oct 21, 11 2:26 PM
grr i keep clicking on the emerald in the cave and it won't let me pick it up - help!!
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Oct 21, 11 2:25 PM
grr i keep clicking on the emerald in the cave and it won't let me pick it up - help!!
 
 
 posted in Grim Facade: Mystery of Venice on Jul 30, 11 1:20 PM
i took the gondola across the river to the house, and in the hidden object scene, it will absolutely not let me select the dragonfly needed to complete the scene. I've tried many times to click on it, as well as exiting and re-entering the game - no change. Please help!
 
 
 posted in Mystery Trackers: Raincliff Collector's Edition on Jul 8, 11 9:16 AM
oh wunder thank you SO much!!
 
 
 posted in Haunted Halls: Green Hills Sanitarium on Nov 30, 10 3:33 PM
Yes, I am having the same slo-mo issues everyone else seems to be having with this game. Holding out for a solution
 
 
 posted in Snark Busters: Welcome to the Club on Oct 15, 10 10:35 PM
My numbers were: left (31422) and right (0;+3;-3;+1;+2). The correct answer for these numbers is 34134.
 
 
i think there's clippers in the garment factory back room. you take those and then cut the twig off the tree where the monk was.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator