Posts created by atmmts

 
 
 posted in Weather Lord: The Successor's Path on Apr 8, 15 8:37 AM
Even with Music and Sound FX sliders at lowest point to the left, both can still be heard. This is annoying as I like to play a game as I stream a video or listen to other music.
 
 
 posted in Love Chronicles: A Winter's Spell Collector's Edition on Jan 20, 15 2:21 PM
Well, I do mind - not a whole lot, but don't feel need to be snarky to those gamers it does bother. While I appreciate that many (most/all) of these games are developed by folks whose first language is not English, it does make me wonder when I see such an slip if there are other aspects of the games where the developers made errors. Based on the number of postings re: 'tech issues' and other threads about glitches, it does seem that the game has some bugs interfering with gameplay.

Sometimes relatively small slips are an indication of overall care taken during production.
 
 
Be kind to each other!

So important! Almost 100% of BFG posters follow this golden rule. So rare any where else on web.

Thanks so much for gentle reminder to all of us,

 
 
Uh, Oh. Hope I didn't break rule by sending PM. I did go out of my way to be polite though.
Being a member for 8 years, I should have realized all the great folks here would address issue in correct manner.
 
 
Both threads have already been started, but thanks anyway.
 
 
 posted in Mysteries of Neverville: The Runestone of Light on Jun 15, 14 7:03 AM
HoneyVegas wrote:Terribly short!


Agree completely. Purchased game - thank goodness used (wasted) a free game coupon. The game ended less than 10 mins after the demo ran out.

Very disappointed.

Do I recommend this game? Nope!
 
 
 posted in Whispered Legends: Tales of Middleport on Jun 11, 14 7:25 AM
Just my 2 cents to be counted among those stuck at same point in game as several others: after playing fish game on ship door, get stuck at scene w/ clairvoyant's wagon. Purple smoke swirling & Hint clock ticking away. - otherwise frozen ( like the movie). Even when I did Ctrl-Alt Del move, screen flickered and returned to same scene in game. Finally able to quit game after canceling forced shut down -which I was only able to initiate by hitting PC off button.

 
 
 posted in Antique Shop: Journey of the Lost Souls on Jun 9, 14 3:59 AM
Thank you very much from all of us who are easily confused~
 
 
The critter in the tree house looks more like an otter. The tail most definitely is not like a beaver's. The teeth - okay, but not the tail, body or head/face.

Okey-doke, I feel much better - I've had my nitpick for the day.
 
 
 posted in Cruel Collections: The Any Wish Hotel on Jan 8, 14 6:50 AM
Usually takes some time before a full walk through is posted, but you may check the forum for a thread on any specific problem you're having w/ game. Also, you can always start a thread yourself to get help. I've gotten great help w/ many games over the years using the forums.
Good Luck!
 
 
 posted in Alex Hunter: Lord of the Mind on Dec 17, 13 4:51 PM
Very odd & a 1st for me w/ BFG: completed dl of game and "Trial expired" shows in game mgr. I know that this is not an unusual prob. for some fish w/ other games. Based on positive reviews, I've decided to go ahead and use game credit to purchase w/out trial. My fingers are crossed that I won't regret it.
 
 
 posted in Island Tribe 5 on Dec 10, 13 2:27 AM
I got caught short the first time I did this level. The trick is: do not keep giving the pearl farm any kelp once you've got enough pearls to feed the pink octopi - then you'll have enough kelp for the crab farm.
Hope this makes sense & helps you.
 
 
 posted in Gardens Inc.: From Rakes to Riches on Mar 28, 13 4:36 AM
Thank you so much for your help. Really appreciate it! Off to try right now...
 
 
 posted in Gardens Inc.: From Rakes to Riches on Mar 25, 13 11:52 AM
Would greatly appreciate any help getting this trophy. I've completed the game (thanks solely to siapson's great walk-through) & replayed many levels, but can't find the one that will 'work' so that timer can be set to 25 mins. What am I missing?
 
 
 posted in Twisted Lands: Origin on Sep 8, 12 10:19 AM
One of the missing men shown on the side of court/police building next to the truck is the spitting image of Gore Vidal ("Benjamin Nunjes"). Wonder if that was done as a wink, wink by developers or they just picked random images from web. I don't recognize the other 2 men, even if I'm old enough to recognize ol' Gore.

 
 
 posted in Eternal Journey: New Atlantis Collector's Edition on Jul 22, 12 6:48 AM
Sheerija wrote:.

As to the suspending believe aspect - needing gears and fuses on a space shuttle on Mars in the year 2178? Anyway, it's really well done and something we have .


I agree completely. I had a true WT* moment when I needed to pick up insulating tape...but on the good(?) news front, newspapers are still being published in 'dead tree' form well into the next century. This, despite marching toward oblivion in the here & now.

It is a very good game all around & I like quirks in my games, people, etc.
 
 
 posted in A Gnome's Home: The Great Crystal Crusade on Jul 18, 12 9:34 AM
Thread below yours has several suggestions. Also go to "YT" and check out vid for The Gnome's Tale that is 1:55 mins long. It doesn't say it's for lvl. 22 in title, but it is. It has ~90 views as of this minute. It took the player exactly 1:29 to do it - no mercy on this lvl., for sure. Trick seems to be to not let the gnomes backtrack at all. Good Luck!
 
 
Well, yes I ran into a glitch - right after replying to OP, but don't think it had anything to do w/ 'double dl& demo'. I'm at the point in game where there's supposed to be a 2nd HOS in Tibet at vendor cart on right across from well w/ monks' skeletal remains. Click 'hint'', it points me there, but Inventory keeps showing 0 objects to find. Tried to delete & reinstall w/ still no luck.
 
 
Shouldn't be necessary to delete. I also downloadled the demo from another site, played till it expired. Then I dl'd demo from BFG & demo picked up from same point in game I'd stopped playing on 1st demo. This has happened many times w/ games from several sites/developers. Guess it's kinda like when you play demo, then buy game - you should be able to start playing from where you left off when demo expired.

Hope this reply answers your question, I know it's a bit wordy. Good Luck~
 
 
 posted in Mystery Trackers: Black Isle Collector's Edition on Mar 3, 12 7:07 AM
You will get the "Completed Tutorial" (Pale Lady) achievement after you begin the HOS in the hotel room. A pop-up lets you know you have to use inventory to find items in purple. This is the first room you get in via the ladder you have to match the rung halves to fix/use.

This is my 3rd time re-starting so I could get the tutorial reward. I could not figure out why I wasn't 'earning' it either.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator