Posts created by pamvan

 posted in Viking Brothers 3 Collector's Edition on Mar 31, 18 3:52 PM
I agree. I have 3 stars on all levels. Still cannot access bonus levels. We paid for the collector's edition and now can't get to the major portion of the extras! I am not happy.
 posted in Viking Brothers 3 Collector's Edition on Mar 21, 18 2:29 PM
I have finished the main game, obtaining 3 stars on every level. I played the 5 tavern games. Even so, I keep getting the message to complete the main game when I try to go to the bonus game level.
 posted in Viking Brothers 3 Collector's Edition on Mar 11, 18 11:06 AM
i finally got gold on this level, but it took For. Ev. Er!! I've been struggling with 25 for a few days now, but I think I focused on getting the supplies from the right hand side of level 24 asap. I find that I tend to overstock on all supplies when I really don't need as many of some as others. Sorry I can't be more specific. If you still have trouble, post again and I'll replay the level to see if I can remember how I did it! Good luck. This is a challenging game for certain....
 posted in Lost Lands: Ice Spell Collector's Edition on Dec 27, 17 6:41 AM
The instructions state to arrange the colors as shown on the hint. What hint? I took a break over Christmas at this point and cannot remember if I found a hint for this puzzle anywhere. I don't see anything in the diary. Any suggestions??
 posted in Moai V: New Generation Collector's Edition on Oct 28, 17 3:08 PM
I have to agree about the guide. I've been looking for the 5th "element" also. I think I would either remember the pile of leaves or the one behind the altar..Gonna try again! Thanks for the reminders.

Made it! Finally
 posted in Moai V: New Generation Collector's Edition on Oct 28, 17 2:34 PM
I found (quite by accident) that I needed to wait until I opened the gate before using the runes in order. Why one needs to click the fire rune is beyond me, but.... Anyway, when I was finally able to clear the gate, then use the runes, then I was able to click on the priest. Worked for me at long, long, long last.
 posted in 4 Aztec Skulls on Jun 23, 17 10:01 PM
There's a little bump in the road in front of the storehouse along with a rock to the right of the cave entrance. Hope this helps. Good luck and have fun.
 posted in 4 Aztec Skulls on Jun 23, 17 6:21 PM
Just type in 4 Aztec skulls caches. It should come up. It's DragonDog. Warning--it's still pretty hard to remember all of them when you're frantically clicking away. I've had to redo several levels just because I forgot one! Good luck and have fun.
 posted in 4 Aztec Skulls on Jun 18, 17 8:59 AM
Look for little--and i mean little--bumps in the sand. Also the small fire pits in villages and along rock walls. Additionally, you can find pictures of the locations online. I have resorted to that option myself since I care more about the building and collecting than the caches. But I like to see that message that I found them all--go figure. Good luck and have fun!
 posted in 4 Aztec Skulls on Jun 18, 17 8:55 AM
You have probably either found the cache or give it up, but I'll tell you what I am doing. I went online and found a site that shows where all the caches are for each level. Now, that may be considered cheating by some, but even after looking at the picture, it isn't always easy to remember where the elusive bundles are located. I am more interested in beating the time with the collecting and building, etc. I'm not sure I am allowed to post the actual site but it isn't hard to find, remember, Google is your friend. Good luck and have fun!
 posted in Viking Brothers 2 on Jun 6, 17 1:03 PM
I am having the same problem as the rest of you. I can get to the file, but when i try to save it I get the message I do not have permission. I am the administrator for this pc so I don't know what else to do. I'm getting tired of this. Have gold on all other levels thus far. Guess I'll move on and hope someone comes up with a solution that works for me!
It needs the blanket and one multi-tool. It is hard to click on! Good luck.
You probably have already figured this out by now, but for others... I missed a statue early on and the only way I found out which level was by going back to the map and looking at the positions in Collections in the strategy guide, level by level. Tedious, but I did find the one I had missed. I found no other way to do this. Good luck.
 posted in Cadenza: Fame, Theft and Murder Collector's Edition on Apr 16, 17 1:16 PM
Outside the villa, using the tape recorder puzzle: when I click on the second icon (the calendar), the game won't advance as it shows in the walkthrough. I click on the "recording" printout and get the message "I need to edit some parts of this sentence" or something to that effect. I have restarted the game and get the same results. I have Windows 10. Is this a glitch or am I simply missing something? Thank you for your help

I'm sorry. I figured out my problem. Nothing to do with the game.
 posted in Cadenza: Fame, Theft and Murder Collector's Edition on Apr 15, 17 2:43 PM
When I click on the second item, the game tells me "I need to cut out certain parts of this sentence" and will not continue. Is this a glitch or am I missing something? It goes from the first item to the second automatically just fine. I have restarted that game and still have this problem.

Never mind. I figured it out.
Well, it took me many, many days of giving up then going back to this level but I finally ended with 3 stars with absolutely no time to spare. I did focus on collecting the food immediately upon its appearance and using the gathering and additional item bonuses together. I did not increase the food to level 3 prior to using the upgrade bonus. I worked a quickly as possible, following the strategy guide pretty closely. I was acting practically on autopilot by the time I finished; I must have tried this level at least a hundred times! I did find the I had to be careful not to use the gathering bonus too closely to upgrading the forge to level 2 so I had the upgrade bonus available as soon as I completed that task. Then I tried to use it in conjunction with the additional item as often as possible throughout. I stopped gathering wood toward the end after the gym and the pool were rebuilt and I realized I had enough to finish the wooden bridge (sorry, I don't remember how much I had left). This was such a hard level; sure could have used that cocoa tree!! P.S. Level 8 is proving about as difficult!! Good luck.
I'm sure you've figured this out by now but just in case... The Sorcerer's stone allows you to change stone into gold. Click on the middle icon on the upper right of the screen and you will see you need 5 stone and one Sorcerer's stone to get gold. The Sorcerer's stone is used automatically once you have it. Have fun!
I sure could have used that booster on this level, but Finally! I finished with 3 stars and not one heartbeat to spare!! All of the advice already given really helped and then it was concentrating and clicking over and over until it became almost automatic!
What a hard level. I don't think I have ever spent so much time on one game level ever. Good luck to everyone and thanks so much for all the advice.
Hespera, what is the auto upgrade bonus? Is it available on level 24? I am still struggling to get 3 stars!! I hope to goodness I haven't missed that bonus all this time!
Has anyone finished this level with 3 stars? I have been trying for days and it eludes me!!
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator