Posts created by llstjohn

+Campfire is the first thing I thought of when I saw this too. I liked the Campfire games, tho. I'll give this one a look.
 posted in Ominous Objects: Lumina Camera Collector's Edition on Aug 25, 16 8:11 AM
I was trying to do the maze map and reset it to start over. The ball disappeared. Any ideas? I don't want to skip it.
 posted in Grim Tales: The Heir on May 15, 16 2:30 PM
Skip is an option. I don't really like to skip them either but had to with the spider. Could not figure that one out. Even with the instructions.
 posted in Nevertales: Smoke and Mirrors Collector's Edition on Nov 11, 14 3:47 AM
I like the 90 minute demo for this game but nowhere did I see a warning to save because the demo runs out if you don't. Some of them offer the option of 'save and quit' so you don't have to play the whole demo at once. This one does not.
 posted in Grim Tales: The Vengeance Collector's Edition on Jul 8, 14 11:45 AM
bfgVaiya wrote:Hey Everyone,

I'm really glad to see you all jumping in to help out with this situation!

Yaelle, you can definitely contact Customer Support <a href="">HERE</a> and request a list of your unused, unexpired coupons. Any of our Reps would be more than happy to get that for you.

Happy Gaming!


And you know they will issue a new code for any you did not use because you forgot you had it.
 posted in Grim Tales: The Vengeance Collector's Edition on Jul 8, 14 11:35 AM
Tookat--did you know that control + will increase the font size? Control - returns it to normal.
 posted in Grim Tales: The Vengeance on Jul 8, 14 11:29 AM
Oh my goodness!! I never thought of looking at the CE forum! I'll go look for the solution to the rotating mini portraits in the vault there. Thanks, prowler!
 posted in Grim Tales: The Vengeance on Jul 8, 14 11:14 AM
Hey, Joyce! I also suffer from FLIS so I bought the SE. Does anyone know how to do the puzzle in the vault where you rotate the mini portraits? Does not make sense to me, clue in the diary no help. I don't want to download the strategy gudie just for a 5 minute trial and can't find one anywhere else.
Glad to see the waters still get a little rough in the pond.

My bad. There is a w/t for this game in the w/t forum.

 posted in Whispered Legends: Tales of Middleport on Jun 14, 14 3:35 PM
Anyone solve that puzzle with the compass in the middle and moving squares of ship pictures to put together? How does it go?
 posted in Black Rainbow on May 16, 14 9:02 AM
The hint system in this game is so good you don't really need a walkthrough tho I am having a little trouble figuring out how to match up the skull color with the ribs. I am a fan of pure adventure games. I do not, however, like to waste time doing something that is not essential to game play. Like in the Rhem series, you ride this train, go up in this elevator, through the tunnel, down these stairs and up this ladder just to LOOK at something. Then if you can remember how to get back there, go to where you started from because the 2 letters you found are what you need to open this door. I have played thew entire series through to the end and loved all of them. (Confession time: I had a walkthrough clutched tightly in my left hand while maneuvering around with my right. Great games, tho!!)
 posted in Black Rainbow on May 16, 14 8:48 AM
Usually when something disappears from your inventory it means you don't need it any more. I'm not that far into it yet.
 posted in Black Rainbow on May 16, 14 8:45 AM
Did you also figure out how to match the skulls and ribs colorwise? Please tell me if you did. If you click on 2 of them long enough do they eventually line up? The hint system on this game is so good you don't really need a walkthrough but instructions on this one are not clear enough.
 posted in Black Rainbow on May 16, 14 8:39 AM
Use the diamonds in the bag. Put the coin in the slot of the 3rd skeleton. Then you have to match the skull color with the rib color. Contact me when you figure out how to do that please.
 posted in Jigsaw World Tour on Nov 29, 13 11:47 AM
I figured out how to save them but am at a loss to open a save and finish it. Tips?

ETA: Never mind. Found 'play' button.
 posted in Jigsaw World Tour on Nov 26, 13 10:57 PM
Exact---do you have the Ravensburger collection? Some of them are animated. Really good! I can't figure out how to unlock all the ones in free mode tho. Adventure mode is where the animated ones are and you have to do them in order. They start with 50 pieces and go from there. Jig Art Quest is really good too. The pieces are square. Hard!!
 posted in Nancy Drew: Ghost Dogs of Moon Lake on May 21, 13 1:12 PM
I'm in a played a little while but as with the last ND I played I find moving the character to be too frustrating for me. I am already lost in the woods, going around in circles. I don't think I will be playing this one.
 posted in Journey to the Center of the Earth on May 20, 13 11:02 AM
OMG!! I am frustrated almost to the point of giving up but I have come too far to do that. I cannot get her to go down the street she needs to use to get to the pharmacy. She needs to talk to Wallace so I can finish this blasted game!
 posted in Journey to the Center of the Earth on May 20, 13 9:35 AM
I found the phones, ginger. now I am in jail. Oh happy day!
 posted in Journey to the Center of the Earth on May 18, 13 10:17 AM
Did the developers play this game at all before it was released? Was there a Beta test of it? I have never been so frustrated with a game in my life. I really like the game itself but there are many issues with it. I cannot find the 4th telephone so I can deduce the phone number to call the guy at the communications center. I wish now I had just gone through the big door to fame and accolades!
 posted in Journey to the Center of the Earth on May 13, 13 4:48 PM
I need to be more clear about what I mean. There is no post puzzle, I meant the markings on the 6 posts you are supposed to use when you put numbers in then touch the mask. But Mr. Russ wrote that puzzle has been altered so that you don't have to do it 6 times. I noticed the door in the mine just opened but did not know why. But now I know it is because that puzzle has also been altered. I got through the door into the sub. I tried it over and over and one time it just worked. Going to quit for today, Jeopardy! time.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator