Posts created by maizijane

 
 
 posted in Mystery Tales: Dangerous Desires Collector's Edition on Oct 16, 17 10:29 AM
I am having the same problem! Is there a glitch in this game?
 
 
 posted in Vermillion Watch: Order Zero Collector's Edition on Aug 7, 17 2:51 PM
I can not get past this one so I am giving up for now. I think it's terrible that there is no skip option. I'm not fast enough to catch the green lights. Definitely frustrating!
 
 
 posted in Double Clue: Solitaire Stories on May 3, 17 12:34 PM
My game did not freeze but after a while it began dragging and messing me up. I am using Windows 8.
 
 
 posted in Silver Tale on Jul 28, 16 3:14 PM
Thank you, I'll try that.
 
 
 posted in Silver Tale on Jul 26, 16 1:36 PM
I have played level 197 umpteen times and still cannot get the silver flower. Does anyone know where the silly thing is???
 
 
 posted in Edge of Reality: Ring of Destiny Collector's Edition on Apr 30, 16 1:44 PM
I am anxious to play this game. I tried to Play it first but it would never open. then I bought it and the same thing has happened. Just get a black screen. I'm running Windows 10 ( and not lovin' it). what should I do?
 
 
 posted in The Hunt for Red Panda on Mar 3, 16 11:49 AM
I can not get the game to open. I am taken back to Game Manager and prompted to Play again. I have uninstalled an reinstalled bfgclient and still can't get it to play. I am using Windows 10. I was not given any error codes.
 
 
 posted in Aveyond 4: Shadow of the Mist on Feb 4, 16 2:51 PM
I wish I had not spent my last game coupon on this game. I have a terrible time trying to figure it out.
 
 
 posted in Elly Cooper and the City of Antiquity on Dec 21, 15 2:12 PM
I am in Chapter 1. When I put the forceps together they disappeared from inventory. am I missing something? I am unable to grab the thing from the fireplace.
 
 
 posted in Demon Archive: The Adventure of Derek on May 25, 15 2:24 PM
I agree with all of the above. I regret using a credit on this one. Frustrating.
 
 
 posted in Mythic Wonders: Child of Prophecy Collector's Edition on May 24, 15 3:44 PM
I'm having the same problem with it freezing. I am at the part where i need to free Nobu, but the items I need are not in inventory. The hint tells me to go back but I can't.

I love these oriental games as their culture is so beautiful. Wish I could go there!
 
 
 posted in Revived Legends: Titan's Revenge Collector's Edition on Jan 4, 15 12:40 PM
The red cloth you put together needs to be stapled. Then give that to the Imp at the top of the pole and he will open the sail. Imp will fall back into your inventory.
 
 
 posted in Revived Legends: Titan's Revenge Collector's Edition on Jan 3, 15 1:00 PM
i've uninstalled and re-installed. Still no little imp.
 
 
 posted in Hidden Memories of a Bright Summer on Dec 19, 14 1:46 PM
I have played this game before and forgot that I did. It is definitely boring and some of the hidden objects are very obscure. My old eyes were being strained too much. I don't recommend this game.
 
 
 posted in Hidden Object Crosswords 2 on Dec 18, 14 1:37 PM
On Level 31, when typing the S in Scorpio, the system will not accept the S. Must I uninstall and re install? That gets old after a while.
 
 
 posted in Hidden Object Crosswords 2 on Dec 17, 14 2:39 PM
Same problem. Help?
 
 
 posted in Mystery Castle: The Mirror's Secret on Oct 8, 14 3:05 PM
Problems here, too. I get Fatal Error: KernelBase.dll. Code 0xeo6d7363; address 7729c42D in thread CFC. I have no idea what all that means,but it frustrates me.
 
 
I was able play the Demo without issue but when I tried to download the full game, my computer bombed telling me there was a dll error. I am running Windows 7 and I wonder if this game is not compatible with it. It says it is but it may not be. At any rate, I would like to have it fixed or get a refund.
 
 
 posted in Witch Hunters: Full Moon Ceremony on Sep 3, 14 3:01 PM
I uninstalled this game and re installed it. Has anyone been able to complete the game without a glitch?

Please ask DEV to post an update fixing the bugs, please!
 
 
 posted in Witch Hunters: Full Moon Ceremony on Aug 31, 14 2:47 PM
I am having the same problem in SE version.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator