Posts created by BethThomlinson

 
 
I'm about to play the bonus chapter. I can't find any indication of any collectibles in this chapter. Morphing objects or words. Are there any?
 
 
Thanks. That did the trick. I had to turn that switch so all the lights were off.
 
 
I am stuck in the middle of the jukebox puzzle. I can't get the record jukebox controls to be activated.

I got the fan to go through the pipe to melt the ice. I got the horn to blow the dart to the upper right. I got the champage bottle to pop. I got all 4 musical notes and the center rectangle opened to show 2 halves of records. But I can't get the controls to work.

I tried flipping the red arrow controls so they connect power (string of lights) to the central power (the one that looks like a searchlight, right?). I tried having the power go different ways - up to the top, over to the horn, and stopped in the middle. I tried having the loudspeaker switch both on and off. Nothing makes a difference. When I press any of the jukebox controls, it just thunks at me and the central control blinks red. What am I doing wrong?

I did the puzzle in a different order from the walkthrough. I did the fan and pipe first, then the champagne bottle, then the horn. Does that make a difference?
 
 
 posted in Murder, She Wrote 2: Return to Cabot Cove on May 28, 13 2:00 PM
In the first game, I got to the cipher puzzle but I guess I don't have the cipher. It won't let me do anything. I opened the cipher screen but just have spinning gears telling me I need the cipher. I can't leave the cipher screen except to close down the game completely.

I hope you don't tell me I have to create a new profile and play the entire game over again to get to that spot. And what happens if I get there again withouut the cipher?

How do I get out of this vicious cycle?
 
 
 posted in Clutter II: He Said, She Said on Jun 3, 12 8:23 AM
This crash happens when playing the window shade mii-game where you have to slide the picture segments left and right, then up and down to assemble the picture. When in the second phase of the game, when sliding pieces up and down, if I slide a piece up too far so that it goes above the puzzle area, the game crashes with an access violation error.

This happens on multiple window shade puzzles. It is 100% reproducible on my system. I DLed and installed the game on 5/29/12.

The last time I got the crash, the error message said:
Access violation at 0x00488A90 (tried to read from 0x000005F3). Program terminated.
 
 
 posted in The Missing: A Search and Rescue Mystery on Aug 24, 11 8:26 PM
It took me a little over 2 hours playing in easy mode without using more than a couple hints. It was an interesting story, but much too short for me. I agree with others that an SE game should be at least 3 hours of play, and a CE should be at least 4-5 hours.
 
 
 posted in Dracula: Love Kills Collector's Edition on Aug 5, 11 4:05 PM
In the bonus gameplay, there is a puzzle with bats (this is not a spoiler). I have played lots of times, but I can't figure out a strategy to win. What opening moves or other strategy advice can anyone give me?

The SG is no help in this case, as it just shows you a finished game. And there is no walkthrough I can find for this that would give advice.

Thanks, fishies!
 
 
 posted in Once Upon a Farm on Jan 6, 11 8:35 PM
I agree with so many other folks that this game is a waste of time.

1. Objects with wrong names. A brush when it asked for a comb; a trophy when asked for a bowl, etc.

2. Some of the worst racial stereotyping I have seen in a game in a long time.

The game developers need to know that correctly labeling items in an HOG is essential. And having 4 wrong items in 3 screens is beyond tolerable. Developers also need to know that most people will not put up with racial stereotyping.

I played for less than 15 minutes before these factors made me quit and uninstall the game.
 
 
 posted in The Institute - A Becky Brogan Adventure on Oct 13, 10 8:33 AM
I agree with all the other posts that this is not a keeper for me.

- Scenes are very blurry. Since the sample graphics on the Web site have nice, crisp graphics, this seems like deceptive advertising

- Tiny objects hidden behind other objects. I couldn't even find everything in the third scene, including a bear. That was after mad clicking everywhere in the scene.

- All hidden objects, over and over

- When there is a break from these, find the differences in 3 variations. Seriously? The worst kind of game for this audience, and they specialize in it!

I am desperate for a good, new game, but this is not it. I would not even use a free credit on this game, let alone purchase it.
 
 
 posted in Twisted Lands: Shadow Town Collector's Edition on Oct 11, 10 3:33 PM
I have a different but related problem with the bonus game. I was able to retrieve the punch card, but I put it into the slot in the machine upstairs instead of the telegraph machine downstairs. Now I can't get it out of the upstairs machine, and the downstairs machine tells me it can't proceed without a punch card.

This is very frustrating! I'm sure I made a mistake in putting the card in the machine upstairs, but it should allow me to back out of the mistake. Now I can't finish this bonus chapter without creating a whole new profile and finishing the game again.

And I, too, have gotten blank cutscenes for the bonus game and the last scene in the regular game. I will write to BFG support, but if anyone has a solution for the punchcard problem, please let me know.
 
 
 posted in Vampire Brides: Love Over Death on Oct 3, 10 9:09 AM
You all have listed most of mine, especially horseshoes, lizards, butterflies, feathers, and disgusting bugs and spiders.

But nobody has mentioned another overused item: binoculars! At least you can use binoculars almost everywhere. Although I have never had a HOG tell me "You have found a useful item: binoculars." You'd think some game somewhere would actually use binoculars for something. Oh well.
 
 
 posted in Goddess Chronicles on Oct 2, 10 12:57 PM
I"m stuck in a room with statues pretty near the beginning. It has two areas where the cursor changes to the gear, but I can't find what to do. There is nowhere else to click, and I have nothing in inventory to use. One area is on the floor in a circle in the middle of blue flames; the other is a round area on the door in the back.

Help anyone?
 
 
 posted in Columbus: Ghost of the Mystery Stone on Sep 30, 10 8:04 PM
I was having the same problem, but I finally accidentally clicked on the 19th area. On mine it turned out to be the waves just under the center of the ship. They have to be painted white.

Hopefully this will turn out to be the same one everyone else misses!
 
 
 posted in Haunted Hotel: Lonely Dream on Aug 31, 10 9:12 AM
I like the demo--got through 4 levels. Yes, the background music and sounds are annoying and the plot is weak, but I don't buy the games for music and plot. When a game has a really great plot, that is often part of what makes it an outstanding game.

This game is more of an adventure game with a couple of hidden object scenes at each level. There are only occasional duplicated scenes (1 so far in the first 4 levels). It has excellent graphics and a variety of mini-puzzles that I like. They are not difficult, but they are engaging.

I'm not fond of the garbage pile type of hidden object scenes, so this aspect is a negative for me, but that's the way most HOGs work. At least the good graphics make them more appealing.

All in all, it's a good but not great game. When you figure that there will be very few truly great games, I'm not disappointed when I get one like this. I need one more game to fill my punchcard this month, and it's the 31st, so I will buy.
 
 
 posted in Robin's Quest: A Legend Born on Aug 20, 10 12:48 PM
How many gold pieces are we supposed to have after finding all the caches? I know there are 38 caches. I found all of them. I had 1610 gold pieces at the end, but the walkthrough final screenshot showed 2510 gold pieces. Since I found all 38 caches, why do I have less gold?
 
 
You have to use the crowbar (although I'm assuming you already did), find and place the piano keys, and then do another **** scene to find the bas relief.
 
 
This might be something you should contact Support about.
 
 
The key is for a chest that you won't get to until much later. Use the crowbar up high to get out.
 
 
 posted in Journalistic Investigations: Stolen Inheritance on Aug 3, 10 2:47 PM
I finished 5 chapters out of 12 in the hour demo. That combined with the bland graphics and puzzles make it a no-buy for me. There is nothing really wrong with it; I think it's actually well designed. But I agree with tropdechats (on the review thread) that this is a good game for beginners. I prefer games like Ravenhearst, Nightfall/Asylum and Redemption Cemetery.
 
 
It's past the Town Square by the broken bridge. Did you notice a lamp there? Zoom in on it.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator