Posts created by txpeach100

 
 
 posted in Incredible Dracula IV: Game of Gods Collector's Edition on Mar 16, 18 12:00 PM
Just found it. The rail factory is just above the tool factory.
 
 
 posted in Incredible Dracula IV: Game of Gods Collector's Edition on Mar 16, 18 11:58 AM
I'm having the same issue. I've checked everywhere. There is nothing I can make that looks like tracks.
 
 
 posted in Scarlett Mysteries: Cursed Child Collector's Edition on Mar 12, 18 9:23 AM
In the Bonus game, I clicked the Ideas tab and put the pieces all together properly & received a plan but I cannot leave this scene. Clicking back does nothing at all. I don't have the rope or the clamp to put the whole thing together. HELP, Please!
 
 
 posted in Incredible Dracula IV: Game of Gods on Mar 9, 18 2:28 PM
I've repaired all the pyramids, opened two gates and have no more to open. It says to put my answer in the bowl but I'm not sure how to do that.
 
 
Athenatoo wrote:The technical aspects of the game are fine (art, music, hints, etc.) but whoever is writing the text clearly does NOT speak English. This grew progressively worse as I played the bonus game. (I need some pruner??????) Some of the so-called "helpful texts" were English words strung together with no meaning . If you are going to sell games to an English-speaking audience, then for heaven's sake, PROOFREAD. I am playing a game, not devoting time to trying to understand illiterate texts.


I wholeheartedly agree! The bonus game drove me crazy with the "I need some" hints like I need some hammer. Aargh!
 
 
 posted in Halloween Stories: Invitation Collector's Edition on Oct 13, 17 1:44 PM
I am having the same issue as some others. After I cover Joe, the screen becomes black and never loads the next screen. By quitting and restarting the game, I get the new room to show up but no interaction with anything is available. I did update my graphics driver. If I run in administrator mode, I have to restart the game and I'm prefer not to. I've tried a few other things on your Trouble shoot page but so far, nothing has worked.
 
 
I'm having a completely different issue. At base camp, in the tent, there is a recipe that uses the wax from a previous location and a jar of stuff. then you are suppose to fan the fire with the pink fan. I put in the ingredients and try to fan the flame (yes, the stove door is open) but it keeps telling me "Let's sort everything else before fanning the fire" So I cannot proceed

I do not have the upgrade to this game and it has never appeared in my BF app. When manually checking, it just keeps checking and checking for ever!
 
 
 posted in Dark Romance: Curse of Bluebeard Collector's Edition on Oct 17, 16 7:33 AM
I was able to put the harpoon and rope together and shoot it across the chasm. However, there is no rope over the chasm for me to cross. When I now click on the cross bow, it shows me a close up of the tree on the other side of the chasm and says I need to find a harpoon and rope to cross.

When I click the hint button in either the hut or outside, it highlights the lower left corner of the screen, where nothing is clickable.

Frustrating!!!
 
 
 posted in Dark Realm: Lord of the Winds Collector's Edition on Sep 7, 16 9:42 AM
I have the spear and the leather straps together but the game keeps telling me I have more to do with it yet nothing in my inventory works with it. What am I missing?

Thanks!
 
 
 posted in Flip Words 2 on Aug 31, 16 6:40 AM
The game has the following quote:

"I only regret that I have but one life to give to my count"

Obviously, the game cut off the ry from country. And the real quotation is one life to LOSE not give
 
 
Thanks so much! I would never have figured that out. My inventory shows blue, green & read already.
 
 
I have gotten 3 cans of paint. Green from a HOP, Yellow from the raven tombstone and the Blue one from the bag on the chair in a different scene. The game says I have 2/3 so I can't move forward. Any suggestions?

Thanks!
 
 
 posted in Aveyond 4: Shadow of the Mist on Apr 16, 16 11:10 PM
Thank you so much! I felt like I had lost my mind! I wish they would put these small details in the game for directionally challenged people like me!
 
 
 posted in Aveyond 4: Shadow of the Mist on Apr 16, 16 10:29 PM
I have Fang. I have the resize recipe. I now need to get the grubs. But I can't find Whispering Wood. IRL on a great day I can get lost in a paper bag. In game, it's a constant struggle!

Thanks!
 
 
 posted in Aveyond 4: Shadow of the Mist on Apr 16, 16 8:31 AM
I've talked to both blacksmith's in Halaina. I've seen the rock with the pink cloud in the cave but I don't have a pick axe. Where can I get one?

Thanks!
 
 
 posted in Mystery Tales: Her Own Eyes Collector's Edition on Feb 28, 16 3:16 PM
Does anyone know if the stupid death files are true or just made up. I found them rather interesting
 
 
 posted in Midnight Castle on Jan 1, 16 9:17 AM
I started playing the game in the middle of the Christmas event. Do the items I've collected this year stay in my inventory? If I was in the middle of an achievement, for instance 163 out of 200 snowflakes collected, do I pick up from there next year or do I have to start over?

Thanks so much!
 
 
 posted in Midnight Castle on Dec 23, 15 3:59 AM
NikkinBrandon1 wrote:please add me 53681. Thank you! I'm at level 10 but I am a daily player!!!


I tried to add you but the game found no matches. Are you sure that's your code?

 
 
 posted in Midnight Castle on Dec 22, 15 5:37 AM
Just started this game and trying to figure out all the aspects. Would love to make new friends. My code is 537636
 
 
I can get through to the initial loading screen but then the games freezes. No joy.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator