Posts created by sewrightcat

 posted in Legendary Slide on Mar 25, 18 4:14 PM
I'm stumped on this level! I don't know where to start. Is there a way to get tiles "un stuck"? I have several of these stuck in different places. I can't move tiles to the places I need them to be to take them out. A step by step would really help! Anyone?
 posted in Legendary Slide on Mar 11, 18 11:05 PM
Finally!! I actually got through it! The things that helped me the most were the, start 2 tiles from opposite sides to stop somewhere in between (this takes a little practice) and figuring out short runs of the elevated tiles to keep from having to build a bridge all the way across the floor. In the end the only ones I could keep elevated were the tiles I needed to unfreeze the three ice blocks. I also made sure to choose a pair that I could position to become the gold tiles so that one slide would take them out.
 posted in Legendary Slide on Mar 9, 18 11:53 PM
Does anyone know how to finish level 32? I have tried a bunch of different strategies and have actually gotten down to the final gold tiles a couple of times. The problem I keep running into is that when I get to the gold tiles I have one trapped in the side alcove and the other is trapped in the main field. I have not found a way to get them in the same field at the same time. Am I missing something? I'm starting to think I'll never finish this level. Help!!
 posted in Dark Romance: Romeo and Juliet Collector's Edition on Mar 17, 17 9:07 PM
Never mind. I figured it out. You have to use the weights on both sides of the scale.
 posted in Dark Romance: Romeo and Juliet Collector's Edition on Mar 16, 17 5:18 PM
I am stuck on making the somewhat elaborate potion in the hut in the stone forest. The recipe calls for 4.5 grams of ground fire pearl but I can't make that happen with the weights the game gives me. The game gives me two of the 2.5, one of the 1.5 and one of the 1 gr. So, unless grade school math has failed me somehow, I can't get 4.5 out of this combination of weights. Is there another one I haven't found yet? Or, am I missing something else? Help, please.
 posted in Moai: Build Your Dream on Jun 21, 16 6:23 PM
I have looked at several threads now and no one is talking about the pesky ghosts. How do I get rid of them? I read somewhere that you only need to click on them three times to get rid of them, but three clicks doesn't seem to do more than annoy them. They still destroy my farms, quarries and markets! I know the statues help but I usually don't have enough resources at the start of a level to build them early on. I'm sure I could get three stars on most levels eventually if I didn't have to be on ghost patrol all the time. Any suggestions, help or "duh" moves I'm missing?
 posted in Nevertales: Legends Collector's Edition on Oct 24, 15 8:34 PM
Never mind. Figured it out.
 posted in Nevertales: Legends Collector's Edition on Oct 16, 15 5:07 PM
Can anyone tell me how to "select" the fire poker in the historian's room? The strategy guide says to select it, then remove the tea pot and S hook so that you can light the lantern. I have clicked all over this scene and can't get the little magnifying glass to zoom in on the fireplace. Is it possible I missed something along the way and I should have it in inventory? I've looked back through the strategy guide to see if I can spot where I may have missed it but I can't find anything. Help please!
 posted in Sable Maze: Twelve Fears Collector's Edition on May 29, 15 6:07 PM
It's possible there's nothing anyone can do to change it. I've noticed that when I send some email messages, and the other person replies back to me, I will see these other characters in my original message to them. I don't know why it does this, but I know I didn't put them there.
 posted in Cubis Creatures on Nov 17, 14 6:56 PM
Has anyone been able to get through this level with all 3 stars? I am stumped and frustrated. If anyone has a special strategy or tricks to get through this level, would you share, please?
 posted in Fishdom 3 on Mar 31, 13 6:45 PM
I've been reading in a couple of other threads that people are as frustrated with this level as I have been. The problem is that when you clear the wooden tiles in the center of the grid, the dynamite naturally goes to the left because there is nothing there to stop it. So, what I discovered is that if you start clearing the left side of the grid first, staying away from the wooden tiles for now, you will eventually fill up the empty squares on that side. Then go up and break the wooden tiles and the dynamite will fall to the right where it blows up the jeweled squares. Then dirt covered squares on the left side don't need to clear to finish the level. You may have to try this a couple of times because we all know what happens in a chain reaction when things can happen before we want them to.

Hope this helps!
 posted in Awakening: The Skyward Castle Collector's Edition on Oct 12, 12 1:43 PM
I went back to the map to look again. I moved the mouse around the area of the windmill until I got the caption that said Crystal Forge. It was a little above the windmill and I noticed that now I had an "up" arrow. Clicked when I saw that and arrived at the Crystal Forge. I do agree that this game seems to have been rushed in development because there are a few glitches like this one. Still love the series though.
 posted in All My Gods on Apr 18, 12 5:12 PM
Is there a specific route you need to take to get this to register as a complete road? I have shifted buildings to make absolutely sure I have every square covered. I have run the road around three sides of the magistrates hall just in case. Am I missing something else?
 posted in Super Granny 6 on Apr 6, 12 7:26 PM
Just a quick comment because I have to get it off my chest. I HATE that stupid pterodactyl with a passion! Whew! I feel better now .
 posted in Super Granny 6 on Apr 6, 12 7:21 PM
I, too, was thoroughly frustrated with this level. I searched the forum for any help I could find. I finally got a method that worked for me so I thought I would offer some tips.

The first thing you need to do is get that stupid blue pterodactyl down to the middle screen. Just stand next to the switch to go to the next screen, wait for the idiot bird to be level with you and switch screens. Then go down a couple ladders, wait for him to catch up with you, then go back up to the top screen.

When you get to the blow torch platform wait until the bats are in a position that they won't kill you on your way back to the switch.

Use the ladders to descend--DON'T FALL--the ladders are actually faster and when you reach the ladder above the switch you can hit the space-bar while still descending.

As soon as the screens start to move hit your right arrow key so that Granny is facing the right way.

On the middle screen the fall is the faster way to go. Also, while falling hit the left arrow key. Walk to the switch.

Again, hit the space-bar and then the right arrow key as the screens switch.

Use the ladder to get down from the platform and run to the drill. You should get there with 2 seconds left on the torch.

If you don't have 2 seconds you will probably have to start again. But this method works for me every time I do it.

 posted in Royal Envoy 2 Collector's Edition on Dec 29, 11 8:27 PM
My question about this level is this: What does the $100,000 ransom get you anyway? I have tried playing this bare bones by just collecting rent to add to the treasures to earn that much gold but I run out of time at around $60,000.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator