Posts created by bachlein

 
 
 posted in Egypt II: The Heliopolis Prophecy on Dec 12, 09 10:52 AM
The drums have a little syncopation...right, right, left, SLIGHT pause, right, left. (At least that's how I remember it.)
 
 
 posted in Egypt II: The Heliopolis Prophecy on Dec 12, 09 10:49 AM
I'm having the same trouble. Did you ever figure it out, or did you have to reload a game before you traded the beer?
 
 
 posted in Samorost 2 on Dec 8, 09 12:30 PM
I have tried and tried to get him unstuck from his parachute, but it won't happen. Exactly WHERE should I click on that second swing? Never mind, I "reentered" that chapter and got unstuck BEFORE I took care of the taxi baby. That did the trick.
 
 
 posted in The Secrets of Da Vinci on Nov 18, 09 12:26 PM
I have the honey syrup, but when I close the door, it says that the fire is not hot enough, but it won't take leaves, logs, or charcoal. So, of course, the water to cool it doesn't work, nor does the cup and saucer to receive it. I am really frustrated!!
 
 
 posted in Nick Chase: A Detective Story ™ on Nov 5, 09 12:28 PM
I just can't seem to get anything constructive done before the car starts up and comes to a blockage. The randomness of the roadway pieces is very frustrating.
 
 
 posted in Drawn: The Painted Tower ™ on Sep 11, 09 1:05 PM
I loved this game. The scenes were interesting, the music didn't get on my nerves...even when I was stuck someplace and the same music played over and over. I loved how you could ask for a hint, but it wasn't too much information to take away the fun of solving the puzzle yourself. There was only one time that I had to visit the blog walkthrough for the answer...and then when I saw what the answer was, I realized how my thinking about the puzzle was entirely wrong! I'm an (almost) 70 year old grandma. I'll keep this one for my grandkids to play when they come visit!!
 
 
 posted in Dream Chronicles: The Chosen Child on Jul 1, 09 7:01 PM
OOOOooooohhhh!!! THANK YOU.
 
 
 posted in Dream Chronicles: The Chosen Child on Jun 30, 09 4:02 PM
I must be terribly stupid, but I can't find the main menu button anywhere...and I presume that the save and exit are there. I had to start over with my granddaughter because I couldn't save. Happily we had just started the game.
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jun 26, 09 3:27 PM
I'm having the same problem. I went to Gameboomers and printed out the first four pages of the walkthrough and went step by step. And still he won't go out. I have noticed that the floor plan has disappeared...there's only the map of London. The only thing the walkthrough says that I couldn't do was "notice the footprints on the floor and where they lead to." But I'm not sure if Holmes says anything about them...and there is nothing to indicate that I should use the magnifying glass here. I AM VERY FRUSTRATED!!! i, too, have played a number of these games, so I'm not a novice, either.
 
 
 posted in Samantha Swift and the Hidden Roses of Athena on Jun 2, 09 5:15 PM
I couldn't figure out how to exit the game when I was in the museum. Do I need to be IN the game and exit from there. And how do I save?
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Mar 10, 09 2:26 PM
I put the numbers 1 through 17 in order, the glass where the beating heart is broke, but beyond that nothing happens. AND THEN!! when I go back to it, the numbers are all mixed up again. I tried turning the faucet handles and pushing the injection stuff.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator