Posts created by nantyglyn

 
 
 posted in Hawaiian Explorer 2: Lost Island on Nov 2, 08 10:07 PM
I tried the demo - but could find no way to pause it, and no way to stop it - no quit or exit. Even when I ctrl/alt/del it doesn't come up in the Windows Task Manager. If I right click on the game in the task bar (to be able to close it), it just starts running again. I think I'm going to have to try uninstalling it while it is running (don't want to continue the demo - didn't like it).
 
 
 posted in Crazy Machines on Sep 16, 08 9:55 PM
Incredible Machine is old, yes - but the kids in the computer lab still play it, and love it. It's timeless. There are more than two - I think there are three or four versions of it. The graphics may be simpler, but the physics aspects of it, and the "fun" aspect, as someone said, are much better.

I had to shut the professor off on this one. He was obnoxious.
 
 
 posted in Crazy Machines on Sep 16, 08 3:06 PM
Yes - this is the same idea as the Incredible Machine (also called Contraptions). My students in my computer lab played many, many hours of this educational game. But this one seems cruder - not as intuitive, not as logical. I don't think it's as well thought out as the Incredible Machine (which I, also, spent many hours playing). There aren't enough directions or explanations.
 
 
 posted in World Mosaics on Aug 18, 08 10:35 AM
ddebbievt - welcome to the pond! Come join us often.

There is a whole category of games called "picture solving puzzles" out there. They don't have the storyline of a game like Gemsweeper, but they have tons of this type of puzzle. I can't give you the address, but if you google Conceptis and puzzles you'll find a whole new universe of this type of puzzle, and more. They're not games - they're puzzles. I think they're a lot of fun. If you try it, let me know what you think.
 
 
 posted in Mystery in London ™ on Aug 18, 08 9:48 AM
I got this awhile ago, I don't like 360 games too much, but for some reason I got this one. I thought it was well done. I don't remember too much about it (OB syndrome), but I do recall that my reaction was positive.
 
 
 posted in Azada ™: Ancient Magic on Aug 14, 08 10:05 AM
Smallhaven - the pink pip tail looks good on you! You go, girl!
 
 
 posted in Rooms: The Main Building on Aug 10, 08 11:12 PM
Just played most of the demo. I think the problem is that it is not explained at all, and not intuitive. What was frustrating was not understanding what to do. It might be fun but was frustrating because of that. The help screen didn't help much, and the timer kept running while I was trying to read the help. I think it could be a fun game if it were explained better. I don't think I'll get this one because of that.
 
 
 posted in Hidden Expedition: Amazon ™ on Aug 7, 08 10:49 PM
I have no idea what my score is. I never pay attention to the score. I've played it through twice. I guess it would still have my scores saved. I'll have to go back and check.
 
 
 posted in Azada ™ on Jul 26, 08 9:40 PM
I don't know if this will help, but I seem to recall that you can't raise it up after you grab it - just slide it along the bottom and onto the chute. I think that's alI I did. Wish I could be more help.
 
 
 posted in Virtual Villagers: The Secret City on Jul 26, 08 9:19 PM
Sara2 - go to the "All Games Forums" tab at the top of this page, then go down to Virtual Villagers Secret City. That's the forum for that game, and people there should be able to help you. Good luck!
 
 
 posted in Azada ™ on Jul 26, 08 3:28 PM
tulipII - you need to practice with the controls on the front of the tank. One moves the "claw" to the right, one down, etc. You need to practice to see what each one does, then push them in sequence to get the claw to pick up the crystal and move it to the left and then drop it in the chute. Some of the controls may need to be pushed more than once, as, for example, each push may only drop the claw a short distance and you may need two pushes to drop it far enough down to reach the crystal. It's been a little while since I did that one, so I hope I explained it well enough. Good luck!
 
 
 posted in Azada ™ on Jul 25, 08 11:28 AM
DIAGONAL? I had no idea! I'm sure that will help immensely. I was always getting down to four okay, but not beyond that. Now I'll have to go practice. Thanks - that was a BIG tip!
 
 
 posted in Dream Day Wedding: Married in Manhattan on Jul 24, 08 9:43 PM
Okay, I just played half the demo - too tired to play anymore tonight. It's cute and easy to play. I like how they use the Chrysler Building as their "transition" between scenes (you know, that building where the top lights up?) I used to work right across the street from that building - many, many long years ago. And the subway scene is authentic. The car itself is a little too clean, but the sounds are true to NY, and the scene outside the car window is the true station, so that brings back memories. I'll finish the demo tomorrow.
 
 
 posted in Azada ™ on Jul 24, 08 8:59 PM
GinaBean wrote:Nanty, I'm not sure which one you're talking about. Is it the one where you're supposed to make squares against the computer? Or maybe the "pawns"?

It's the "pawns". The making squares one is really easy. Any hints for the pawns?
 
 
 posted in Dream Day Wedding: Married in Manhattan on Jul 24, 08 8:49 PM
Isn't chocolate one of the basic food groups?
 
 
 posted in Forgotten Riddles: The Moonlight Sonatas on Jul 18, 08 9:43 PM
I like this game, too. I like the riddles, some of which really made me think. But I agree with both Gina and Cesse that I really disliked the part where, if you got a hint, it didn't tell you what to do - it just did it. That was most annoying - how are we to learn? But I did enjoy the minigames.
 
 
 posted in Sherlock Holmes: The Mystery of the Persian Carpet on Jul 13, 08 4:24 PM
To HighlandMax again- I worked with tech support until we could do no more - could not get it to run on my computer. We gave up. Tech support thinks I need an updated driver, but the driver company will not let me download one, and my computer manufacturer (Dell) does not have the latest driver on their site, so I'm dead in the water on this game! Good luck to you.
 
 
 posted in Sherlock Holmes: The Mystery of the Persian Carpet on Jul 11, 08 11:30 PM
HighlandMax wrote:I gave up on this game. I un-installed it and re-installed at least four times, and still there is no sound, I can't get out of the cement factory. And the last time I tried it again, I couldn't even exit the game. I ended up having to turn off my PC. Something is bad wrong with the game.


HighlandMax - the game worked fine on my computer until I installed the updated version. Now I also get stuck in the cement factory and have to ctrl/alt/del to get out of the game. I can't even do anything in the cement factory. Sounds like we are having the same problem. I've contacted tech support. They gave me some things to try but nothing worked. I'm waiting to hear back from them again. I feel your pain!
 
 
 posted in Azada ™ on Jul 9, 08 9:28 PM
Now I'll sart playing Azada again to get myself back in the mindset.
 
 
 posted in Sherlock Holmes: The Mystery of the Persian Carpet on Jul 8, 08 11:14 AM
Super unfortunately, I cannot play at all now. It's not just a minor glitch. I'll have to contact technical support. Bummer! At least it worked before I reinstalled.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator