Posts created by cjpandie

 
 
 posted in Art of Murder: Hunt for the Puppeteer on Apr 14, 10 1:35 PM
[b]I can't say I hate this game but don't understand it. I couldn't get through the first one after buying it. But figured I can always go back and finish it later, when I run out of other games to play. I probably won't buy this one at least till I finish the first. I too felt like I was running around in circles and didn't get very far without the first walkthrough, so I would need the walkthrough for this one also. I do love the graphics. And after getting the dialogue going it was pretty good. Sure not your typical love story is it?
 
 
 posted in Mind's Eye: Secrets of the Forgotten on Apr 12, 10 2:06 PM
That link doesn't work!!! Darn it
 
 
 posted in Dominic Crane's Dreamscape Mystery on Apr 8, 10 11:34 AM
tuttepeever wrote:I found this to be totally frustrating and quit with 15 minutes left. Received items that didn't have a name and didn't know what to use them for. I could have used a Walkthrough for this one. The graphics were just okay but wish there had been some more instructions as to where or what to do next. This is the 3rd night in a row that I am disappointed. I guess we all have our preferences but this one is definitely not for me. I'm sad since I really need something new.


[b][i]I have to say I agree on most points against this game. I haven't quit yet, but if we don't get the walkthrough soon, I will. I have no idea what the object of this game is. I do like the graphics but have a hard time knowing what to do with them. I get censured for clicking too much, but there's no explanation of intent.
 
 
 posted in Hidden Mysteries: The Fateful Voyage - Titanic on Mar 31, 10 2:00 PM
[b]I have never commented on any game before. but this one is rediculous. Too hard to figure out what you are suppose to be doing.
 
 
 posted in Hidden Mysteries: The Fateful Voyage - Titanic on Mar 31, 10 1:58 PM
susielee wrote:This is not for me. I didn't like it at all. The graphics are not crisp and clear - more fuzzy and grainy. I hate all the clicking on people to get them to talk. The game is very confusing. You really need the walkthrough to carry you step by step because there's no clue what you should do.
 
 
 posted in Rhiannon: Curse of the Four Branches on Mar 5, 10 8:37 AM
[b]I have never had much success with this type of game before but, thought I would try again. And I have run into some problems with this one too. If I can't get some thing to go as the walkthrough says it should I go back and think, what haven't I done and that usually takes care of the problem. However, I have run into a problem getting into Rhiannon's room. When I first clicked on it, it let me in and threw me out. Now I cannot get in there. I have clicked on the letters that it tells me to, repeatedly but nothing seems to work. I have checked out all the outside areas that I can find and gone in and out and still cannot get into that room. I need those diaries, I know to get anywhere. So I will keep trying and possibly complaining untill I either get tired of the game or find a way in.
 
 
 posted in Mystery Age: The Imperial Staff on Feb 6, 10 9:47 PM
I cannot find the last piece of the harpoon. Hint tells me to go to mini puzzle, which I already skipped. Where do I find the last piece of that harpoon, I do need it to shoot at the octopuss don't I?
 
 
 posted in Penny Dreadfuls: Sweeney Todd Collector`s Edition on Feb 3, 10 11:50 AM
The walkthrough says to use the fishing rod on the item under the water at the wharf. It won't stay there and it won't pick anything up. Tried and tried. Really kind of disappointed in such an expensive game not working right. I have spent many a dollar on this game site, You'd think they would work right. Anybody have this problem, and did you resolve it? Help!!!
 
 
 posted in Kuros on Sep 11, 09 8:43 PM
I am having trouble finding the last shell to open the mini game. I have clicked and looked and looked and clicked. I find nothing. Any help anybody? And the walkthrough doesn't give locations of all the parts you need to find. Why not?
 
 
 posted in Mystery Masterpiece: The Moonstone on Jul 26, 09 1:17 PM
You have to also use the magnifying glass on where it looks like it is a pocket. It is on the lower right part of the gown.


I have seen the letters and the area that was cut out and the detective says he needs to analyze the stain. How do we do that? That is what is holding me back from going on in the game. There are no tools that help with that. I have the magnifying glass, tweezers, and the key. Didn't collect anything else and the other areas are done. Help!!
 
 
 posted in Syberia on Jul 20, 09 4:26 PM
elemare wrote:Right click to get your inventory screen. At the top is MENU. Click it and click SAVE. Another screen open that says NEW SAVE. Click a blank (black) screen and hear a "clink" - you've saved!

That doesn't work. I hear the clink, but go back to play and have to start all over. So I fast forward as much as possible, but as I get farther into the game that gets tiring. Thought it was suppose to show a time and picture when you clicked in the blank boxes? I have contacted Tech Support. Hope they can help don't want to have to redownload it. It took forever to download the first time.
 
 
 posted in Syberia on Jul 18, 09 8:07 PM
gojojogo wrote:To save the game you need to click on an empty, black square. Then it will be saved with a picture and the date and time.

That did not work for me and I just know I will have to go throught the whole game again up to the point where I left off to figure it out again. Darn it!!! Is there a trick to that, saving the game I mean?
 
 
 posted in Mystic Diary: Lost Brother on Jul 17, 09 8:25 PM
[b]How are you suppose to get a hotspot to open up. I have clicked repeatedly on them and nothing happens. What am I doing wrong. I have found both the pliers and screwdriver. They aren't doing me any good sitting there and I can't find any use for them.
 
 
 posted in Book of Legends on Jul 13, 09 2:50 PM
I'm ready for part 2. Anyone get an answer to when it's coming out?
 
 
 posted in Righteous Kill on May 28, 09 3:55 PM
[b]The only problem I have had so far in Righteous Kill is trying to click on an item on the list and the game not acknowledging that I am clicking on it. This file you are talking about, where is it and how do you get to it? This is the only game I've had trouble with in BFG. And I paid for the game, would like to play the whole thing. Darn it! How do you contact Tech support without going through all their question things? There's got to be a way to type in your problem. Any body give me help? Thanks
 
 
 posted in Nick Chase: A Detective Story ™ on Feb 18, 09 9:50 AM
[b] This is probably so simple but, I get the analyzer built, don't know how to do the liquid solution. And also something about the regent. Does it have to be at a certain setting to let you go on?
 
 
 posted in Escape the Museum on Jan 29, 09 8:16 PM
I can't find the darn gas valve. Give me a clue as to where to look. Please. Thanks
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Jan 27, 09 7:47 PM
[b] I really enjoyed this game. It was a big challenge. I would not have made it without the little helps I got. But I love most hidden object games.
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Jan 26, 09 8:07 PM
[

"When you go into that room it is dark so you use the matches to light the kindling. Then you have to complete 3 orange and black puzzles held by gargoles.

When you complete those puzzles the twins coffin rises and you click on it to open it. The twins coffin opens and a video runs of the twins. They come out and tell you about Victor.

Only after the video of the twins can you find the "R" key for the typewriter in a hidden object game in the Toy Store and then you can open the 3rd door in the red hallway.

I hope this helps.
""

Ok is there a cheater for these puzzles? I do not want to skip them all. I do not know how I managed to get through that door, but I did it. I guess I just don't have any patience to go through all that over and over. Darn it.

Well, I guess I found a cheater. Never would have gotten it on my own. On to the toy store to go on with this. Thanks for any help.

 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Jan 26, 09 2:36 PM
I found the room at the bottom of the well. Just not fast enough to get the door open. Most likely will have to skip that puzzle. I need to get something in life done besides this game. But it is addictive. cj
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator