Posts created by jaldeer

 
 
I woke him up the 2nd time playing. Yes, the bone is suppose to be right next to the steps of the apothecary. When you give him the bone, it takes a few minutes before you can go back and finish the HOP and this time you can't wake him up since he's already awake chewing on his bone. What I did was give him his bone, walked to a few of the places I had been to pass the time, then came back to finish the HOP. Hope you can complete this.
 
 
Anytime I play hidden object games, I frequently save my game during play so that way if I need to, I can put it back if something gets missed or the game messes up. You go to where the game installs. Go to Local Disk C/Users/Your Name/ AppData/Roaming/ERS Game Studios/Haunted Legends - The Secret of Life. Sometime during play, I exit, go that that location and copy and paste to my desk top, that way if something happens, I delete the file in that location and copy and paste the saved one on my desktop back. That way you don't have to start over.
 
 
 posted in Haunted Hotel: The X Collector's Edition on Nov 14, 15 1:09 AM
Same problem. I saved the pictures on my screen of where all the collectibles are. I'm toward the end of the bonus chapter and I just noticed I'll have only 19 morphing objects & 23 petals instead of 24. I followed the guide as to where they are. I noticed at the beginning of the game where the petal collection is that the petals are outlined before you get one. Once you get one, if fills it in. I've gotten the last petal according to the guide and I have one missing according to the counter on the screen. I went to the petal collection and I didn't see any outline of where one would be. Maybe it's a miscount? Let me know if one of you figures it out. I was fixing to start over again, but, I won't waste my time if trolde played twice and didn't get the other 2 supposed morphing objects or the 24th suppose petal.
 
 
You're welcome. The first time I played, I used the water instead of slapping him and of course I didn't have water for the flowers. I restarted when that happened. Thankfully that part isn't too far into the game.
 
 
It's that glass of water you get from the kitchen windowsill. You have 2 choices to revive the unconscious guy on that table. Throw the water on him or slap him. If you choose the water, you won't have it to put on the flowers. The guide tells you to use the water on the flowers when you get that way. It also tells you to slap the guy to revive him. Hope this helps.
 
 
You're welcome!
 
 
Yes, they are in the bonus chapter and there are 3. One is on Gavin's desk and the other 2 are in the room with the soldier you give the helmet to (you have to get rid of the roots blocking the entrance first). One on the left wall and one on the right wall. All 3 are blue and in cups. You need Gavin's blue magic powder from his desk. (it'll be added to your inventory when you get it). You have to play the bonus twice to get that achievement since there are only 3 and you need to put out 5. The bonus is short, so, I didn't mind playing it again.
 
 
After you do that, you are suppose to take off the cage for the 2nd part of that mini-game.
 
 
I didn't wake him the first time playing, but, did wake him up the second time playing, The bone you are suppose to give him is next to the stairs leading to the pharmacy/apothecary (don't remember what the game calls it) that is across from his dog house. You pick up the bone and then click on the dog house with it. Then the sparkles appear to try the hidden object again. When you are in the dog house Chappie is chewing on his bone and he is awake. You don't have to worry about waking him up this time since he is awake chewing on his bone. Hope this helps.
 
 
See my above post.
 
 
You're welcome. I already beat it a 2nd time for both main and bonus. Got all achievements. What I remember about the purification candle is you click on the candle box (should have a magnifying glass on it), put what you need on the screen according to the guide (might help if you put it on the screen in the order it says), and follow the directions on that paper on what to put in first. I know you put the ingredients in the bowl, mash it, the blood goes in after the dry ingredients, then you put the wick in, then pour the mixture. All I remember is picking up the wick and clicking on the candle box. The first time I did have trouble. I tried putting the mixture in before the wick. The directions says to put the wick in before the mixture. Hope this helps.
 
 
The blood you get at the cabin. To the right is a memorial to Meril with her picture and when you arrange the candles correctly, she cries blood and you need a tube to put it in. I forgot where you get the melting pot. If I remember, I'll post.

Edit: The tube for the blood is also at the cabin in the box inside. The Elder gives you the melting pot at the House on the Hill after you give him the Evidence against Gavin. Hope this helps.
 
 
You just pick up the wick & click on the box and it'll be put in there when you do that.
 
 
Ok, I beat it the first time no problems. I'm playing again to get the Smother 5 Magical Fires. Anyway, I'm at that part where you put the dream catcher together. I did have trouble this time and it wouldn't let me put the silver amulet on since I tried putting it on last, so, I got out, restored from my last save, got to that part again, and followed the directions on what to put on first and the silver amulet is listed as being put on the screen first. You might try that and see if that helps.
 
 
I didn't have any problems. I'm past that, but, if I'm remembering correctly, Meril's brooch/pin you got from her room (I think that's where it was gotten) went at the bottom and the silver one went on top. The crystal thing was at the bottom on the rope/string in the middle. Hope I'm right and hope it helps.
 
 
I had the same problem. I figured out you have to put the wick in first then pour the liquid. Hope this helps.
 
 
I don't understand what this means "open up the watches you recieve for achievements.....
so far, each I have opened has something to look at.
I don't know if this is strictly an Easter Egg.....but, it is a neat extra, that I stumbled upon from my habit of clicking everything I can. " I take it you looked at the achievements. What was the suppose Easter Egg? I noticed in the achievements below the others on a table looking thing, it looks like one could be there. Is that it? Do click around to get it?

Edit: I don't think there is an achievement for just clicking around. The one on the table by itself is for completing the main game.
 
 
 posted in Redemption Cemetery: Clock of Fate Collector's Edition on Oct 27, 15 11:41 PM
They fixed the bridge problem. There was an update on October 1st.
 
 
 posted in Redemption Cemetery: Clock of Fate Collector's Edition on Oct 19, 15 3:22 AM
When the hard button is lit up, you are playing on casual and when the casual button is lit up, you are playing on hard. I know it doesn't make sense. It should be the other way around.
 
 
 posted in Redemption Cemetery: Clock of Fate Collector's Edition on Oct 19, 15 3:17 AM
I got all the achievements and of course had to play twice to get them all. Yes, the T & H puzzle are difficult on hard mode. I had trouble also, but, after trying off and on for a week, I finally got it solved. In casual mode, the pieces snap into place when you get each piece right. On hard mode, they do not. You have to follow the picture of both the T and the H according to the guide. The spaces and the lines have to be exact and they do not snap together until the end when you get the last piece in place. After the first time you solve it, it gets easier each time you play. As far as the gun powder puzzle on the bonus chapter, you have to click the space you want to move that paper with the gun powder to. Took me a bit to figure out. Hope this helps.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator