Posts created by MOM2LIAM

 
 
 posted in The Secrets of Da Vinci on Jan 3, 14 12:34 PM
I've made it near the end of the game. I just need the sugar to make the fumigant. I've spoken with Saturnin who instructed me to reclaim the codex from Hector (done) and he said I'd be able to enter his room. I'm dressed as a guard and can easily walk around, however, the room is closed. Any suggestions?
 
 
 posted in Hallowed Legends: Samhain Collector's Edition on Apr 2, 11 4:35 PM
My SG doesn't have the solution, so I placed all pieces exactly like MargieB provided. Can't get past the (calf?) 3rd animal. It goes up and through the animal. Pieces are placed just like the screen shot.

No choice but to skip the puzzle
 
 
 posted in Hidden Mysteries: Vampire Secrets on Mar 19, 11 5:54 AM
I'm stuck in a HOG in the castle coffin room. It lists "scythe" which I found but it is still listed. I found anoher one which I click on to no avail. Now I can't get the chess piece and continue the game. I've tried quitting the game and starting again, but it doesn't change anything in the game.


So, I had to restart the game. When I got to that HOG I clicked on the smaller scythe on the left of the screen AND did no leave it for the last item. The scythe stayed on the screen but was deleted from the list of items to find. Here's hoping it's the last bug I encounter.
 
 
 posted in Hidden Mysteries: Vampire Secrets on Mar 19, 11 5:29 AM
I'm looking at the book right now, and I think dumb luck is the way to go.
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Oct 24, 09 9:20 AM
I skipped the dang puzzle. I'm playing on a laptop with a track pad, not a mouse. The highest I got was 70. I think I tried over 2 days before I gave in.
 
 
 posted in Dracula Origin on Apr 25, 09 5:02 PM
LOVED the surprise ending! Thanks to prpldva for pointing me in the right direction and to those in the forum who's previous questions helped me get through some of those hair-pulling puzzles.

One question. In the castle, what was the purpose of looking at the girl's photo with Harker's glasses? I saw the scratch marks but was i supposed to do something??

Thanks again!
 
 
 posted in Dracula Origin on Apr 20, 09 8:29 AM
THANK YOU!!! I did all but that last part!

Karen
 
 
 posted in Dracula Origin on Apr 20, 09 8:20 AM
Hey PrplDva

Thanks for the response. Unfortunately, I did ask for the remedy. He left and came back and is standing over Seward. I try to take/switch keys but I keep getting the response that "I can't do that" (or something like that).

Any other suggestions?

Karen
 
 
 posted in Dracula Origin on Apr 18, 09 1:01 PM
Hi,

If it says s se it means south and southeast respectively.

Karen
 
 
 posted in Dracula Origin on Apr 18, 09 12:43 PM
Hello, I've read through the posts for this problem but still can't seem to figure this one out. I've created the "key" from the pretzels and the inn keeper is hovering over Seward. The inn keeper has gone out and come back. I can't exchange the keys. I've picked up the papers and tooth. What else am I supposed to do???


As a point of curiousity am I supposed to be able to get the monk out of the abbey? I clicked all over the cage but there didn't seem to be a way to get him out. I left without rescuing him b/c I thought he was dead.
 
 
 posted in Dracula Origin on Mar 3, 09 4:13 PM
where are you in the 1st scene? are you talking about the map or graveyard?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator