Posts created by pavlovscat

 
 
 posted in Roads of Rome: New Generation 2 on Nov 7, 17 12:40 AM
Thanks a bunch. Your list made it easy to find those last few caches.
 
 
 posted in 4 Aztec Skulls on May 5, 17 2:55 PM
Thank you for these! I couldn't find #3 in Chapter 12. I also missed the ones in the cracks. I found the rest but was stumped on those. Yay!
 
 
 posted in Elven Legend 4: The Incredible Journey on Apr 5, 17 11:57 AM
heidiaunt wrote:I finally got three stars on every level and the bonus land will not unlock. Very disappointing. What am I missing?


If you have the regular edition, you do not get bonus levels. You need the Collector's Edition.
 
 
 posted in Dark Dimensions: Blade Master Collector's Edition on Jul 1, 16 7:57 PM
Another problem here with the candle mini-game where the #2 candle does not respond to clicking it or other candles so cannot be lighted. I had to skip the mini-game.

I am running Win 7 Home Premium 64 bit SP1 with AMD Radeon HD 6570 video and fully updated drivers.
 
 
Windows 7 Home Premium
I have the hammer & spoon problem as well.
 
 
 posted in Maze: Subject 360 Collector's Edition on Mar 18, 16 7:58 PM
Windows 7 Home 64x and everything is up to date on my pc

I am having the same issue with the guide. The guide worked fine before the update. Is there any way to roll back an update? I didn't have any problems prior to updating. It's a shame because this is a game I really liked.
 
 
 posted in Flying Islands Chronicles on Feb 12, 16 2:15 PM
Win 7 Home Premium x64
My pc is completely up to date. I am having the same issues as others on The First Rune. The warrior disappears before all the barricades are destroyed.
 
 
Don't use the address letter on the gate where the eye shows. Use the letter on the screen for the marble mini-game. Dupin will will talk, and then the gate will open.
 
 
 posted in Fear for Sale: City of the Past Collector's Edition on Nov 9, 15 4:38 PM
Windows 7 Home Premium 64 bit
I am in the Gallery and just put the pieces of evidence in the diary. There are no arrows to navigate out of the room. Neither the map nor the tasks will open, so I cannot progress.

The guide and the menu still open.
 
 
 posted in Redemption Cemetery: Clock of Fate Collector's Edition on Sep 27, 15 4:42 PM
I have the common problem of CTD upon completion of bridge puzzle in the bonus chapter.

Running Win 7 Home Premium 64 bit
 
 
 posted in Haunted Legends: The Dark Wishes Collector's Edition on May 14, 15 1:27 PM
Shoddy beta testing again. What a shame. This is one of my favorite series. If you help the clockmaker before you finish with the librarian the game crashes. I assume this is because you don't get the objective to help the clockmaker until you are done with the librarian, yet game play allows you to complete the clockmaker senario first. I had already completed the task before I received it as an objective. NOPE! You cannot do it that way.

I have done extensive beta tests for other genre games. It would be so much better if they would use experienced beta testers and allow them to test the entire game before release. This type of issue should be very easy to find and fix. Obviously, I found it.

EDIT: It seems I was slightly wrong. It's the same problem, but the trigger is saving Roberto first, not the clockmaker. I've replicated this 2 more times by saving Roberto first. If I go to the librarian with the bandage before I save Roberto, I can continue.
 
 
 posted in Monument Builders: Cathedral Rising on Jan 14, 15 2:16 PM
None of the buildings are producing supplies on this level. I can get the hunters and the gold they drop. I can chop wood, and the pack horses deliver. None of the buildings are sending out pack horses. All roads are repaired, and all hunters are gone.
I have tried closing and reopening the game as well as re-installing. The next regular level plays fine.

Windows 7 Home Premium 64-bit SP1
 
 
 posted in Hidden Object Crosswords 2 on Dec 3, 14 9:32 PM
Windows 7 Home Premium 64 bit
I was able to enter a profile name and start to map, but when I try to play the first level, I get a black screen with sound only. Restarted again and same thing.
 
 
Wigi, you made my day. I haven't laughed that hard in ages.

I was born in, and live just outside of, New Orleans, so I feel the British pain with these incongruities. Don't even get me started on the problems with how New Orleans and Louisiana are portrayed like in MCF13th Skull or Deadtime Stories. LOL

If you play games (or watch movies), you'd think everyone in Louisiana talks with a Cajun accent (I've been told I sound like I'm from New York or New Jersey), we all have alligators in our backyards (nope, just in my dinner!), we all live in swamp huts (I live in an average USA suburban house with a fenced back yard, plumbing and electricity) and the swamps are steps away from the city proper (nope again, gotta drive to get there unless you live in farthest New Orleans East and the swamps closest to the city are nothing like the spooky, moss draped cypress swamps in the games). Yes, we have a rich voodoo history, but you don't find the friendly neighborhood Voodoo Mistress on every corner.

I will say that it greatly aggravates me that the folder name for this one is abbreviated to MCF. Since the game manager rarely works properly anymore (And, yes, my AVP is set properly. Everything worked fine until the last update. The latest update to the game manager is just borked with no plans as far as I can see to fix it.), I had several minutes of hissy fit over not being able to find the folder to play the game. It never occurred to me that a flagship BF game would be abbreviated. That is just plain lazy. I guess I shouldn't be surprised because that is the typical result when successful companies get too big and start outsourcing. I'm sad to say that I feel the days of BFG's superiority are waning. Soon not even the bonus punches will be enough to make up for the loss of quality and customer care.
 
 
 posted in Northern Tale 4 on Aug 1, 14 12:36 PM
I always find the solution after I post. LOL

There is a lantern to the left & below the gold shaft. I missed lighting that one. It lights the area around the bottom left lantern. Finished with 3 stars.
 
 
 posted in Northern Tale 4 on Aug 1, 14 12:15 PM
I could not complete this level. The bottom left lantern cannot be lit, so it is impossible to break the stone in that dark area. I am going to restart the level and see if it happens again.
 
 
 posted in The Tiny Tale 2 on Jun 6, 14 8:24 PM
The game played without issues until Level 38 where I encountered a similar problem to others. The tower was built and showed zero wood needed, but the objective would not complete. All other objectives were completed.

I exited & restarted the game, replayed the level and collected all the wood before I started the tower. That worked fine.

The previous time, work on the tower stopped because the wood ran out and had to be restarted. I don't know if this made a difference, but it was the only thing I did differently.
 
 
 posted in Puppet Show: Souls of the Innocent Collector's Edition on May 27, 10 5:39 PM
All drivers are updated. Uninstalled & reinstalled Flash. Strategy Guide gives an access error when I try to open it. I am using the demo version.
 
 
 posted in Dream Chronicles: The Book of Air on Mar 26, 10 8:12 PM
Yay!! Looking forward to this one. I love the first three.
 
 
 posted in Engineering: The Mystery of the Ancient Clock on Mar 18, 10 1:09 PM
I have uninstalled & reinstalled the game demo, but it tells me "Trial Expired". I have never played this game.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator