Posts created by Paminca

 
 
Horrible! I've played all The Mortimer Games and there aren't enough words to describe how awful this game is. I have probably bought 200 games on BG. I don't often write reviews but felt I needed to say something hopping to save someone from the abomination I just played.
 
 
 posted in Agatha Christie: The ABC Murders on Sep 8, 17 3:50 PM
Do not buy this game . It's awful.
 
 
 posted in Agatha Christie: The ABC Murders on Sep 8, 17 3:47 PM
Don't buy this game it's slow , jerky and I found it unplayable. Also got no help fixing it from BG. SOOOO disappointed with Tech help and with them allowing a game so
badly designed on the site. I've bought games here for years and this is the worst. Your warned.
 
 
Running W 10. Stuck at the bells. Moon won't open. All the bells are in place but keeps saying "Bells are Missing". Tried uninstalling and re-installing but still is stuck. Games is unplayable. May I be reimbursed Plz..
3
 
 
I have Windows 10 and I've placed all the bells yet the directions say Your missing some bells. I click HINT and the sound rings but no sparkles. I've restarted the game, still nothing. Everything else in the game is working fine, except this. I can't go further so I can't finish this game. Feeling a little cheated. Where is the fix? I will stay away from this game producer in the future.
 
 
Don't bother trying to use the "new build". Just did and and was told no updates availuble. I need to start checking for tech issues before I buy a game.
 
 
 posted in Rite of Passage: Hide and Seek Collector's Edition on Jun 30, 14 2:55 PM
Finished the game. Had to close for the night and when I went back the next day to play it I couldn't find a way to access it again. Does anyone know if I have to play the whole game again to get to it? If so, I should of waited for the SE game because this bites.
 
 
 posted in Grim Tales: The Vengeance on Jun 19, 14 11:31 AM
Went though the gate useing machetti to cut away vines and it didn't come back into inventory. Now I can't get though the log. Not a happy gamer.
 
 
 posted in True Fear: Forsaken Souls on Apr 9, 14 4:43 PM
I rarely bother to leave a review. Most games are just a variation of one another. Change the art, yet the stories are very similar. Not so this one. This was really well done and kept me interested. Lots of places to search, with a horror theme that was actually interesting. I wish I'd known it was going to be this good because I'd of bought the CE version.
 
 
 posted in Nancy Drew: The Deadly Device on Feb 20, 14 3:31 PM
Where's the walkthough for this game? Do we have to go to Gameboomers to get one? ND games are usely great fun but a walk though is nessasary.
 
 
 posted in Fearful Tales: Hansel and Gretel on Sep 27, 13 12:47 PM
Me again. Already tried deleting the first profile and put in another. Guess what. It froze in another place and I was jumping though the same hoops I'd jumped though before. I'm done, done, done. The game I bought after this one is working just fine. It's not my video card, I have windows 7. I'm close to spitting nails.
 
 
 posted in Fearful Tales: Hansel and Gretel on Sep 26, 13 5:36 PM
I want my game credit back. I have done everything the "Help" section said to do and I've had nothing but problems. First it froze on the rusty knight. Then after an hour of going though the suggestions on Help the game manger stopped working. I uninstalled reinstalled over and over and every time I tried to play the game it would freeze and the game manager would stop working. I've deleted this game and bought another which so far is working fine. I think there is a flaw in this game which has not been fixed. I want my credit back or fix the game.
 
 
 posted in Final Cut: Encore on Aug 9, 13 4:08 PM
Game plays for a while then freezes. I have updated all my drivers and made sure I have current DirectX. It still freezes. Needs a fix plz..
 
 
 posted in Fairly Twisted Tales: The Price Of A Rose on Jan 25, 13 2:49 PM
Well, I'm over half way though the game when I get stuck. I'm in the music room finshing an HO. On my list is "star fish" but when I click the star fish behind the box on the chair nothing happens. I clicked "Hint" thinking there might be another on somewhere in the sceen but it circled the star fish I'd aready spotted. I closed the game hopping when I turned it back on it would work but nooooo. Not happy. game was ok till now. I'm not about to start all over by uninstalling/reinstalling the game and have to start over.
 
 
 posted in Witch Hunters: Stolen Beauty Collector`s Edition on Aug 27, 12 9:36 AM
I've had trouble to. Game played ok , it's when I got to the bonus game that it had problems. Hint and Powers wouldn't work and when I grabed the horn on the wall it froze. Couldn't get it to close even when I went to windows. Finally had to go into Task Manager and close it that way. I promtly uninstalled it. I'm not reinstalling it just to play the bonus game. I'd have to play it all over again and who's to say it wouldn't have the same problems. Very disapointed. This is an expensive game and I feel a little bit cheated.
 
 
 posted in Big City Adventure: London Classic on Feb 11, 12 1:45 PM
Hate the scarab puzzle. I'm stuck. No skips and no clue how to deal with this puzzle. $%#&@!!!!!.
 
 
 posted in Resurrection, New Mexico on Feb 10, 12 10:22 AM
Do not buy this game. Problems like things in the lists not being in the scene. A "cup" turned out to be a clay pot and somethings so blurry they don't look like what their suppose to be. Also, it's possible to skip a puzzle but then be stuck at a point in the game and not be able to continue. This game is not well put together.
 
 
 posted in Resurrection, New Mexico on Feb 10, 12 10:15 AM
This game is very glichie. In one HO scene I spent ten min looking for a "cup" which turned out to be a clay pot when I got feed up and clicked "hint". Lastly, I did the window scene in the drug store before I found the dolls. I couldn't figure out what I was suppose to do so clicked "skip". Now after I've found the dolls I can't get back into the window scene and I can't get forward in the game. The game keeps saying check out the window scene. I hate this game.
 
 
I've just started and I've encountered a glitch. When I first used the crow bar to enter the lighthouse it did not return to my inventory so when I got the rope and tried to return to the lighthouse the door was locked once again and I can not get back in , nor is there a crowbar to help me. #@&%@#$#!!!! Must I start over?
 
 
 posted in Dr. Jekyll & Mr. Hyde: The Strange Case on Mar 7, 11 7:13 PM
Same problem as most here. Screen comes in but can't read anything. It's like pieces of the fonts lettering are missing. SOOOOO glad I tryed it before buying it, Come on, Big Fish, this happen to me with another game last month to. I've been such a happy fishy for a long time why does there seem to be so many problems lately?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator