Posts created by tac11

 
 
cannot find the small key to unlock the small chest in the bedroom upstairs.
the chest is in the cabinet. I think this is where the last billard ball is.
 
 
 posted in Christmas Stories: Nutcracker Collector's Edition on Dec 11, 12 10:04 AM
I cannot find the hunting lodge. One blog said it had a cork & barrel and a ice structure. I have no idea what they are talking about. I need specifics as to where to find it.
 
 
at the gondala crash site, where is the rag to open cabin door?
 
 
I need the power plug for the jukebox. I have all the parts for the projector, but the sister will not let me in until I find all the parts. I know where the plug is, but can't get to it.
 
 
I have the parts for the projector,but can't find the key for the "secret door". Where can I find it ?
 
 
 posted in White Haven Mysteries Collector's Edition on Feb 27, 12 10:04 AM
I am having the same problem (as many other people are having) with the barbed wire. I cut it put up the ladder etc. Hint button keeps going back to that spot.Also I cannot find the last vial. Someone fix these 2 problems. I want to finish a game that I paid for!!!!
 
 
 posted in The Keepers: Lost Progeny on Dec 23, 11 11:59 AM
I keep getting a hint that there is something in this entombed man. I have knocked down the wall but I cannot find anything. I think its a metal gargoyle.Where is this gargoyle? Stuck on this one.
 
 
 posted in Fear for Sale: Sunnyvale Story Collector's Edition on Dec 9, 11 1:24 PM
where is the lens for the projector?
 
 
Where do I find the code to open the safe in the gas station, It is not in my journal. Also, how do I open the box with the skull head on it ?
 
 
 posted in Mystery Trackers: Raincliff Collector's Edition on May 15, 11 9:20 AM
where is the hook knife? i've looked all over the place for it.....
 
 
 posted in PuppetShow: Lost Town Collector's Edition on Mar 25, 11 9:50 AM
Thanks Lady-Cav ,
You saved my day!! Finished the game!!
 
 
 posted in PuppetShow: Lost Town Collector's Edition on Mar 25, 11 9:15 AM
I have dynamite in slot in cave, but no matches . Where do I get the matches to light the fuse and how do I get across the cave?
 
 
 posted in PuppetShow: Lost Town Collector's Edition on Mar 22, 11 2:57 PM
In chapter 4 hos scene, where is the coffee grinder? I used the hint button 4x. It always shows the same place but I can't see it .
 
 
How do I get to the safe behind the books? They won't move. Have I missed a step? I have the thing that opens the safe.
 
 
I have placed the broken sword in the slot by the stain glass window. The sword moves but the lever does not.I have tried moving the lever first then the sword and visa-versa, noyhing. I have tried click n' drag . Nothing works What do I have to do?
 
 
 posted in Treasure Seekers: The Time Has Come Collector's Edition on Jan 20, 11 11:32 AM
I am playing the game but every time I quit I have to begin again. I can't continue where I left off. This is so frustrating . Is this a techinal problem or what?
 
 
 posted in Phantasmat Collector's Edition on Jan 9, 11 10:58 AM
I am struck on the notes for the piano.I have all the piano keys, and thought I had all the notes but I can play re.me, fa but when i hit sol I get a horn sounding noise. Also in some the blogs they said something about sol by the piano and using matches. I have no matches. Can someone please help ?
 
 
I am at the mausoleum,put the 3 gold pieces in the skeltons, pulled the chains several times, still do not see the gold spot,
I need some help..
 
 
I have all the dates for the crypt but when I put them in nothing happens.Do I have to put them in according to birth,death etc, I have pulled the lever after each date
 
 
chapter 2 boiler room, where is the firewood.?. i have looked everywhere
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator