Posts created by GrandWeeze

 
 
 posted in Nevertales: The Beauty Within on Mar 5, 14 2:27 PM
I haven't posted for quite a while, but having just finished the SE, I needed some place to say "WOW!!!" This is an amazing game! So creative! If I weren't so backed up on trying games (and a cheapskate to boot) I would consider getting the CE to try the extra content. Keep the games coming from this developer.
 
 
 posted in Lost Civilization on Nov 6, 13 8:35 AM
I have a "hard" copy of NiBiRu Age of Secrets. It was put out by The Adventure Company (always a go-to for me) and the date is 2005. I remember really enjoying it.
 
 
 posted in 2 Planets Fire & Ice on Oct 16, 13 8:24 AM
This has happened to me several times. You cannot get these 2-for-1 deals through the Game Manager. You have to type in the game name on the cart, hit continue shopping, type in the second game name, then enter the deal "code." I was resigned to never being able to get a 2-for-1 deal, but this method works.
 
 
 posted in Dark Canvas: A Brush With Death on Feb 15, 13 8:26 AM
Absolutely no download problem. Start to activation was approx. 2 minutes. Again, I thank my cable modem!
Concerning the problem of trying to limit CE purchases, in the past year I haven't even demoed CE's because I know I'm not going to spend the money on them. An advantage to this is that I don't get angry with BFG as others do saying there is no new game to play the day the SE comes out. And I have plenty of demos in queue waiting to play on the days a CE is introduced.
 
 
 posted in Weird Park: Scary Tales on Dec 13, 12 6:25 PM
I just deleted this game. I am not going through the rigamaroll of Dr. Felix, changing my resolution, etc., etc. I've got better things to do with my time.
 
 
 posted in Antique Mysteries: Secrets of Howard's Mansion on Apr 24, 12 8:31 AM
I found the gameplay very clunky. It annoyed me so much, I deleted the game well before the trial was over. I didn't need that much frustration.
 
 
 posted in Witches' Legacy: The Charleston Curse on Feb 16, 12 9:34 AM
I just finished the demo and agree that this is a very well-done game. My problem is one that I've encountered in many other games - you must constantly go to the journal to get the complete story. You pick up a letter which is unsigned, but the journal entry tells you who wrote it. In this instance, it would be just as easy to have the letter signed, although I realize that the alternative to most "journal info" is a narration which many gamers object to. I object to interrupting gameplay by continuously returning to the journal! It doesn't happen in this game, but I've also encountered information that appears in the journal prior to its appearance in gameplay. That's just poor editing.

Whoa! I just lost lobster status. Although I haven't tried guppies, I suspect lobster is much tastier!
 
 
 posted in Atlantic Journey: The Lost Brother on Feb 6, 12 8:33 AM
Sheilaclown,
Me, too! I'm deleting.
 
 
 posted in Cradle of Egypt on Jan 14, 12 11:31 AM
Well, I replayed the game under a different name (really tired of the music by this time!!) and thought I had beaten the glitch. Then I made the mistake of choosing the second building to construct rather than the first since I had enough resources to buy either and the second one gave a bonus. That was it! Took away all my accumulated points in the final "epoch" and told me I had finished the game!
 
 
 posted in Cradle of Egypt on Jan 4, 12 10:45 AM
Failure!! Totally failed to save my progress and made me begin the level all over again! How annoying!
 
 
 posted in Cradle of Egypt on Jan 4, 12 10:42 AM
Same thing happening here and I'm trying to figure it out. I am also playing untimed mode (I'll only do timed once I've won the game in untimed mode) and have played this very challenging level at least 4 times before I realized that the game totally discounts any gains I made on the previous playing of the level. I'm going back in now to see if I've gotten around the glitch. It can't be anything else, because why would the developer provide an untimed mode but not allow you to win in that mode?? I'll be back to report my success or failure.
 
 
 posted in Awakening: The Goblin Kingdom on Sep 30, 11 12:12 PM
I did the beta test on this game and have been anxiously awaiting it since then. Yes, I know the CE came out a while ago, but since I'm too cheap to buy collector's editions, I've waited til now. But this is a definite buy - A+, Five stars, 2 thumbs up!
 
 
 posted in Chocolatier: Decadence by Design on Sep 18, 11 10:02 AM
Funny coincidence - I am at the moment replaying this game! I love the Chocolatier series and would love for a fourth one to come out. I highly recommend buying this at this fantastic price. Believe me, you'll more than get your money's worth!!
 
 
 posted in Grim Facade: Mystery of Venice on Sep 18, 11 9:57 AM
I purchased this yesterday with multiple activation problems until I uninstalled it and re-downloaded it. Thoroughly enjoyed playing even though I kept getting thrown out of the game trying to go upstairs in the one house next to the shopkeeper. Managed to get by all that nonsense and onto the next part of the canal. All of a sudden, the screen began to break up, pixilate, throw up all sorts of ridiculous images. Had to control-alt-delete to get out. Haven't gone back in to see if it's still doing that. I really do love the game and want to finish!

When I opened up the game today, all problems had disappeared and I was able to finish. So glad! I really enjoyed it!
 
 
 posted in Redemption Cemetery: Children's Plight on Sep 9, 11 9:32 AM
This SE is the first time I demo-ed this game and it's one of the few times I haven't asked for tutorial help. Certainly didn't need it as it runs the way most games do. It took me an hour to finish the demo, but I felt it was super easy - the H0 scenes and the puzzles, which aren't my forte. The story does grab me, but I don't think it's worth buying.
 
 
After reading about extreme DL times, I decided to time mine.
1 minute DL
1 minute install
20 seconds activation.

Obviously I've got a fast cable hook-up.
 
 
 posted in Unsolved Mystery Club ®: Ancient Astronauts ® on Aug 13, 11 9:14 AM
lkwriter wrote:
Darla1108 wrote:This is exactly what's happening to me. I was able to download just fine, but nothing happens. I click Play and nothing. I was able to demo the CE but this won't do anything.

Just came back after trying to uninstall and I can't uninstall through the Game Manager. This is really getting to be more trouble than it's worth. I always liked that BF had a game manager where my games could be easily located and uninstalled, but I am really disappointed with this new version



This is happening to me, too. I'm starting to believe all the scuttlebutt about the new GM being bad. Let me try that reboot tactic and see if it works. This is annoying!!
 
 
 posted in Art Mogul on Aug 4, 11 1:01 PM
I demo-ed this game yesterday due to the comparisons to Chocolatier (I'm just desparate for a new one to come out!!) Chocolatier games use the "Shooting gallery" as an interior game, where Art Mogul uses object searches and "STD's" as interior games.
I found myself getting very frustrated from not remembering all the variations on the gameplay, where different paintings where, and, for that matter, where I was
One aspect of the game which I don't believe has been mentioned is the borrowing from banks. I was told in the tutorial that I had to borrow, but then totally forgot that I was supposed to repay the loan, so when I found myself out of money, I had no credit to borrow again!
Upon finishing the demo, I had decided not to buy, just because of being so frustrated. But what happened next really belongs to the various spooky, supernatural games we've been treated to. I dreamed about playing Art Mogul last night!! YES! REALLY! Now I figure since it's so entrenched in my subconscience, I have to have on my computer!!
 
 
 posted in Millennium Secrets: Roxanne's Necklace on Jul 25, 11 11:24 AM
macmeri wrote:I played the first 4 chapters with no issues and was really enjoying the game. Until now... I am in chapter 5 and although I used my knife to cut the bamboo for kindling, it did not appear in my inventory. I thought it might have been one of the herbs I was collecting...until I tried to build the fire and needed kindling. I went back to where I had cut it hoping I just had to pick it up or something but it is nowhere to be found. I re-searched every area for something else to use for kindling to no avail. I clicked for a hint and that wasn't working either. I had used a couple of hints earlier in the game so it had been working. I quit the game and restarted it but still no kindling and no hints. I only have 5 items in my inventory so that isn't the problem. So I finally came here... I was kind of hoping I wouldn't have to come here...to find out if it is an issue with the game that others are experiencing. It is. I don't want to replay the game to get back to this point when there is no guarantee it won't happen again AND from what I'm reading, I can expect issues in Chapter 6. It's too bad because I really liked it...


Same thing happened to me! (See thread I started entitled "Help! my kindling disappeared!") And it looks like we're not the only ones! I guess we need to run the report that the mod suggested.
 
 
 posted in Millennium Secrets: Roxanne's Necklace on Jul 23, 11 7:24 PM
My thoughts exactly, but no that isn't the case.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator