Posts created by nanalinnell

 
 
 posted in World Mosaics 7 on Apr 16, 14 8:53 PM
I'm having the same issues some of you are having. Every once in awhile (about 75% of the time), this game crashes and won't let me shut down the game manager so I end up having to shut down the computer with the on/off switch. Also, I can't tell you how many times I have clicked the correct part of the mouse only to have it put the wrong mark in the square, i.e. puts an "x" where it should have a check mark. I pushed the correct part of the mouse. I can get 3/4 into the game or later when it does this and/or then crashes. Is there anything I can do to fix this error? It's very annoying.
 
 
 posted in Island Tribe 2 on Mar 18, 14 5:38 PM
Does anyone know where the first part of the precious bowl artifact can be found on Level 22? It pops up after you finish the goals of that level and doesn't give me enough time to look for it. Didn't find anything on the forum so maybe I'm the only one having this problem.
 
 
 posted in Patricia's Quest for Sun on Apr 8, 12 5:53 PM
Liked the demo. Bought the full version. Finished it in one day. Disappointing that
it didn't last longer.
 
 
 posted in Grim Tales: The Legacy Collector's Edition on Mar 10, 12 1:07 PM
I finally got rid of the weeds. You have to click on each green clump at a time and they will each disappear one at a time. THEN you rake it and THEN you pour the bottle of water on it. Finally! I guess I didn't notice that the weeds were disappearing one at a time. Thought the rake would be the thing that got rid of them. Hope this helps.
 
 
 posted in Ravensburger Puzzle Selection on Feb 9, 12 12:00 PM
Getting the exact same thing on that level. Unexpectedly closes. Did you get an answer or fix yet?
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Oct 28, 11 10:21 AM
I can't get it to work either. I tried the way the hint suggests AND the way the walkthrough shows the solution. Neither one has worked yet.
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Oct 24, 11 1:19 PM
I'm having similar issues with the electrical root (?) puzzle. I did it the wrong way and tried to reset it but it won't reset. Now I have all these lines going the wrong way and I can't get past it. Tried to click on the dots to undo it all, but it didn't work. Looks like others have the same issues. Do I have to start all over again just to get this puzzle correct? UGH!!!!
 
 
 posted in My Kingdom for the Princess III on Oct 4, 11 12:22 AM
I agree. Where is the Mac version -- of this, Roads to Rome III and Build A Lot on Vacation. The PCers get three TM's and we are stuck with the same old HOG and kids games.
 
 
 posted in Twisted Lands: Insomniac Collector's Edition on Sep 8, 11 7:04 PM
Okay. I did it, but it still doesn't make sense. The correct answer for my game was to pay attention to the sample picture in the diary of the panel, NOT the numbers corresponding to the illustrations on that scroll. I don't get it at all but at least the door opened.
 
 
 posted in Twisted Lands: Insomniac Collector's Edition on Sep 8, 11 6:46 PM
I'm sure I saw the right numbers: a 2 on the mountain, a 0 on the flag, and a 1 on
the light switch. I entered the symbols for those numbers under the corresponding mountain, flag and light switch etched on the panel, but they didn't work. I believe I entered the correct symbols, but it isn't working. Do I have a bug?
 
 
 posted in Twisted Lands: Insomniac Collector's Edition on Sep 8, 11 1:33 PM
OKAY. I give up. I got all three images from the telescope. A 2 on the mountain, a 0 on the flag and a 1 on the light switch (?), but when I enter the correct pictures corresponding with those three numbers (the mountain, the flag and the light switch), nothing happens. I have tried putting them in the order etched on the door panel, the order in which I saw them and the order shown in the diary. Nothing works. I looked at the strategy guide but evidently the code varies. I am unable to go back to the telescope because I had already entered the codes correctly and they were now entered in the diary.

What the heck! What am I missing? Please answer.
 
 
 posted in A Vampire Romance: Paris Stories on Jul 19, 11 12:34 AM
I can't even figure out how to get started in this game. What????
 
 
 posted in The Timebuilders: Caveman's Prophecy on Jun 26, 11 4:37 PM
Loved it. Think it's my favorite all time game. Challenging and fun but doable (with
help from this forum) and took more than a week to complete. Is the first one as much fun?
 
 
 posted in The Timebuilders: Caveman's Prophecy on Jun 26, 11 5:25 AM
Okay. Here's the TRICK! 1. Only trade the middle amount of stone for steaks - don't trade the largest amount; 2. Get to the 12000 steak bigjaw ASAP; and 3. Leave the bigjaw blocking the pick-a-rock alone until you've got the 12000 steak bigjaw. I tried everything else and even though the strategy of others was correct, I missed the part about trading only the middle trade. I also built two huts at the beginning and upgraded the three times because they brought 250 steaks, the most you can get at that point. Hope this helps somebody.
 
 
 posted in The Timebuilders: Caveman's Prophecy on Jun 24, 11 7:42 AM
How anyone could say this game is boring is beyond me. I love it. It is challenging, you can't possibly finish it in a day like most of the others, and every level has a completely different challenge. Most TM games are boring. They have the same quests on every level, just different scenery. Not this game. For me, this has easily been the best TM game ever! Have been playing for a week and not even close to being finished, PLUS I have made good use of others' comments and walkthroughs, and it's STILL NOT BORING!
 
 
 posted in The Timebuilders: Caveman's Prophecy on Jun 22, 11 9:45 AM
Can someone help me understand why we need both the bridge and to pay the crock on the left? Can't figure it out.
 
 
 posted in The Timebuilders: Caveman's Prophecy on Jun 20, 11 9:59 PM
I might be stupid but I cannot figure out how to get the advanced level here. What am I missing?
 
 
 posted in Roads of Rome on May 7, 11 8:57 PM
How do you know if you have finished this game? I kept getting stuck on the minigame of episode 4 Level 10 even though I beat the minigame.
 
 
 posted in Roads of Rome on May 4, 11 7:46 PM
I am at Episode 4, Level 10 and can't get past it. I conquered the minigame but every time I exit out of the game and try to go back, I still get the minigame as though I hadn't won. Nothing I have tried has worked, i.e. "skip it." It seems like it's just stuck on the minigame.

 
 
I was doing fine until I bought the game. When I went back in to play it, the screen
was frozen. From reading these blogs, I don't think reinstalling the game will help, although it looks like some people actually finished the game. Anyone gotten a reply from BF yet?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator