Posts created by MissMoraduke

 
 
 posted in Bad Dream: Coma on Nov 10, 17 8:07 PM
I was ready to dump this game, but after reading the reviews and understanding more of it, because I got so stuck, I am going to stay with it. But I must say I really enjoyed punching those annoying crows! A free game credit will work as I dont have anything else to use it on.
 
 
I couldnt play the game with the monkey, thankfully I could skip it am more on, one of the pieces just froze and then nothing would happen. At least I am still playing it because I love and and hopefully no more problems because I am buying it.
 
 
 posted in Midnight Calling: Wise Dragon Collector's Edition on Aug 23, 17 3:16 PM
I am stuck frozen at the bugs too, have to shut down and retry. Shame I like the game a lot. Retrying didnt help either.
 
 
 posted in Midnight Calling: Wise Dragon Collector's Edition on Aug 17, 17 1:33 PM
I love the raccoon helper, cute as a button, and a mean little thing too. Just adds to the game, cant wait to send him somewhere again. I guess my old age loves these cute little things. I dont care how hard or easy a game is, some are just to hard for me, and I think the visuals are really nice, cant wait for a sale and to get back to playing.
 
 
 posted in Haunted Legends: The Black Hawk Collector's Edition on Mar 9, 17 12:19 PM
I like the Dwarf, better than some of the silly helpers we get in other games, hes part of Haunted Legends, hes a Legend in himself, Im liking this game so far, when we get another buy on get one free Im buying it, Dwarf and all. I have to many on hold so need to wait for a sale.
 
 
 posted in Lost Grimoires: Stolen Kingdom on Mar 7, 17 8:05 AM
My issue was the game was terminated, according to an error message, and when I went back on I had to put my name back in and start from the beginning and I was half way thru. I dont know if I can play it all over again. What a waste.
 
 
 posted in Maze: The Broken Tower Collector's Edition on Oct 11, 16 9:12 PM
My map only shows 4 circles and nothing on them, its been like that as far as I am in the game. It doesnt work, I wonder what to do. I just have to keep using the hint,
 
 
 posted in Doodle God Fantasy World of Magic on Sep 5, 16 1:38 PM
I wanted to try the game but no mouse, had to shut down computer and restart, tried again no mouse. Oh Well.
 
 
I stopped on the Demo, to savor the game, so different and so much fun, I cant wait to buy with a 2 for 1, I really like it, puzzles were easy but different, cant wait to get back!
 
 
I played for an hour, busy and bright doesnt even cover it, I had to quit because I felt like I was on a weird trip, how much strange stuff can they pack into one game, the lady talking then goes on to sneezing and coughing, really, I felt like I would catch what ever she had, this is one strange game,, I wanted to buy it, I think I did the Beta on it and even stopped with it then, well hope others like it, play and see for yourself.
 
 
[Removed by Moderator]
 
 
 posted in League of Light: The Gatherer Collector's Edition on Jul 27, 16 3:59 PM
Try the arrow?
 
 
 posted in Enigmatis 3: The Shadow of Karkhala Collector's Edition on Jul 23, 16 10:52 AM
Well I have had a different problem, in the HOP scene where you open the toolbox with the three dials it froze up and I lost my cursor, and I was really enjoying the game and now was getting set to buy it, I have Windows 10 on an Alienware game computer, I had to shut down to get out of the game, I want to play it, I wonder if there will be fixes for these bugs.
 
 
 posted in Grim Legends 3: The Dark City Collector's Edition on Jul 16, 16 8:03 AM
[Removed by Moderator]
 
 
 posted in Darkness and Flame: Born of Fire Collector's Edition on Jul 15, 16 8:15 AM
I have lost the sound on the game about halfway thru, I deleted game manager and even the game, and redownloaded it. The sound still wont play, I have checked my sound systems and it says all ok, I am Windows 10. and all my other games the sound works. I just like the background sound when I play games, I know I can play without it, but I really wanted the sound back.
 
 
[Removed by Moderator]
 
 
 posted in Facility 47 on May 18, 16 6:26 PM
Is the cursor thing going to be fixed I cant make it work anymore and was hoping to buy it with the sale Please help.
 
 
 posted in Facility 47 on May 18, 16 3:17 PM
No cursor here either, Dell Alienware computer, I try uninstalling and installing and see what i get.

I just moved my blank cursor around till I get the option screen and take if off wide screen and I have a cursor, put it back on wide screen and its gone and had to click out ESC to get out, so for me the problem is with the screen resolution.
 
 
 posted in Rooms: The Unsolvable Puzzle on Mar 5, 16 11:46 AM
I try the room for days before I have to refer to 9otters solution, I dont know how you do it, I hope I can at least get one room on my own, or what it the point of playing the game, it just is so hard and I am only on Level 1 room 16, I just cant get it. 9otters if you read this is there any way you can give a little help to figure out how to solve these rooms, as I just cant get anywhere on my own, I love the game, and love the banging and rooms shaking by the way, just would really like to see some accomplishment
for myself in at least solving a room or 2, and I know its going to get harder as I go, what am I missing?
You must be the smartest person on the planet!
I take a picture with my ipad and then go and solve the room.
Just another question, what makes the room walls disappear and become wood, or open up again, I am so confused.
 
 
 posted in Rooms: The Unsolvable Puzzle on Feb 22, 16 12:50 PM
Is this game to hard for me to purchase, I played about 10 rooms and its getting harder, I guess I dont have the idea yet, can it be solved in the numbers allowed it seems I only get one crown or whatever it is, its a cute game, but hate stopping because I just cant go on.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator