Posts created by LunaNik

 
 
The Mystery of the Disappearing Cursor...

It's not just the custom cursor that disappears on me, but also the system cursor, so the game is totally unplayable. My Flash, Shockwave, and Java are all up-to-date, as is my BFG Game Manager. El Capitan 10.11.6.
 
 
I'm not sure what happened, but I can no longer finish the main game. I dealt with the three rune rings to shut off the beams. Then, I successfully dealt with the three multi-compartment cabinets on the Summoning Platform, and all the "power" shut down.

The Shadow and his minion then appeared on the Summoning Platform. When I hover the cursor over them, it changes to a "talk" icon, but it doesn't work; neither character says anything.

I tried clicking on them with the shadow lantern...nothing. I clicked "hint," and merely got a black bar saying, "I'd better move on." There's literally nothing left undone in any other area.

The guide simply says to use the shadow lantern and it will prompt a mini-game, but I can't do that. It's like that screen is stuck. I quit the game and tried again...same issue.

My Game Manager states that no updates are available for this game, and I do have the latest version of the GM. I quit the game completely and relaunched it from the GM. Nope. Same issue.

Mac OS 10.11.6
16 GB RAM
2.5 GHz processor
Flash and Java are up-to-date.

Help!
 
 
 posted in Letter Quest: Remastered on Oct 12, 17 5:43 PM
After I finished the demo, I clicked "buy now" in the Game Manager. This game was put in my cart, but not at the DD price of $2.99. Instead, it showed up at the regular Club Price of $6.99.

I then tried it from the BFG website...same result. This should be ringing up at $2.99. Can someone fix it before the DD is over?
 
 
 posted in The Keeper of Antiques: The Last Will on Sep 29, 17 7:53 PM
Mac OS 10.11.6

Game won't launch. I just get a blank white screen and the spinning beach ball of doom. Uninstalled & reinstalled twice. Uninstalled & reinstalled Game Manager, tried again. Nope. I use Chrome so my Flash is up-to-date.

It's not my computer; it's the game. I should note that I had no trouble downloading and playing the CE.
 
 
equicate wrote:
belamba wrote:Playing on a brand new MacBook Pro MacOS Sierra and all up to date.

The game 'will not start or open!'

On pressing play in GM icon for game drops down to the Dock, and then freezes so have to force quit.

Tried uninstalling and reinstalling but to no avail.

Any ideas please?


Same here and I'm running on same system.


Similar, but not exactly the same. The game DLs with no problem. When I click "play," I get a full screen of bright white and the dreaded spinning beach ball of doom.

COMMAND + OPTION + ESCAPE shows the app is not responding, and I have to force quit. I've uninstalled and reinstalled. Same issue. My Flash, Java, etc. is all up-to-date, as is my Game Manager (which I recently uninstalled and reinstalled to solve a problem with a different game). None of the "Mac Game Troubleshooting" measures are at all helpful.

Computer — mid-2011 iMac
Operating System — 10.11.6 El Capitan
Processor — 2.5 GHz Intel Core i5
Memory — 16 GB 1333 MHz DDR3
Graphics — AMD Radeon HD 6750M 512MB
Hard Drive — 206.96 GB free

Edit: I managed to get the demo to work by quitting all applications, then restarting my iMac. I had already tried this and it didn't help, but I randomly decided to try it again, and it worked. I don't know if it'll help you Mac folks with newer computers and operating systems, but it's worth a shot.
 
 
 posted in Leaves: The Journey on Aug 1, 17 7:56 PM
I found it seriously disappointing that so many reviewers who have labeled themselves "experts" posted excoriating reviews of this game, simply because they personally found it too difficult for them.

This is an adventure game; they typically don't include strategy guides, explicit instructions, and hint buttons. You're required to be observant, take notes and make drawings, and experiment with the puzzles you encounter. No one holds your hand in adventure games.

If you dislike this type of game, don't play them. But don't complain that it's too hard, counsel other gamers not to bother trying it, downvote it because you couldn't figure it out, and demand that BFG not carry this type of game in the future. Quite a few of us like adventure games and wish there were more. And this one was excellent, BTW.

A charmingly surreal environment is the setting, and the goal is to find all the leaves belonging to the Treefruities' home tree. You'll need to pay attention to every detail, because clues for the various puzzles are everywhere...and so are the leaves. Some are in plain sight; others you don't get until you gather clues and solve a multi-level puzzle.

The puzzles include pattern recognition, color theory, deciphering symbols, determining the correct order of things, restoring complex images, and more. Quite a few of them are original, and the ones that are familiar have had their challenge level stepped up quite a bit.

There is a map, which notes where the leaves are located, but does not transport. However, each area includes a pylon which will transport you to all other areas...but you'll have to unlock each area first. Navigation is noted either by arrows at the edges of the screen, or by the cursor lighting up, which it does at doorways, ladders, staircases, and wherever the scene's design visibly changes.

The inventory is at the top of the screen. Move your mouse there, and a clickable button will drop down. Click it, and your inventory will drop down. Some items are usable; others are solely for informational purposes. And there's one item that is reusable wherever you like.

I found this game to be a breath of fresh air after so many nearly alike HOPAs, most of which provide no challenge at all. Hopefully, we'll see more from this dev, and many more games like this one.
 
 
Downloads fine. Won't run. All I get is a blank white screen and the spinning beach ball of doom. Uninstalled/reinstalled. Same thing. Really tired of buggy Mac versions.

Mac OS 10.11.6
2.5 GHz Intel Core i5
16 GB RAM
246.6 GB free space on drive
 
 
 posted in Love Chronicles: Death's Embrace Collector's Edition on Jul 10, 17 5:27 PM
Vendel's games never work properly on any Mac running any OS. And they never bother to fix the issues. I had multiple problems with this game, culminating in a crash during the demo, whereupon I gave up.

Spirit of Revenge: A Test of Fire CE also crashed on me, and the extremely long error message that popped up included multiple references to a completely different game, Love Chronicles: Beyond the Shadows, which strongly suggests that Vendel is reusing buggy images, renders, and programming to create new games that also crash and/or are full of bugs.

No update for the Mac version of A Test of Fire was ever offered, and more than a year has passed, so I wouldn't hold my breath waiting for the bugs in this game to be fixed. Frankly, BFG should drop Vendel altogether.
 
 
 posted in Tales of Terror: Art of Horror Collector's Edition on Mar 30, 17 10:12 AM
This game was not ported properly for the Mac. I'm running 10.11.6 and have run into problems that make the game unplayable. Please don't tell me to uninstall and reinstall, because it's NOT me.

First, the game comes up in square format and there's no option for 16:9 aspect correction. Part of the game is off the bottom of the screen. Unplayable. No idea why this dev chose to even make a square format since you can't buy a square CRT monitor anymore; no one makes them. Sure, I could switch to windowed mode, but on my HD monitor, I'd be playing in a tiny window. Nope.

Second, the volume sliders are non-functional. The music is overwhelmingly loud even with the slider all the way down, and the voiceovers are inaudible even with the slider all the way up. Another nope.

Third, in the first game scene, the only thing I could click on on the table was the broken phone. I couldn't read the note or click on the coin purse, even though the hint button insisted I needed to look at the coin purse. Unplayable.

Clearly, you need Mac beta testers. I volunteer as tribute.
 
 
 posted in Awakening: The Golden Age Collector's Edition on Feb 27, 17 4:49 PM
1. Once you reach the Forest Portal, both the hint button and the map's available actions function stop working. Both keep saying there's something to do at the Forest Portal, and the hint button will only transport you there, long after you're done there.

2. The HO scene in the train station (where the SG says you get the "fine mesh") doesn't work. It's impossible to click on any item on the list. The wrench, firecracker, and multiple other list items are clearly visible, but nothing happens when I click on them. The only thing the game will let me do is pick up the four bright red wheels, but there's no indication as to where they go. The SG is completely unhelpful, since it only says "complete the HO to get the fine mesh."

Because of #2, the Bonus Game is unplayable, so I've wasted my money on the CE.
 
 
 posted in Spirit of Revenge: A Test of Fire Collector's Edition on Jan 14, 17 3:12 PM
What a surprise, a Vendel game that crashes on my Mac. It was either that or a bug that makes the game unplayable.

Since one or the other has happened with every single one of the games Vendel has released in the past few years, since it affects both Mac and Windows users, and since they NEVER release an update to fix the issues, I strongly suggest that BGF stop producing their games. It's clear that Vendel doesn't know how to port games to the Mac, and that they don't beta test enough.

The lengthy error message I received when THIS game crashed included multiple references to images, renders, and programming from Love Chronicles: Beyond the Shadows, which strongly suggests that Vendel is reusing buggy images, renders, and programming to create new games that also crash and/or are full of bugs. I doubt this is the kind of product BFG wants its name on.

Mac OS 10.11.6
2.5 GHz Intel Core i5
16 GB 1333 MHz DDR3 Memory
AMD Radeon HD 512 MB Graphics Card
500 GB SATA hard drive with 269.74 GB free

And, no, I'm not wasting my time uninstalling and reinstalling. My BFG Game Manager is up-to-date, as are my Flash and Java. It's not me. It's Vendel.
 
 
I didn't find this too different from every other Eipix game released in the past few years, with one exception...some of the puzzles actually provided a challenge. Other than that, The Lost Paradise appeared to be the same thinly developed, slowly moving storyline with "unhidden object" scenes that can be completed in less than a minute, and endless conversation and cutscenes to click through.

Also, I found Philip Drake infinitely irritating. He's a millionaire who can't manage to do a single thing for himself—like match up symbols—but repeatedly ordered me around with an annoying whine. "Get our stuff from the backpack." "Go get stuff from my briefcase." However did he manage his 40 years on Earth without me? Sheesh.

As always, the production values are high, but this isn't an animated movie...it's a game. I'll take substance over style any day of the week.
 
 
This game is completely unplayable on my iMac running 10.11.6.

The opening animation began normally, then became overlaid with increasingly larger white blocks. By the time the menu screen appeared, the entire screen was white with a blinking cursor in the center. I successfully jumped to a conclusion, typed my name, and pressed "return."

Some of the whiteness cleared up at the top right corner, so I tried a blind click and part of the options menu appeared...just the volume sliders. At this point, I gave up because I couldn't see the "play" icon.

Since I couldn't see the "exit" icon either, I attempted to force-quit. It didn't work. Neither did the power button. I ended up having to cut power to my iMac to get out of the game.

I have to say that this is pretty bad quality control. This kind of garbage should have been cleared up during beta testing, or is that only done for the Windows version? If so, you're shorting your Mac members. We get buggy games too frequently.
 
 
 posted in Kingdom of Aurelia: Mystery of the Poisoned Dagger on Nov 29, 16 5:11 PM
PROS:
• Engaging storyline with several plot twists.
• Eye candy graphics including excellent poser work and stunning detail.
• Mostly an adventure game.
• Sequel to Namariel Legends: Iron Lord.

CONS:
• Exact same soundtracks as the first game.
• Exceedingly horrible English including the puzzle instructions.

I still gave it four stars because I enjoyed playing it and believe it has replay value.
 
 
 posted in Epistory: Typing Chronicles on Oct 4, 16 9:05 PM
On the game page, I posted a review upon completion of the demo, so I wanted to post a supplemental one now that I've finished the game. So, my review on the game page is more of an overview, while this post gets into more detail.

First, if you play every single world, look for all the secret treasure chests, and activate every battle zone, the full game will take at least 12 hours, if not longer. I played nearly 16 hours, because I explored every world thoroughly.

Aside from the main world, which is called The Bridge, there are eight sub-worlds:
• Burning Hollow - underground world
• Forgotten Forest - forest world
• Drowning Halls - water world
• Ice Mausoleum - ice world
• Creation City - mechanical world
• Crystalline Mine - dark world
• Shattered Isles - air world
• Lost Desert - desert world

You eventually earn four different powers: fire, ice, spark, and wind. Switch between them by typing those words. Some enemies can only be destroyed by a certain element, and some end boss battles are mixed. For example, if you're using fire power and an ice monster with the word "enemy" approaches, you must first type "ice," then "enemy" to switch from fire to ice, then attack the insect.

The difficulty level increases throughout the game. I encountered some insects with words like "multimedia," "schoolteacher," and the like. But don't let that worry you if you're not an accomplished typist! The game has a built-in adaptive difficulty level. If you type more slowly near the beginning of the game, the insects won't approach you so quickly once the words become longer. The game adapts to YOUR skill, not the other way around, so that any level typist can enjoy it.

Additionally, there are upgrades that help you out, which you "purchase" with the points you earn in the game.
• Velocity - increases the speed of your fox
• Intensity - increases the time you're given on a combo
• Knowledge - shows the hidden chests on the map
• Perseverence - lets you start a combo with more time
• Teleport - lets you teleport (on the map) to the entrance of any sub-world
• Knockback - makes your "hits" repel insects away from you

Personally, this is one of the best games I've played in a long time. It's innovative in its design, gameplay, game mechanics, and graphics. I found it challenging and fun, and believe that it has a high replay value, so I definitely recommend it. This one is really difficult to describe; you really have to try the demo to get a feel for it.
 
 
 posted in Epistory: Typing Chronicles on Oct 4, 16 8:38 PM
stargate100 wrote:Hi I had been playing this game with no issues at all screen resolution was fine apart from when I got to creation city and the maze all of a sudden the electric thing when i pressed my spacebar to type I couldn't see it to type it had gone from my screen in a certain place in the maze ie trying to get to the other side of the maze to get out. I am just asking which screen resolution I need to play this particular level all levels before have been fine.

pc windows 10


Hi, stargate!
This isn't a bug. I had the same trouble. You need to navigate through the maze until you get to a spot where you can see the electrical tower. It's kind of a back-and-forth process, since the tower opens one set of gates when it closes the other set.

What I did was stand in a place where I could see most of the gates, then activate the tower a few times to plan a path through the maze. I hope this helps!
 
 
I'm wondering why 13th Skull doesn't work with El Capitan. I know the specs say 10.4, but so do the specs for Dire Grove, and that game works perfectly with El Capitan. (I know because I just finished playing it 15 minutes ago.)

13th Skull installs and runs, but the initial cutscene is black (sound only) and so is the menu screen. Yes, I've tried un- and re-installing it. And my Flash etc. is up-to-date.
 
 
rebeccacz wrote:i just download the game but it's black when i open and i can only hear the sound without any image!!


If you're playing on a Mac, the same thing just happened to me with El Capitan. Since the specs on the game page say OS 10.4, I'm assuming this game won't work with more recent operating systems.

Personally, there are a lot of older games I really enjoy, so I'm going to use an emulator to install the server version of 10.6.8 in a partition so I can still play them.

Added in edit: I retract my above statement, as I just successfully played Dire Grove which is also specifies OS 10.4. There may be another reason why we're hearing the sound portion of the cutscenes, but not seeing the video portion.
 
 
 posted in Lost Lands: The Golden Curse Collector's Edition on Aug 8, 16 12:30 PM
August 8th, and I'm having the exact same problem. And it absolutely IS a glitch.

1. The recipe does NOT say the ingredients must be added to the pestle in a particular order. However, if you don't add them in the order they're listed, you can't take the pestle once the ingredients have been ground with the mortar.

2. The hotspot to get the mortar to grind the ingredients must be a single pixel. Meanwhile, every time you miss it, Maaron endlessly repeats himself, rapidly changing your frustration to rage.
 
 
LunaNik wrote:I just went to replay this game, and it repeatedly crashed about 30% into the loading process. What's up? I had no issues the first time around, when I initially bought it.

OK, so it's not our computers, because I'm on a MacBook 5,1 (2Ghz Intel Core 2Duo) with 8GB RAM, OS 10.6.8, Flash also updated.


It's worse. I've upgraded my computer to a newer iMac running OS 10.11.3. Now, as soon as I get past the "please play with sound" screen, the game crashes. Both The Tree of Life and The Living Mountain run fine.

Edit 9/21/2016: Upgraded to OS 10.11.6 now, and the game consistently crashes at 39%. This has happened with varying Mac OS from 10.6.8 through 10.11.6, so it's NOT our computers; it's the game. Would someone please address this issue? I'd like to get my money's worth by being able to play this game more than once. Please note: "Both The Tree of Life and The Living Mountain run fine."
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator