Posts created by herisf

 
 
 posted in Midnight Castle on Feb 1, 15 2:27 PM
Today my inventory is showing only the pets. I cannot see the tickets or inventory items. Definitely odd.

Playing on an iPad 2 on the latest iOS update.

--- This issue resolved itself. I left the game and when I returned the normal inventory was there. ---
 
 
 posted in Midnight Castle on Sep 12, 14 7:58 AM
Craftsmith Achievement: I have never been able to maintain an accumulation of crafting more than 10 items in 30 minutes. I have at least twice been up to 14 items, at least once up to 13. When I leave the game and return, I am always reset to 10. I didn't notice this for quite awhile, but has gone on for at least 15 levels (am currently on level 33). At this point I am resigned to this never working and not achieving these goals, or getting the final Superstar achievement.

I play on an iPad 2 with 13 GB capacity running iOS 7.1.2 (11D257). While I know that I will never be able to get these achievements, it would be nice if you could fix this so other players could.

Thanks for creating and supporting this fun game! I play at least once each day. It's a great relaxation from the Real Life daily grind!
 
 
 posted in World Mosaics 5 on Mar 29, 12 8:05 AM
I'm finding this game highly entertaining, but not for the gameplay. As others have said, the boards are not difficult enough. No, it's the content that is amusing - who knew that feathers were edible? I didn't know that they could be included in Thanksgiving stuffing! There were other bloopers scattered throughout the various holidays. The developers really needed to have someone better versed in English review their facts.
 
 
 posted in Haunted Legends: The Queen of Spades on Apr 24, 11 7:30 AM
Carnnie wrote:Where can I find the key to that room?

Hopefully by now you have found it. But if not, it's in the room with the suitcase on the floor. Move the suitcase using the oil, and then look in the chandelier above it.
 
 
Playing on an iMac here, and had troubles with the pipe puzzle. Twice I picked up pipe pieces, put them in place, and then they stayed adhered to my cursor and wouldn't let me drop them *anywhere*, not even back into the pipe pile. I had to back out of the game, then get back into it. Once back in I was able to continue where I left off (at least it saved my progress) but then the same thing happened *again*. Not a game-stopper, but highly irritating, since I knew where the pieces needed to go. And a pain in the a** when doing a trial (although I suppose it's a good time to have problems!). I'll be waiting for the SE to see if the problems have been addressed.
 
 
 posted in Dark Parables: The Exiled Prince Collector's Edition on Feb 28, 11 4:47 PM
I'm on an iMac running Snow Leopard, and also cannot load DP-EP. I've deleted the game files as mentioned by AmandaGator in the Mac forums, emptied trash and restarted the computer, twice. Still won't load game and the GM crashes. I'll wait to see if the SE does any better.



 
 
 posted in Kuros on Dec 4, 10 9:47 AM
I had no problems downloading, but got stuck in the fire area. When you use the mallets so that you can break the rocks to obtain your items, I accidentally used two mallets in the same area - and now need a mallet to get my last item. So far nothing has regenerated after closing out and restarting x2. Good graphics and the puzzles are fairly easy. A decent game, but one that I can wait to get.
 
 
 posted in Mysteries of Magic Island on Nov 30, 10 7:39 AM
The game ran fine on my iMac, but the graphics were a bit blurry. As others have said, a standard hidden object w/ much to-ing and fro-ing. By the end of the demo hour I was already on chapter 4 of 6, so not very long for me. Puzzles were easy and the hint recharges fairly quickly. All in all, there are better games out there with sharper graphics (which I much prefer) and more challenging puzzles. Not a buy for me.
 
 
 posted in The Seawise Chronicles: Untamed Legacy on Nov 12, 10 7:42 AM
Same here - the Intro keeps looping, absolutely no improvement from before the "fix". Gee, thanks . I have an iMac w/ Intel processor. I won't bother with specs, because I doubt the issue will be fixed, since nothing has happened since I last reported it.

We haven't gotten any decent SE games lately, so was really hoping this one had gotten fixed. Ah well, the usual neglect.
 
 
 posted in The Seawise Chronicles: Untamed Legacy on Sep 26, 10 7:48 AM
Just downloaded & tried to play the Mac version of the game - the beginning scene where the fairy enters, flies away, and then you go towards a gate just cycles over and over. Had to force quit to get out of the whole thing.
 
 
 posted in Youda Legend: The Curse of the Amsterdam Diamond on Sep 11, 10 5:55 PM
Look carefully at the symbols on the box. Put the rings into the appropriate column (round, diamond, triangular). Also note that the box has a blue column and a blue row. So yes, blue rings go there, also by shape. Good luck.
 
 
 posted in Golden Trails: The New Western Rush on Sep 4, 10 12:31 PM
soblessed57 wrote:
tomjard wrote:I just tried to download this, but as usual, it is only available for intel based macs. Not everyone has brand new macs.


Just curious how often is this an issue here with BFgames for Macs? Are the mac games really only for intel-based macs,because if I bought a mac, I don't think there is any way on earth I would consider corrupting it by putting windows in it! Getting away from Windows with all the viruses,SPWARE/MALWARE, is the whole reason that I would consider paying triple the price of a PC to switch to Mac! My dream machine is the MacBookPro laptop.

My iMac is an intel-based Mac. No need for Windows to be loaded. And, if you want Mac gamers to respond to non-specific game questions, you need to go to the Mac forum in the Chit-Chat area.
 
 
 posted in Drawn: Dark Flight ® Collector's Edition on Sep 3, 10 6:24 PM
Thank you - I was stuck here too. Of course, AFTER that I then saw the arrow in the street (sigh...)
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Aug 16, 10 6:57 PM
cyndyk2 wrote:I'm trying to buy the fish food from the storeowner and it won't let me. He tells me to look around, and I can click on the fish food, but nothing happens from there; I have plenty of crystals, I know where to use the fish food and I have the other two gems in place in the gazebo, but I cannot get that dratted fish food off the shelf to save my life. Is this another glitch or did I do something out of order? Has anyone else run into this problem, or is it just me? I'd REALLY like to get to the end of this thing eventually! LOL

In the game, you need to know that you need the fish food. So once you try fishing in the pond and are not successful, *then* you can buy the food. The same is true for all the puzzles - you have to have a reason to go buy or look for the item.
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Aug 9, 10 5:29 PM
Macfun wrote:I have tried to play this game by signing on as different players when I hit a glitch. I have a Macbook with a 10.6. I downloaded the updated versions of adobe, flashdrive, etc after getting a new HD. What I am discovering is if you get past the orchard, then other things may go wrong. Under one sign in, I got all the way to trying to find the gems for the diadem, but I can't find the gnome necklace on the statue in the tower courtyard. I am being instructed to buy the breathing apparatus, but I don't have enough crystals. I have checked the walkthrough, and find I need to do the courtyard digging and dynamite to continue. (Other players on my game got froze out at the orchard again or the deer wasn't injured. Just weird stuff) I tried to not click on any items before the prompt in the bottom box. I thought maybe collecting things too early was having an effect on the game. Can't figure it out)

While I like this game, the frustration of how it runs on Mac takes the enjoyment away. I give up.

The statue in the tower holds the Gnome Key (if I recall correctly). The Gnome Gem is obtained elsewhere. You have to leave to Queen's Garden South and go find the gnome and do something for him (catch a bird). Once you complete your quest he will give you the Gem. Good luck.

edited to correct the Key name.
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Aug 9, 10 5:24 PM
As evidence that I've spent *way* too much time fooling around w/ this game, I found a way around the "orchard problem". Once you open the orchard door, walk your character around, do NOT teleport using the map. I walked around, healed the deer, took the deer to the orchard, and watched the deer hop around the orchard. I then went to get the squirrel and started using the map again, and was able to get past the orchard to the Queen's Garden North. Walking the character around also seems to get around the problem of the deer being in 2 places at once (on the cliff and on the ground w/ a broken leg).

I hope this works for others of you out there who just want to play the game. Good luck!
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Aug 8, 10 1:53 PM
alexakaruda wrote:I've noticed in the forum that other people are having trouble with the Muse of Writing, too. I have the quill (not the swan feather--I already traded that in), and I got the quest for the rose key, but when I go to the gazebo, I can't get the next quest. It just says with the hint button that there are spaces there for gems, but I can't click on them (and clicking on the lever does nothing, either). As a result, I can't do anything with the Muse of Writing (clicking on her does nothing). Do I have to restart the game again? Help!
You need to complete the Muse of Writing quest by clicking the quill on her and obtaining her jewel.
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Aug 8, 10 1:51 PM
My Mac version of the game froze when I put the squirrel in the orchard first - I had to force quit, and when I went back I was still stuck. I ended up deleting that profile and starting over (going much quicker since I actually knew what to do and where to go).

If I put the deer into the orchard first and then the squirrel, it ran fine. I haven't tried putting both animals in at the same time, though, so don't know how that works. For this portion of the game, do not follow the plaque instructions.
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Aug 8, 10 9:10 AM
Just wanted to say that I've played the entire game and it ran fine for me on my iMac running 10.6.4. No problems (except for user brain errors). A fun and enjoyable game, with a nice twist to the ending.

ETA: on replay, my game freezes if I put the squirrel in the orchard first, or both the squirrel and the deer together. Even on Force Quit or after restarting my computer, I'm frozen at the same scene. I ended up deleting my profile (twice) and starting over.
 
 
 posted in Elixir of Immortality on Aug 1, 10 6:39 PM
Sound stopped after about 5 minutes of playing the demo. I have an iMac running 10.6.4. The graphics look great, and the puzzles look interesting. But with no sounds or sound effects, this is a no buy until it's fixed. Sound did return when I closed out and re-opened the game, but why bother when it will probably go away again?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator