Posts created by EmeraldY

 
 
 posted in Queen's Quest 2: Stories of Forgotten Past on Nov 17, 16 4:18 PM
How do you give the milk to the cat on the roof? I can't see a bowl or other place to pour it, and the cat is not interested in my pouring it over his/her head!! TIA, Emerald
 
 
 posted in Elven Legend 3: The New Menace Collector's Edition on Jul 28, 16 8:16 PM
The guide for level 16 doesn't mention it, also doesn't show it. I tried moving the mouse all over around the black hole, and sometimes there were minor things I could do. But nothing that led me to the resources I need to proceed. Help!
 
 
 posted in Sir Match-a-Lot on Feb 9, 16 8:24 PM
I love this game! BUT...is there a way to get to this wheel when I want to or do I have to wait for some circumstance to occur that brings it to me? Signed, Confused
 
 
 posted in Lost Island: Eternal Storm on Sep 12, 15 7:15 PM
Burf, your memory is PERFECT!! I got stuck before I knew what the quest would be, but it indeed was healing the elf woman. And the thing I didn't do was to USE the darn hourglass...not knowing the quest, I didn't realize how important that was. (My nearly 73 year old brain cell was obviously on a coffee break!) I used it, it worked, and I am happily back doing quests.

Thanks so much for your solution!
 
 
 posted in Lost Island: Eternal Storm on Sep 12, 15 2:11 PM
Thanks, Valdy. No, it's not (at least so far!) healing the elf woman's wounds.

I am getting better at doing chest puzzles, and my husband loves doing them. so he is a great help!
 
 
 posted in Lost Island: Eternal Storm on Sep 11, 15 5:19 PM
Hi tiggeress, thanks for the suggestion. The only hourglasses I could find in my collections were bonuses given when a collection was completed...and I couldn't exchange any to get an hourglass. I even bought an hourglass ($$$$$!!) but that
didn't help. (SIGH).
 
 
 posted in Lost Island: Eternal Storm on Sep 10, 15 8:28 PM
i am only level 14. And yes, I have tried clicking on the item, to no avail.

Viridis gives you the quest on a much lower level that I am on, but not being taken to the Target means I can't get the item...unless someone knows another way!

Thanks, BarbaraFish
 
 
 posted in Lost Island: Eternal Storm on Sep 10, 15 7:07 PM
When I get this quest and click on "To Target" it only directs me to the info about the item and doesn''t take me to the target. I gave up on it days ago but realize I haven't had a new quest since. HELP!! Can someone tell me where the target for this quest is located?

I ADORE this game, but I HATE the chest puzzles. I simply can't do them. Very frustrating because I never have enough funds to buy the item that solves the puzzle for me. ARGH

Thanks for any help you can provide!

Emerald
 
 
 posted in Awakening Kingdoms on Feb 24, 14 2:36 PM
Thanks, Zephyr. I'll keep trying...sigh!!
 
 
 posted in Awakening Kingdoms on Feb 23, 14 4:39 PM
I have been trying to find the Clippers during probably 8-10+ visits to Dawnshadow Lake, which is where Mira tells me to go for this quest. The Clippers seem to be nowhere to be found. Is there a glitch? I'm getting frustrated, and I don't want to just do DS Lake forever!!
 
 
 posted in Rush for Gold: Alaska on Jul 7, 13 6:39 PM
I got through the level! I carefully watched what I did with the coal this time. After I got the 50 there was still more coal. Be sure you have the girl check out every spot for exploration as they might be coal (or gold diggings!).
 
 
 posted in Rush for Gold: Alaska on Jul 6, 13 6:05 PM
This level (the first one the sheriff appears on) asks for 50 coal. I have 30 coal, but can't find another coal deposit! Is this a glitch or am I just missing it? Help, please!!

BTW, I love this game!!
 
 
 posted in Age of Enigma: The Secret of the Sixth Ghost on Feb 9, 13 5:42 PM
I have the clock set to 5:55 but nothing happens! Am I missing a step?

Thanks in advance for any help!

Emerald
 
 
 posted in E.P.I.C: Wishmaster Adventures on Sep 25, 12 11:35 PM
ARGH! I put the vines in the volcano and they burned up, so now what can I do?!?! Help!! I can't seem to find any more vines, so I'm really stuck.
 
 
 posted in Allora and The Broken Portal on Sep 7, 12 5:06 PM
I found it! Thank you so much! Knowing it was an Egyptian eye helped!
 
 
 posted in Allora and The Broken Portal on Aug 5, 12 10:40 PM
I can't find the eye and I've been looking forever, hints don't show anything. If you found it, could you please tell me where? Thanks in advance!

Emerald
 
 
 posted in Inspector Magnusson: Murder on the Titanic on May 15, 12 9:06 PM
Thanks so much, Sheerija, I'll go try it!
 
 
 posted in Inspector Magnusson: Murder on the Titanic on May 14, 12 4:18 PM
There is a trunk tied to a car in the hold. I can find 3 of the 4 needed coins but not the 4th. When I try to use a hint, the hint gets used up but doesn't show anything!
It must be in there as the game won't let me go to any other area, but I sure can't find it. Thanks in advance, Emerald
 
 
 posted in Aztec Tribe: New Land on Mar 18, 11 2:49 PM
Of course! That makes sense, Dragon! DUH. Thanks for clearing that up!!
 
 
 posted in Aztec Tribe: New Land on Mar 17, 11 4:44 PM
Thank you so much! So it has nothing to do with "trading with other towns?"!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator