Posts created by justaques

 posted in Beyond the Invisible: Darkness Came on Jan 11, 18 4:48 PM
After I played the demo of this game I wasn't ready to give up and delete it like many others I've tried recently. I actually wanted to see what it really was all about, so I purchased this game and I was very pleasantly surprised how intriguing and interesting it was. It was like reading a fairly good book. The hints were very helpful and the game worked perfectly.with lots of problems to solve.
 posted in Grim Facade: A Deadly Dowry Collector's Edition on Sep 25, 17 3:54 PM
Very disappointed with this game. I always looked forward to each new Grim Façade game because it was always worth waiting for and would keep me busy and intrigued for a lot of hours because it would be somewhat difficult with lots of things to do while solving the many puzzles, mini-games, etc. This game was very short throughout and the theme was uninteresting and far-fetched. I had no problem playing this game until I just started the bonus game when it locked up and I had to do a Ctrl/Alt/Del to get out of the game. After that I had no problem playing the bonus game other than, in too short a time, the game ended leaving me with the feeling that the developers simply ran out of ideas, closed up shop and went home. Not worthy of CE status.
I have a problem: I was trying to purchase this game along with Grim Façade| A Deadly Dowry to take advantage of the two for one special and something happened because I was informed that I already own it and I was not aware of purchasing it previously. Would it be possible to check whether I actually did purchase it or not.
 posted in Reflections of Life: Call of the Ancestors on Sep 19, 17 1:56 PM
When I downloaded what I assumed was the trial version of Reflections of Life: Call of the Ancestors SE, the game showed I had only 5 minutes left to play. I was not able to get access to the 5 remaining minutes so assumed I must have at some point played the trial to this point and liked the game and planned to buy it, so I bought the full version of the game with the intention of playing the game in its entirety. How wrong I was - I have not been able to access any part of it. When I push the play button a message comes up that I now own the full version and can play it with no interruptions but it just sits there and is completely inaccessible. I have played many games successfully both before and after this one and am at a loss about what I can do . I am using Windows 10 on a PC and hope somebody has some answers for me.
Tried to get interested in this game and could find nothing to keep me playing. Felt like I was playing something from about ten years ago. Very disjointed game-play so will delete.
 posted in Maze: Nightmare Realm on Sep 10, 17 7:29 PM
I have to say that I thoroughly enjoyed playing this game from beginning to end. After having problems finding games that would work with Windows 10 lately, I was afraid this might be another one, but happily it played without a hitch. Lots of mini-games and problems to solve and certainly not boring for me.
 posted in Reflections of Life: Call of the Ancestors on Sep 9, 17 3:32 PM
Downloaded this game but when I tried to play it and couldn't there were only 15 min. left to play game so I thought I must have played it and really liked it, so I purchased and downloaded it. However from that point on I have not been able to open it or any other games I tried to play so I am very upset since I am usually able to play most games with little or no problems. I have a PC running Windows 10 - 64 bit. Is anyone else having this problem or is it only me I uninstalled my program manager and re-installed it. but did make any difference.
 posted in Vermillion Watch: Order Zero on Sep 3, 17 5:19 PM
I was not liking Vermillion Watch: Order Zero on my PC running Windows 10 64 bit and attempted to uninstall it but nothing happened. I thought it was another quirky game and pushed install l to see if it would. When it was finished re-installing the game a message came on that I had only 2 minutes left to play and I should purchase it although I had already purchased it. After that I had no problem uninstalling the game, but I really did not like this game and found it very unenjoyable to play.
 posted in Ghost Files: The Face of Guilt on Jul 26, 17 5:28 AM
get error access violation at 0X774D213B and it exits game.
 posted in Kingdom of Aurelia: Mystery of the Poisoned Dagger on Sep 19, 16 7:05 PM
I found that whenever I got stuck at any point in the game the only solution was to uninstall the game and re-install it and I actually had to do this three times in order to complete the game and it worked perfectly each time I did and after finishing the game I have to agree it turned out to be a terrific game. I have Windows 10, 64bits.
 posted in Sea of Lies: Beneath the Surface on Mar 10, 16 5:43 PM
Having the same problem. Have you gotten past this part yet?
 posted in Fear for Sale: City of the Past Collector's Edition on Dec 1, 15 5:02 PM
This happened to me with the mailbox too. Since it was very late I exited the game and left it overnight and when I opened the game next morning it started at the point I left off and I had no problem whatsoever getting in the mailbox to get the wire, firefly, etc and was able to play the remainder of the game straighthrough. It seems to me that parts of the game are lost after a lengthy time of playing, so exiting the game for a lengthy time resets and restores it again. I'm using Windows 10, 64 bit, and I always use alternate method to download because it seems to work better with windows 10.
 posted in Medford Asylum: Paranormal Case on Oct 21, 15 8:29 AM
Couldn't figure out what was going on so deleted and will wait for something playable to come along in the near future, hopefully.
 posted in Kronville: Stolen Dreams on Sep 14, 15 8:41 AM
I played to end of the Beta and it seems much easier to play so improvements were made to the hints and there is now a skip too which I'm sure wasn't there before when I first tried the game. As I got further into the story I found it very interesting and worth purchasing.

Thanks for all your help DD
 posted in Kronville: Stolen Dreams on Sep 14, 15 7:28 AM
Was this game ever introduced before perhaps under another title? I downloaded and played a bit of it and it is very familiar.
 posted in Whispered Secrets: Golden Silence on Sep 5, 15 6:16 AM
Win 10 - I'm getting this message after game quits running "lua runtime error"

To update original post: Couldn't figure out what this message was so I deleted game and re-installed twice - once under original name and it didn't do anything so I uninstalled and used another name and the game worked perfectly with no further problems. This a really great game.
 posted in Runaway Express Mystery on Sep 24, 14 4:09 PM
I am stuck and I have nothing in my inventory to use. I have gotten to the point where the game tells me that I need to confront the guilty person with the facts and I cannot communicate with anyone in the game plus the hints say that there are no hints available so, being so far in the game, I hope I can do something other than restarting the game from the beginning under a new player. The game has been very interesting and I've had no problems up to this point. I am using a PC running Windows 8.1
 posted in Dream Catchers: The Beginning on Sep 10, 14 8:02 AM
Is this necessary to play this game? It is holding up the installation of Dream Catchers the Beginning because it wants to install it to play this game but after reading about it I see that there will be issues that I do not wish to deal with such as errors, etc
 posted in Haunted Halls: Nightmare Dwellers on Jan 1, 14 12:54 PM
I just got to this point and the same happened to me. Has there been a fix for this problem yet?
Congratulations Just The Facts

Your reviews are always welcome and the best! Keep up the good work!

Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator