Posts created by sinshack

 
 
 posted in The Fall Trilogy: Chapter 1 on Jan 10, 10 8:04 AM
[quote=Coronagold
I'm curious to the length of play.

I'm not a big fan of 360 nodes like I used to be back when I had an equilibrium.


I played for about 3-1/2 hours, but I did stop in the middle to squeeze some orange juice for breakfast, so it was probably about 3 hours actual play time. It was a very intense 3 hours, though, so I didn't feel cheated.

If you can't handle the 360, you can turn it off! That's my favorite feature of this game, because I get motion sickness when I play the 360 games and can't last more than a few minutes. I've had to delete a lof of great adventure games because I just can't play the 360. I hope the next 2 chapters are released the same way, giving the gamer a choice of 360 or arrow mode. That satisfies everyone.

Julie S.
 
 
 posted in The Fall Trilogy: Chapter 1 on Jan 10, 10 7:59 AM
Diat60 wrote:I'm curious about the title, specifically the word "Trilogy". Does this mean there are two more parts of the game coming or is this all there is?


When you get to the end, the closing screen says "Chapter 2 coming soon" so this is the first game of 3 parts. I'm looking forward to the next 2!

Julie S.
 
 
 posted in The Fall Trilogy: Chapter 1 on Jan 10, 10 7:52 AM
judimose wrote:Well, I downloaded it twice, and got an error message both times - couldn't even get to the opening cut-scenes.


Contact Curstomer Support, and they'll walk you through any problems. I'm running on Windows Vista, and I didn't have any problems.

Julie S.
 
 
 posted in The Fall Trilogy: Chapter 1 on Jan 10, 10 5:30 AM
Fabulous game, and it solves one of my pet peeves - the 360 degree, nausea-inducing format can be turned OFF!! In fact, that should be one of the bullet-points in the "why to buy this game" ad. I've had to pass on too many wonderful games because I get motion sickness from that format.

Very interesting game play, more of an Adventure format that HOG but a bit of both. The puzzles are fairly challenging but I was quite proud of how far I got before I "cheated" and tabbed over to the walk-thru.

It doesn't look like a very long game, maybe 3 hours based on how far I am compared to the walk-thru. I just finished my trial period and didn't hesitate to buy it because I'm having so much fun. Nice artwork, and the story line so far is interesting. I'm not sure about replay value because you will be looking for the same items each time, but for about the price of a fast food burger combo I think it's worth the price!

Great job!
Julie S.
 
 
 posted in The White House on Jan 9, 10 10:38 AM
For those who get stuck on the lawn - go to the Journal and chose a new location from the map!

This was a real "Duh" for me - I uninstalled the game and replayed it from the start, and noted the pop-up about using the journal to go to new locations on the map. Since we didn't have to do that in any other part of the game, I completely forgot about it!

I'm posting this in the other forum on this subject, so more people who are having the problem can see it.

Julie S.
 
 
 posted in The White House on Jan 9, 10 9:10 AM
PamsEldorado wrote:Well, once again, I've downloaded The White House and then foolishly bought the game. I've made it through to all the levels without problems, but now I cannot finish the last one. I've gotten one mirror and then nothing; I can't go any further. The screen isn't frozen, but the hints don't work and I've clicked every possible place on the White House Lawn.


azmesa340,

I have the exact same problem. I tried exiting the game and returning - the only thing that happened is that all the items I just found returned to the scene, but I didn't get the list of items to find again so I'm stuck. ARRGHHH!!

Julie S.
 
 
 posted in The White House on Jan 9, 10 8:54 AM
I had no problems at all with the game - until I got nearly to the end! When I am looking for the mirrors, I find the first one and the game locks up, and it won't give me another list of things to find or a new location. I closed the game and restarted, and all the items I had just found are back again but there is no list of things to find.

I guess I'll just have to wait for the update - I hope it comes soon. It is a very good game, with lots of interesting facts and great artwork. Some of the scenes are a bit too dark, making it hard to spot the objects, but there are plenty of hints if you need them. I especially like the outline option, being able to see the outline of the object without having the actual location revealed.

Julie

ps. To the developers, I loved the professor's comment when he asked Miranda to hurry - those little gems of humor are what makes a game special.
 
 
 posted in Natalie Brooks: Mystery at Hillcrest High on Dec 23, 09 12:55 PM
The link to the blog walkthrough isn't working - it just leads to an empty page.
 
 
 posted in Mystery Case Files®: Dire Grove™ on Dec 11, 09 5:41 PM
1_of_5 wrote:I also see the morphing objects as part of the game. Maybe if enough people getting the standard version contact CS or post here about it they'll put out an update for the game that will reinstate the morphing objects? Worth a try.

I'll vote for it even though I got the CE.


For me, I had already purchased the $6.99 version before I saw the message in the forum that the morphing objects were left out of the "cheap" version. I wouldn't have purchased either if I realized that was the case, because charging nearly three times as much for the game just to get wallpaper and a few extra video scenes just isn't worth it. I, too, believed that the morphing objects were supposed to be in "my" version as well, or I wouldn't have bought it.

For future reference, BF, a logical price for a CE edition would be $9.99, not $19.99. You'd sell a lot more and there would be a lot fewer upset customers.

Very, very disappointing.

Julie S.
 
 
 posted in Mystery Case Files®: Dire Grove™ on Dec 11, 09 7:07 AM
Is there a reason why we aren't getting the Morphing Objects in this version? They are mentioned in the Blog Walk-Thru, and a poster in another forum mentioned that they didn't work for her, either.

Julie S.
 
 
 posted in Jane Angel: Templar Mystery on Dec 10, 09 12:15 PM
Pinky559 wrote:hello toall fishes. I am playing the demo and got to the part where you have to move these little glowing lights to an empty spot. I was having a problem so I skipped it. when i did it left the game on with the words "hydro carbonic analyser" and im stuck there. Can anyone help me to let me know what I have to do? Many thanks.


I didn't have that problem, but another poster did - probably on page 1 or 2. They shut down the game and re-started it, and were able to proceed.

For those having problems with the glowing lights puzzle, it took me a bit to figure it out, also. The object is to get the required number of same-colored lights in a group, such as 6 white lights. Every time you move a light without making a match, more lights are added to the board - so try to keep the center of the board clear, even if it means making a match that is not on the list. When you make a match of 6 or more, no lights are added to the board.

If you need more than 6 lights of one color, like 8 blue lights, you will need to make two groups of lights with a space in between, such as a group of 3 and a group of 4, then join them with the 8th light in the center. That gets really challenging in the bonus section, because it asks for as many as 16 lights of one color, so you have to arrange 3 groups to be joined by one in the center.

Hope this helps! That was a really fun and different mini-game.

Julie S.
 
 
 posted in Jane Angel: Templar Mystery on Dec 10, 09 10:08 AM
Eugene_Duranin wrote:Hi, I'm Eugene one of JA's developers (actually one of two ).
Thanks to everybody for attention. I'd like to answer some common questions I saw.

2) Bad spelling - I apologize if there is screaming mistakes! We aren't native speakers (Although all textes were under native speaker correction). So you should excuse us when we use one of possible word's translation (I'm talking about swabs and mobs). Hope it will not be a cause to miss interesting story and gameplay we made

Eugene,

I hope you didn't pay the person who claimed to be a native speaker and reviewed this game for you. It wasn't just a matter of using the wrong words, because the entire game was hard to follow because the sentence structure was so bad. Either the person lied to you and was not a native speaker, or they never even looked at the game.

English is a very difficult language because it "borrows" from nearly every other language on the planet and because American English is different from British English which is different from Canadian and Australian English. What is called a "mop" in America is often called a "swab" in England, and that wasn't a problem for me. The "biscuit" that is like a dinner roll in America but a cookie in England showed up looking like a cheesecake in your game, however, and I'm not sure where that usage came from. My main problem was trying to follow the dialog when the sentences either didn't contain a verb or was just confusing because it was translated badly.

If you are paying for translations, you might want to use testors from the countries where you will market the product. I'm sure there are plenty of people on this forum alone that would be happy try your game for free in exchange for honest corrections to the lanugage problem. Big Fish Games might be able to help you find testers who are real native speakers.

It is a great game with beautiful artwork and an interesting storyline. You will get a lot more repeat customers for your products if you can solve the language problem.

Julie S.
 
 
 posted in Chronicles of Mystery: The Scorpio Ritual on Nov 23, 09 1:17 PM
I figured it out - I just checked on the guard one more time.
 
 
 posted in Chronicles of Mystery: The Scorpio Ritual on Nov 23, 09 1:12 PM
I's stuck, despite the excellant walk-thru. When I am in the Vatican, trying to remove the cords from the drapes, I keep getting the comment that I cant cut the cords because the guard will notice. I've tried cutting them from both the chari and the ladder, but I get the same comment both places.

Does it have something to do with the dirty fireplace mantle? I can't find anything that will clean it, but that is the only thing in the room that I haven't done yet.

Julie
 
 
 posted in Gardenscapes on Nov 11, 09 1:22 AM
This game is the best value in a long time - very entertaining, long playing time on the first game, easily re-playable. The butler is hilarious.

The first time thru I played it in relaxed mode and bought the most expensice decorations just to see how it turned out (why on earth are the pink plastic flamingos the most expensive?) but now I'm playing it on timed mode and chosing what I like best. Makes me want to go out and buy an estate just to put in a real garden like this!

Great job on this one! Great graphics, long game play, no frustration factor because the objects actually look like what they are supposed to be, plenty of hits if you need them. The only thing that is irritating is how long it takes to re-load the garden at the end of each chapter, but it has to sort out your choices so I can understand why it takes so long.

Julie S.
 
 
 posted in Hidden Magic on Nov 1, 09 4:39 AM
Is anyone else having problems finding the "acorn" during the fights? That is the only item I have not been able to find in any screen, and I'm playing the game through for the second time. If you have found it, can you post a screenshot so I can see what one looks like?
 
 
 posted in Trapped: The Abduction on Oct 27, 09 5:29 AM
It took me a good 3 hours, and I had to use very few hints, and didn't need to use the walk-thru at all. BTW, I love the fact that the walk-thrus are available immediately most of the time - it saves me searching the web for one and cuts down on questions within the forums that might turn into spoilers for some players. (I've asked a few of those questions myself out of frustration!)

I loved the logic activities at the end of every chapter. As one person wrote on another forum, they were nice treats for your tricks. The ending was great, too - it took you to a logical, satisfying conclusion without being an actual conclusion, so I can't wait for the sequal.

We've had a great wealth of Hidden Object games this month - too bad the premium of getting a game free for every 5 (or was it 6?) games purchased was a one-time-only offer, because I think I would have earned 3 or 4 games this month! I hope the Chief Fish doesn't stick us with a bunch of Time Management games next month to even things out.

Great work, everyone!
 
 
 posted in Little Things on Oct 15, 09 12:37 AM
This one had huge potential as a very cute fun game, but it has two major drawbacks for me.

The main problem that prevents me purchasing this game is that unless you are actively in a hidden object puzzle, the background swirls - instant motion sickness if you are prone to it in video games. The background swirls even when you are doing the jigsaw puzzle, so it was nearly impossible for me to do the first simple 4 piece puzzle. The other problem is the curser - it's a huge magnifying glass, which you'd think would make it easier, but there is no "center" marking, so once you find the object you need to click around in the general area until you hit the hot spot. Luckily there is no penalty for wrong clicks, because some of the smaller objects required 10 or more clicks before I finally hit it.

Some of you may enjoy this, but be sure to do the trail download before purchasing, just in case.
 
 
 posted in Avenue Flo on Oct 14, 09 7:44 AM
I'm having problems with dialog being skipped. I've restarted the game several times, and no matter what I do when I answer the cell phone in the dinner it jumps right past the dialog with Quinn and goes right to the task list. It happens several times during game play as well. The game still works, but I miss a lot of the explanations of what is happening in the adventure.

Is this a common problem, or is it just me?

Julie
 
 
 posted in Magic Academy II on Oct 2, 09 10:46 AM
bplh wrote:Hi

It looks like you put the screwed up paper from the basket in the burner which in front of the door. But you can't select the paper. Am I missing something or is there a glitch?

Thanks
bplh


You have to put the flower into the container first, then go back and get the paper-looking thing.

I finally got past the missing arrow in scene 10-4. I had to just click all over until clicking on the toad came up with a new dialog, then the arrow appeared.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator