Posts created by Don_67

 
 
 posted in The Unseen Fears: Outlive Collector's Edition on Feb 3, 18 4:28 PM
I'm having the same problem!! I've retraced my steps four times but can't get anywhere. Somebody out there please help us find the other half of the totem clue!!!
 
 
 posted in Mystery Trackers: Queen of Hearts Collector's Edition on Jan 11, 17 9:23 AM
I evidently need Elf but he is not available...how do I access luggage? Where did he go. Any ideas?
 
 
 posted in Mystery Case Files: Broken Hour Collector's Edition on Dec 29, 16 5:32 PM
I'm going to have to abandon the game. I've tried and tried to input the combination to the safe, but it just spins out of control. I've exited several times but nothing works. If anybody has a solution, please let me know. I would really like to finish this game.
 
 
 posted in Mystery Case Files: Broken Hour Collector's Edition on Dec 29, 16 5:24 PM
I can't get past the safe. Like several other people, the pointer thingy just spins around. I got the first and second numbers in but then all heck breaks loose and it spins and spins. I don't have a touch screen and my curser hates that thing. Any ideas from anybody?
 
 
Never mind! Got it. Do I feel like an idiot or what????
 
 
Tell me where you went wrong because I'm doing the same thing but can't figure out how to get my bottom part to move. My knight is the same as in the bas relief but I keep getting three or two triangles on the top and neither of the pillars will move on the bottom.
 
 
 posted in Revived Legends: Titan's Revenge Collector's Edition on Jan 7, 15 4:56 PM
After waking Athena, she said something about giving me something to capture lightening in but she never gave it to me. She held back the rocks and stuff and the only thing I could do was exit the scene (without the lightening thingy). Now I'm at a door that is supposedly opened by the key Athena gave me...I don't have a key. Anybody else having this problem?
 
 
If you click on the picture of the caravan in the bottom right of your screen, it will take you to inside the wagon. But if you exit out of the wagon you end up wherever you were before you clicked on the wagon, not back in the forest. I can only assume this is not the case if you get to a certain point in the story which I never will because I couldn't pick up the first gear. It wouldn't let me and still won't let me. Have to abandon the game but I have to say this game still needs some work. The hint button is really bad. It leads you where you can't go and points to puzzles you don't have the pieces to play. I even resorted to the walk through but whoever wrote that didn't have the same problems I did.
 
 
 posted in Bluebeard's Castle on Nov 16, 11 5:38 PM
Where do I find the third key? I'm stumped.
 
 
 posted in Sandra Fleming Chronicles: Crystal Skulls on Jun 30, 11 5:00 PM
I've got an even bigger problem. I jammed the beam against the boulder and now it's stuck over the beam and I can't move either one of them. I'll look for the hammer but I'll bet even that won't help.
 
 
 posted in Tearstone on Jun 2, 11 4:41 PM
I can only find two of the three "o"s? Can anybody remember where they found the "o"s? I found one in the wierd clock room and don't remember where I found the other one. Been looking for an hour...
 
 
 posted in Dark Parables: The Exiled Prince Collector's Edition on Mar 1, 11 6:04 PM
Going to the right of the cottage worked! Thanks so much.
 
 
 posted in Dark Parables: The Exiled Prince Collector's Edition on Feb 28, 11 5:46 PM
I somehow managed to end up in the forest and can't get back to the castle. What am I doing wrong? I've spent an hour going in circles. Can somebody help me?
 
 
 posted in Mystery of Mortlake Mansion on Dec 25, 10 6:01 PM
In the instructions, it gives you an option to pick your gender but there is no place on the options for which to select. Anybody else have this problem? This British guy is getting on my nerves.
 
 
go to the side of the mansion and you'll see a cage. Get it by going out on the second story porch and put the parrot in it.
 
 
I can't pick up the goblets what do I need to do first? I have a feeling this is necessary to trigger the trap door.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator