Posts created by tweakycrow53

windows 10 and same issue at the well I have tried all suggestions but still crashes. I hope there is a fix soon. I have quite a few games I can't play because of tech issues
me too can't get the pole any solutions?
 posted in Nevertales: Legends on Nov 21, 15 7:41 AM
I also would hate to reinstall and start over!! seems like a lot of glitches in games that I have bought that I cannot complete
 posted in Rite of Passage: The Lost Tides Collector's Edition on May 3, 15 6:10 AM
second game last month where there is a glitch I want to get out of the plane
 posted in Magic Gate: Faces of Darkness on Apr 28, 15 2:09 PM
this is making me mad I have tried repeatedly and cannot get the last piece I have gone back to the to people got the magnifying glass still nothing...I want my money back!!!!!!!!!!!
me too I have tried repeatedly
 posted in Midnight Mysteries: Ghostwriting Collector's Edition on Jan 10, 15 9:56 AM
scs2 wrote:Hi rpeters59 -- you have lots of company and there's a thread later in this section that has been locked which contains some of the other comments. Apparently the items for the lamp have to be added all at once, in a certain order and possibly only in a specific place -- if you don't somehow divine that this is required, the game becomes unplayable. So far the only suggestion from BFG is to just toss out your game and start a new one under a new name. Pretty unacceptable to me.

I have restarted several times are they going to do some updates to make this game playable?
 posted in Midnight Mysteries: Ghostwriting Collector's Edition on Jan 7, 15 2:12 PM
Therealmargesimp wrote:
BereniceP wrote:I have lost the carbide for the lamp. It disappeared out of my inventory and now I cannot move forward. Please help. I am using Windows 8

Same with me - lost the Carbide and I'm running W7

me too..second time starting this game...installed uninstalled they need to address the issues.
 posted in Midnight Mysteries: Ghostwriting Collector's Edition on Jan 4, 15 12:48 PM
I cannot get the second clock hand completed it but can't get in to get the clock hand
 posted in Fright Collector's Edition on Jun 29, 14 7:53 AM
suus52 I have the same issue what now we cannot finish the bonus round???
 posted in Order of the Light: The Deathly Artisan on Feb 18, 14 1:59 PM
where is the umbrella to put in the drink on the picture
 posted in Natural Threat: Ominous Shores on Feb 27, 12 10:32 AM
my game crashed now can not continue
stephanieSill wrote:Please help ! Im Stephanie my e mail address is (removed by moderator)
Im in the office with the computer and put in the password 94yxo2 or 94yx02
any way it wont unlock the computer
what di i do?
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator