Posts created by Dragonfish89

 
 
 posted in Delicious: Emily's Miracle of Life Collector's Edition on Apr 18, 18 2:09 PM
I hit on this solution by accident, I had one customer left who was waiting to pay and had only made about 6 cupcakes.
Instead of taking her money I filled the cupcake box while she and her table companions got a bit grumpy waiting to pay.
When the cupcake order was filled then I let her pay and earned the diamond for that level.
Because this new developer doesn't have beginner level option some challengers/levels are so hectic for me I found this the best way and I'm sure others have also.
I earn the diamond and/or find mousey first and then go back in to earn the three stars or vice versa. Which means you can play the level a few times but eventually successfully.
 
 
 posted in Nostradamus: The Four Horseman of the Apocalypse on Apr 29, 17 7:37 PM
Hi kaitlinn, I too love this game and have just completed. I fortunately didn't have any glitches and all seemed to run smoothly. Loved the pace the puzzles and the story.

I've been playing Adventure Games for some years now (Myst was my first) and this game was a good combination of Adventure and Hidden Object.
I also would recommend Facility 47, Violette, Adam Wolfe x 2 and the Drawn series.
I haven't played the others that kgustavson mentioned.

You might also like Shaban and Steel LIFE as they are also a little different.
 
 
 posted in Hidden Expedition: Midgard's End Collector's Edition on Sep 16, 16 3:13 PM
Hi babsvb1948, from memory you have to complete the part at the Schumann estate first.
If you've done that you should have the axes to place on the statue base and get coordinates. Then you should be able to get the map. I hope that helps.
 
 
 posted in Final Cut: Fade to Black Collector's Edition on Jan 14, 16 3:27 PM
Hi alimac, you may have already worked it out by now, But from memory you just keep using the arrows to look around until you find the sign or thing, I'm sorry I can't remember what, but it will tell you when you find it. Cheers.
 
 
 posted in Final Cut: Fade to Black Collector's Edition on Jan 14, 16 1:48 PM
Hi, I've finished the game and loved it, but sadly didn't find any Christmas stockings.
I'm thinking I'll play it again in a while just to find the stockings, is there any help to where I should look out for them? Many thanks.
 
 
 posted in Melissa K. and the Heart of Gold on Jan 8, 15 3:21 AM
Hi bamc, the collectibles are the lying down buddhas found in the HOGs.
You can also find them when you check in the box on the home page, you got Bonus HOGs as you progress and there are Buddhas in these as well.

If you you click outside the puzzle or on the X in the top R of the puzzle this should take you out of the puzzle but not out of the game.

It's a great game when you get into it, most interesting and fun to play, but can be a bit tricky working out what you need to do sometimes. There are walkthrough tips elsewhere on this forum. I hope you get going and enjoy.
 
 
 posted in Puppetshow: Return to Joyville on May 26, 12 6:17 AM
Hi, I am enjoying this follow up Puppetshow so far. But have hit a snag in that I don't understand the match faces and accessories puzzle. I have read and re-read the walkthrough for this part but just can't get what you are supposed to do.
Any help would be appreciated as I don't like to skip puzzles (slider puzzles excepted
 
 
Hi linda4646 and tatarooroo, this also held me up for a couple of nights.
And not helped by not having instructions for puzzle areas like most IHOG's so you waste a lot of time trying to work out what you're supposed to do.

Firstly I found that if a piece was put next to another correct piece it would automatically attach itself. This worked ok till I had two pieces left although my semi-completed tiles didn't seem to match the picture in the answer book (found in the drawer on the main menu page) and I couldn't unattach my tiles to try different spots, nothing seem to work.

So after much googling and searching I found this particular forum with these two comments about the tiles...so when I tried the double clicking hint from linda's entry the whole piece flipped over and I could finally attach my last two pieces.
I went outside and back to the entry, spoke to big hefty guy then went back to garden and a new hog spot had resin in it.
I'm guessing the two pieces in your inventory will be used later, they are the tiles that Chelsea gave to the museum lady to carbon date but she nicked off with them instead.

Then there was the pizza oven puzzle to overcome next but that's another story...

I actually am enjoying this game in spite of some difficulties with puzzles and what to do next, I haven't had any problems with the game not working or too dark etc like a lot of others seem to have, I'm using Windows 7 if that makes a difference.

I hope they don't keep HOG format for the Chronicles of Mystery series and go back to proper adventure game format, or maybe throw in the odd IHOG for fun like Her Interactive did with Nancy Drew games.

Adventure games are for me as a rule but I find IHOGs are a lot of fun if my brain doesn't need to be tested too much, but not tedious as some of the simpler HOGs are.
Good luck and happy gaming...
 
 
 posted in Robinson Crusoe and the Cursed Pirates on Jul 9, 10 3:08 PM
Brilliant, many thanks Spirit! I have my pearl and progressing onwards...
 
 
 posted in Robinson Crusoe and the Cursed Pirates on Jul 3, 10 3:54 AM
I'm stuck on the turtle race also and have read through here trying to find out how to win or how to skip. I get my turtle up the right side nearly to the pearl but the other turtle is just too darn fast for my clicking fingers, any help would be most appreciated as otherwise I am stuck at this point and cannot finish the game.
 
 
 posted in Rhiannon: Curse of the Four Branches on Apr 7, 10 3:56 AM
A tip for getting around more quickly is to open up the map and click on the red arrow nearest to where you want to go to and it takes you straight there. Although sometimes you need to walk away first such as the first time you leave the garage, otherwise you miss a cut scene. Hope this helps.
 
 
 posted in Rhiannon: Curse of the Four Branches on Apr 3, 10 5:07 PM
Hi Magicalnat and others who found this part a bit frustrating and tricky...

I found this worked for me...look at slate 1 in close up by RIGHT mouse clicking, then LEFT mouse click slate 2 from inventory and it willclick/combine with slate 1, and then LEFT mouse click slate 3 and it will click/combine with slate 2...hope this helps.

My favourite games are Adventure games and am loving Rhiannon and am very happy to see a bit of adventure games coming into HOG, such as Mystery Case Files (Ravenhurst and Dire Grove).

psSorry guys, I am new to posting and couldn't work out how to quote and reply all in the one go.
 
 
 posted in Rhiannon: Curse of the Four Branches on Apr 3, 10 5:00 PM
kazkaz1957 wrote:
magicalnat wrote:Can I have a little help on this game please, if anyone can...I am on Chapter Two and am trying to combine the 3 stones together, but every time I right click in inventory it does nothing, I've also try combining by left clicking, still nothing...I have repeated this part 4 times now, just in case I missed something, still nothing...get rather frustrated....thank you


Hi Magicalnat

Sorry you're having problems with Rhiannon. The combining of the slates seems to be a stumbling block for some players as if there is something wrong with the original download. It seems to correct itself if you uninstall and reinstall the game but you must not, under any circumstances, use any save you have already created. This means you'll need to start the game again which I know is very frustrating but is the only way to get rid of the glitch.

There is some further information on the technical thread of this forum. If you send me a PM I may be able to help further.
Best wishes
Karen
 
 
 posted in The Serpent of Isis ™ on Apr 5, 09 4:03 AM
Hello, is anyone able to help me with finding 2 flies and 2 butterflies in the luggage car. Some parts of this game come up very dark to black on my computer and to make matters worse I've just cut some wires and now have to search with the torch!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator