Posts created by arthurC

 posted in Mundus: Impossible Universe on Apr 17, 18 3:00 AM
I played my first profile in 'easy' mode, and it was a dream .. I sailed through most of the levels and I found it relaxing and quite addictive. I loved the little man .. he seemed SO concerned when i had to re-do a level, and so happy when I succeeded. Loved it.

Then, I switched to 'hard' (who wants to sail through every level??) and within a few levels I grew to hate the little man for making me part with my hard-earned gold for paltry piffling power-ups that were never enough I got to level 112 (I think) and changed profiles, but for some reason It wouldn't let me choose the easy option for any of the other profiles. So after using up all my profiles and hitting the same brick wall every time, eventuallly, I just gave up.

Its a fascinating little game, great graphics, nice music and innovative ways to match .. and I really really tried, sometimes playing the same level over and over again for days, without power ups, until I cracked it .. but it's just too much effort for scant rewards.

Great shame.
(More gold and being allowed to play earlier levels to earn it, would have helped).

 posted in Silver Tale on Dec 27, 17 8:02 AM
Many thanks for the swift response
I'll go through the game tips again .. maybe I can pick up some more.
Much appreciated
 posted in Silver Tale on Dec 27, 17 6:52 AM
I've been playing this game for days and days, and I think I must be missing something fundamental to the game: I can't seem to get any gold .. and without gold I can't buy bombs and sundry other power-ups. And without powerups I can't earn badges and move on.

The only way It appears I can get gold, is by trading in my resources for gold bars. So in effect, I have to keep losing levels over and over again, until I've accrued enough supplies to buy a few bars of gold. But hours and hours building up resources will only buy me a couple of bombs and more time, and hopefully earn me a badge. Then, when I have the badge, I have to go through the whole process again.

I have managed to earn badges for every level so far ..but I'm only on level 27, I think (the 'easy' levels, by all accounts) .. and I really don't fancy playing Silver Tale unto eternity!
There has to be more to the game than that, surely?

ps: I've also got 'phoenix feathers' coming out of my ears, but I can't do anything with them. I've tried using them on the horse .. but it won't let me.
 posted in MatchVentures on Nov 4, 17 6:05 PM
Just in case any of the devs read this .. I wonder if you know the name of any of the music played during the game?

It's lovely .. and there's a haunting strain in it that is so sad, it brings tears to my eyes (and I hardly ever cry these days!).

Sometimes, I find myself playing the game just to hear the music's so soothing.

Just wondered.
 posted in Witch's Tales on Nov 1, 17 4:09 PM
Has anyone managed to complete level 15 within the given time?
If so, how long did it take?? (if that makes sense)
 posted in Jewel Match Royale on Oct 19, 17 6:59 AM
I think I'm going crazy.

This level has 3 boards .. two in the main game plus the garden board.

I can get through board okay 1, (apart from a large chunk on the bottom right hand side which needs a key) .. and I got the key to open up board 2. But there is NO KEY on board 2 to open up the remaining locks on Board 1!

I've looked everywhere .. and there's nothing. It's not stuck at the top, nor is it hiding in a corner at the bottom. There is NO KEY.

Am I missing something?
I can't continue until I figure it out.
 posted in Clutter Infinity: Joe's Ultimate Quest on Sep 20, 17 8:51 AM
Any update yet on a fix for this game?
It's been over a week now.
 posted in Clutter Infinity: Joe's Ultimate Quest on Sep 14, 17 6:37 AM
And just incidentally .. is anyone else seeing lots of marketing emails below?
 posted in Clutter Infinity: Joe's Ultimate Quest on Sep 14, 17 2:28 AM
I also have the 'no cursor' problem. Also, the game isn't 'centred' on my screen, but has shifted over the the right. Very strange. There's absolutely NO way I can play it!

I love Clutter, and was so delighted to see a new one, that I'm afraid I did something I've only ever done with Mystery Case File games .. I bought outright without playing the demo (well, I used a 'Free game' coupon).

PLEASE PLEASE try and get this fixed Big Fish.
 posted in The Lost Labyrinth on Aug 10, 17 12:53 PM
Very nice game .. Not very taxing, but very relaxing.
 posted in Jewel Match: Snowscapes on Jul 18, 17 3:41 PM
Stuck on level 28 .. and I doubt I'll get any answer here because it's such an old thread .. but here goes anyway:

I've got baubles at the top problem .. and below them, is a row of locks. The problem is, there are no keys on the grid, and no arrows to any other rooms where the keys would normally be. Just the one board .. nowhere else to go. I'm wondering if it's a glitch?

Any help anyone. I can't advance and may as well pack the game in if I can't find a solution.
 posted in The Trials of Olympus III: King of the World on Apr 21, 17 6:40 AM
I've been playing this game for three days now, and I just don't get it! The game play's okay (and it's quite relaxing) but there doesn't appear to be a comprehensive tutorial. Not a clue about what the objective is explanation about why I'm collecting gold wotsits, or how I earn new power-ups? And even though I've been playing on and off for hours, my progress still sits at 6%.

Am I missing something??
 posted in Bestseller: Curse of the Golden Owl on Mar 26, 17 4:37 PM
Bartsister .. you are a genius !

Many many thanks
 posted in Bestseller: Curse of the Golden Owl on Mar 24, 17 3:53 AM
This level is driving me nuts!

The goal, apparently, is to blast blobs of mud to Kingdom Come .. and you're given just a minute and a half to do it .. with the assistance of clocks. Well, I've been blasting, and blasting, and blasting (and blasting!) and nothing happens. Last time I played, I accumulated something like 275,000 points, and increased the 'time left' to over 5 minutes, and yet I STILL (apparently) have 4 blobs of the mucky stuff remaining.

They are nowhere to be seen .. the board is totally free of blobs of mud, and yet it says I still have 4 to destroy.

No instruction, of course.

Is it a glitch, or am I missing something?

 posted in Bestseller: Curse of the Golden Owl on Mar 4, 17 12:45 AM
Is there a knack to solving this?
Anyone know?
 posted in Bestseller: Curse of the Golden Owl on Mar 1, 17 1:42 PM
Thanks stusue ..
I'll go and try again.[i]
 posted in Bestseller: Curse of the Golden Owl on Mar 1, 17 1:42 PM
Thanks stusue ..
I'll go and try again.[i]
 posted in Bestseller: Curse of the Golden Owl on Mar 1, 17 11:55 AM

I'm totally discombobulated.
Any hints anyone?

 posted in Bestseller: Curse of the Golden Owl on Feb 21, 17 2:57 PM
All I've managed to dislodge are two light bulbs .. and there doesn't seem to be any rhyme or reason why I even did that. It appears to be pretty random. I can't understand either, why It appears making long long strings of tiles is somehow necessary, and yet I get so few rewards for doing so .. not even any power ups to speak of.

Hate not being able to skip a level too .. If we want to skip a level, we should be allowed to, right?
 posted in Bestseller: Curse of the Golden Owl on Feb 21, 17 2:59 AM
I'm afraid I'm becoming quite addicted to this game .. But I just cannot figure out down to dislodge the light bulbs! It must have something to do with lining up the 'power charged' tiles and blasting them out .. but it's just not working.
Any idea anyone?
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator