Posts created by nykelli1843

 
 
 posted in Golden Trails 2: The Lost Legacy on Jul 4, 11 9:16 AM
Does the SE have the clovers to find like the CE? Cuz I'm on my 3rd location and no mention of them nor seeing them.
 
 
 posted in The Serpent of Isis: Your Journey Continues on Mar 2, 11 2:10 PM
I found the HOG scenes waaaaay to easy and lost interest before trial period was even up.
 
 
 posted in Jack of All Tribes on Jan 27, 11 1:56 PM
Same thing, got access error on level 24 twice....I have newest dirext x, newest graphic cards, lots of memory and the game STILL does this. I've cleared out old files.

I'm sitting here with roughly 14 games that I can't play either due to: access problem or not full screen. Boyfriend cleans and rebuilds computers and doesn't know why this is happening. Strange enough, 3 games I bought elsewhere play perfect.

I cancelled my membership this week. I have roughly 10 free credits but reluctant to even try more BFG. CS will just tell me to do the Dr felix diagnostic which shows nothing.

I'm using W7, with 64 bit. Very unhappy gamer here.
 
 
 posted in Jack of All Tribes on Jan 26, 11 10:33 AM
I reached like level 9 when trial ended, only 1 HOG scene encountered. Little too simplistic for my tastes, but would be cute game for those in the mood. I wish it allowed you to search out and plot your own buildings instead of the foundations already in place.

Was hoping it had more freehand tasks. I'm tired of HOGS and IHOGs (never thought I'd say that) and can't find any game to hold my interest.
 
 
 posted in The Stroke of Midnight on Jan 21, 11 12:26 PM
The movement/panning didn't bother me. As with the last 14 games I've bought here recently, I don't have full screen access.

It's a game with potential but I found myself almost nose to screen in the HOG scenes to find items. Got bored with 10 minutes left in trial.
 
 
I didn't get caught up in all the hype, didn't even read the speculation threads, so my disappointment isn't quite so bad.

Something just fails to enthrall me. I don't like the mixing of real people. The HOG scenes are extreme junk piles; I found myself moving the laptop closer to me just to determine what an item was.

Are there morphing items or not? I didn't see any in my demo time. Never mind, someone answered this same time I posted.

I'll probably wait for the SE as so far I see little to warrant the cost of the CE.
 
 
 posted in Enlightenus II: The Timeless Tower on Aug 21, 10 2:51 PM
Like others, I liked first one better. This time around, I disliked matching items from "inventory" to scene for some reason,.

I don't get the mini games..choose a lightening bolt or whatever, place it in cartoon cell and that's it, you win it first time.

Just not keeping my interest but I'll try back later.
 
 
 posted in Redemption Cemetery: Curse of the Raven on Aug 21, 10 10:58 AM
Not sure if tech issue or game itself, but it is soooooo slow loading new scenes.
 
 
 posted in Snark Busters: Welcome to the Club on Aug 15, 10 3:56 PM
I love FROG's (hated them at first) and this is a great game. I like how you use the completed frog item and another "missing" piece of another item appears, I sometimes miss it, I'm so busy looking around.

Don't be turned off by cartoonish graphics, they really are imaginative and well done.

I try not to use a hint in most games I play and this one is just hard enough to please me. Make sure you check out all areas of a scene, there are numerous items to explore.

Kudo's to the developer's, an interesting, humorous and quirkly little game.
 
 
 posted in Shaolin Mystery: Tale of the Jade Dragon Staff on Aug 12, 10 8:57 AM
Nice clean graphics and I like doing the COG items (or whatever you want to call them, but........I find it way to easy so far and not much of a challenge, so probably not a purchase for me. Too bad.
 
 
 posted in Samantha Swift and the Fountains of Fate on Aug 7, 10 3:41 AM
This game is a being a pain...I finally got full screen, quit. Came back to it later and small screen again.

I reset this game about 7 times last night. So annoying. It's the only SS game I've liked but at this stage I'm losing patience.
 
 
 posted in Samantha Swift and the Fountains of Fate on Aug 7, 10 3:38 AM
I didn't like the other SS games, but did like this one. Just wish it would keep screen size, I have to keep opening it, closing until it comes up full screen.
 
 
 posted in Samantha Swift and the Fountains of Fate on Aug 6, 10 12:44 PM
Was fine until I purchased it--now my screen is small and won't resize. I changed game to full screen and changed my comp properties--no go.

Tried two other games and they are full screen.

GRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRR.
 
 
 posted in Immortal Lovers on Jul 24, 10 4:09 AM
Wouldn't even buy it as a daily deal.
 
 
 posted in Golden Trails: The New Western Rush on Jul 18, 10 7:00 AM
Went to do the unlimited speed part and got to end and it said I can't do some because I didn't unlock the special missions.

I got the 150 sheriff badges required for the secret mission scenes. I got 90% of all trophies, so where is my access to secret missions?

I stupidly hit play adventure to go back and see and it starts me all over again, with no trophies.

Grrrrr. Confused and walk through didn't help explain this.
 
 
 posted in Hidden Mysteries: Vampire Secrets on Jul 17, 10 3:22 PM
Too simple. Good intro HOG for beginner's.
 
 
 posted in Elixir of Immortality on Jul 17, 10 12:00 PM
Played about half hour and probably back burner the game til another time. It's just not holding my interest and I find the HOG items to be way too easy to find.

Sometimes, it just my frame of mind or I didn't play the game long enough. Have fun, all!
 
 
 posted in Golden Trails: The New Western Rush on Jul 16, 10 10:25 AM
I beta'd this and didn't like it (didn't even finish). I tried it at another site again and didn't like it.

So, after seeing so many positive comments, tried it again and liked it. Bought it and have spent at least 5 hours playing and just fnished.

Those sheriff badges were well hidden in some spots! Only problem I had was during mini-game when I couldnt place an evidence item..after that, I had to really click my mouse hard to play. Some items required 2 clicks to register. It was like that to end of the game. I tried a diff game and didn't need the extra mouse pressure, so don't know what was up.

This game was a pleasant surprise.
 
 
 posted in Golden Trails: The New Western Rush on Jul 16, 10 10:20 AM
Yes, I it was the right item in the right picture. I tried like 10 more times and it finally went. Every other evidence scene worked okay.

Strange enough, after that mini-game, I had to start clicking my mouse real hard for anything to work. Even in the regular HOG scenes, I ended up clicking an item twice to make it work or else REALLY click my mouse hard.

Beginning of game worked fine.
 
 
 posted in Golden Trails: The New Western Rush on Jul 16, 10 5:17 AM
After you complete a group of scenes, you have couple seconds to place an item in a picture.

I cannot get the wad of money to go in the scene. I know it's the right item in the right picture.

I hate to skip the mini-game as I haven't used a clue or skipped anything so far. This takes place in the mine area. Grrrrrrr. Any suggestions? I've replayed this mini game 12 times trying to make it stick.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator