Posts created by rdagj

 
 
 posted in Ruby Maze Adventure 2 on Aug 3, 17 1:21 PM
I am pretty far into the game, and came to a place where I had a choice to give the staff to the character, or take a different gold arrow into another level. I chose the gold arrow over the staff. BIG mistake! The second level also required giving a staff to the character. I figured Ruby could carry two staffs a time. Apparently not. When I finished the level and was take back up to the character wanting a staff; I didn't have a staff to give him. And no apparent way to retrieve one. I cannot continue without a staff; and there is no way to start over; not that I want to start over, as I am so far along. Is there a "cheat" or a way around this problem? I am using Windows 10. Tried the steps posted above; didn't help. Would really like a way to start the game over, or get past where I am stuck. I also tried removing all evidence of this game from my computer and reinstalling it. It still put me back at the place where I am stuck. Somebody really needs to fix this game!
 
 
I am in the Reliquary trying to put the puzzle mini game together. I can move the puzzle pieces, but how do I rotate them? Getting very frustrated at this point!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator