Posts created by ajwiggin

windows 10
when downloading, the download stops with error: game manager experienced an internal error. Please try again. Error code: 3
Have tried several times to download and get same error.
 posted in Viking Brothers 3 Collector's Edition on Dec 27, 17 2:34 AM
Finish level 2 and it will not move on to next level. Same problem as many others.
Windows 10
 posted in Dark Realm: Lord of the Winds Collector's Edition on Sep 3, 16 11:52 PM
Will not download. Error 3. Windows 10.
 posted in Moai 3: Trade Mission Collector's Edition on Dec 28, 15 3:37 AM
I downloaded game, set my options and hit play, it shut down my computer. This is not the first game that this has happened to me. Laruaville 4 I think (and some others I cannot remember at this time), shuts down computer also. Sent the diag to tech support, tried all the options in the help section, still can not play that game. Tech support could find no reason why it is doing this and said it looks like your computer just does not want to run this game. I have the first 3 of the series.....does not make sense to me. Windows 10 and previously windows 7 (this happened on both versions of windows, so windows 10 is not problem either. This is becoming a real problem, making me question continuing with membership.
Uninstalled and then reinstalled and I started a new game under another profile and this time it froze before I could even get to the academy. Need a fix....I love this series.
That is what is happening to me in windows 10. Just gets stuck and only thing I can access is strategy guide and menu buttons. Tried running as administrator and running as windows xp and windows 8 still did not fix this problem. Too bad I was really enjoying the game (I have all the other 6 in this series and love them).
I love all shades of purple so for me it is great. Merry Christmas!
Running windows 10, playing demo went from witches house to witches academy and screen stuck there as if to play cut scene...but nothing running.. Had already been to witches academy found skeleton hand then went back to witches house used the skeleton hand on container got items, then attempted to return to academy and it is stuck.
Also the escape button allowed the pop up menu so I could return to main menu and quit game. I quit game and tried playing is still stuck in same spot.
 posted in Laruaville 4 on Dec 14, 15 2:17 AM
Using Windows 10, game downloaded fine but when attempting to play shuts off my computer. Restarted computer and attempted to play game several times without success.
 posted in Grim Facade: Hidden Sins Collector's Edition on Jun 21, 15 6:18 AM
Running Windows 7, this game runs for a while and then shuts down my computer. I restarted computer and tried again, same thing happened. Unfortunately I already purchased this game and now cannot play it.
 posted in Rite of Passage: The Lost Tides Collector's Edition on May 5, 15 9:46 AM
Bonus Chapter
I'm stuck in the plane looking for coordinates and it wont let me get out or use the map to get out....... guess I can't finish the bonus chapter??
 posted in Monument Builders: Alcatraz on Jun 24, 14 5:07 PM
All goals completed, but will not end level.
 posted in Violett on Apr 9, 14 6:09 AM
gave up after a few minutes.....
 posted in Haunted Halls: Nightmare Dwellers on Jan 15, 14 8:19 AM
Gone into a jungle and person tied up surrounded by fire. When trying to light the torch the game locks up and must start task manager to exit game.
 posted in Excursions of Evil on Jan 15, 14 12:19 AM
How Is this the new game release for tomorrow when there are reviews of this game dating back to Oct?
 posted in Rolling Idols: Lost City on May 28, 13 3:50 AM
Downloaded game and it showed up as free trial expired in game manager. Could not play free trial.
 posted in American Pickers: The Road Less Traveled on Feb 22, 12 3:49 AM
When I clicked play button received the following 2 errors:

Display Change Failed
Hardware failed to switch to the specified mode

Fatal-ISV (..\..\source\t2d\
A fatal error has occured and the application must exit. Video device could not be initialized.
 posted in Treasure Hunters on Mar 13, 11 12:14 AM
Don't know if anyone else had problems with cursor being very hard to control, but played for only 4 minutes and deleted.
 posted in Dr. Jekyll & Mr. Hyde: The Strange Case on Mar 6, 11 8:45 AM
This game is awful! I know BFG's can do lots better than this. I played the entire hour hoping it would get better....sadly no buy for me.
 posted in A Girl in the City on Jan 31, 11 3:17 AM
I found this game tedious and boring. No buy for me, quit demo after 30 minutes. Angie
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator