Posts created by gailweis

 
 
Totally agree with ClassicalJazz. If the CEs had a couple of more hours of play, I would definitely buy them. Bought one, and was disappointed at spending $13 more and then not really getting anything for my money. Liked these reviews; will play the demo and see then. BTW, I am playing the demo of Asylum Conspiracy based on the reviews and am really disappointed - the HOs are easy to find and the Hint button fills so quickly that it's too tempting to just use it to progress. Makes me wonder - who is writing the reviews?
 
 
 posted in The Pirate's Treasure: An Oliver Hook Mystery on Jul 22, 10 4:09 PM
Does anyone at BFG read these reviews? Wizard of Oz, Journalistic Stories, and now this! What's going on? I thought they Beta tested these games. I signed up for that, and haven't received any game to test. If I had received this one, you know what my response would have been. So disappointed! Will the 5th time be the charm?
 
 
 posted in Journalistic Stories on Jul 20, 10 3:51 PM
Wow! Feel great - thought I was the only one who thought Wizard of Oz was really bad (tried Easy, Normal and Hard and still coudn't find anything - and I'm pretty expert at HOG's)! This one takes second place. I can't figure out what to do in the scene behind stage, after viewing Gloria's body. And the dialogue! Who wrote this?
 
 
 posted in Secrets of the Dragon Wheel on Jul 14, 10 4:03 PM
Yak, yak, yak. After reading some of these reviews, I was excited about playing the demo. How disappointing! Much too easy, hidden objects easy to find, puzzles easy to solve, And all the talk! I got bored really quickly. Won't even use a game credit for this one. Is it possible that, once I buy it, the game will be better? It did say I was only playing a sample version. What do you gamers think?
 
 
 posted in Flux Family Secrets - The Rabbit Hole on Jul 12, 10 3:51 PM
Same thing happened to me. Am waiting to hear back from BFG!
 
 
 posted in Flux Family Secrets - The Rabbit Hole on Jul 12, 10 3:42 PM
I reinstalled the game, downloaded a new DirectX, and still don't get anything at the railroad tracks in the Lincoln Chapter 1. No arrows, no **** scene, nothing. Any suggestions?
 
 
 posted in Artifacts of the Past: Ancient Mysteries on Jul 11, 10 6:09 AM
What a bore! Much too easy - even in the Normal mode, ****'s easy to find. I'm definitely spoiled after playing Dead Stories. This is a pass for me. If there are only 3 stores, and I finished the first one in under an hour, not worth the money.
 
 
 posted in Deadtime Stories on Jul 10, 10 2:22 PM
One of the best games I've played in a long time. Great length, difficult hidden object scenes, excellent story line and a real challenge. I just finished playing it and can't wait to play again. Congratulations BFG, this is a winner!
 
 
 posted in Flux Family Secrets - The Rabbit Hole on Jul 4, 10 6:42 AM
Pa_tri_cia_: I have the same problem - I'm just starting the Lincoln chapter, and I get no hidden object scene, no arrows to move to another scene, nothing! I e-mailed customer service and am waiting for a reply.
 
 
 posted in Flux Family Secrets - The Rabbit Hole on Jul 3, 10 7:22 AM
Re full screen problems: I went into Options, clicked Full Screen, and it worked. My problem now is that I am at the railroad tracks, but nothing is happening, I get no hidden object screen, and no arrows to direct me anywhere else. I'm stuck. Help anyone?
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Jun 26, 10 2:07 PM
i can't even get the game to install - keep getting "installation failed" message, Help!
 
 
 posted in Master Wu and the Glory of the Ten Powers on May 9, 10 9:58 AM
Terrible game. Just closed out of the demo and will not go back. Hints stopped working and you can click forever without being penalized. I think I'll just play Magic Encyclopedia - Illusions again. Now that's a GREAT game.
 
 
 posted in Escape the Lost Kingdom on May 8, 10 12:57 PM
I just completed a survey on a chat session I had, giving an A+ to the service representative. I couldn't agree more with the posters here. Customer service at BFG is the best!
 
 
 posted in Magic Encyclopedia: Illusions on May 8, 10 7:54 AM
Same problem for me. I can't get out of Chapter 2 because it keeps highlighting the boat when I click the hint button. I got the ladder, but am still missing 2 items from the old woman's room, and 2 items from the canal. Keeps saying Look somewhere else or it highlights the boat when I'm in the old woman's room. Help!
 
 
 posted in Magic Encyclopedia: Illusions on May 8, 10 7:51 AM
I'm getting really frustrated with the hints. I'm in Chapter 2, and when I'm in the old woman's room and click the hint button, it highlights the boat. I go back on the boat, click the hint button, and it highlights the boat again. Back and forth, back and forth and I'm not getting anywhere. Help! I'm still missing pieces from each scene.
 
 
 posted in Magic Encyclopedia: Illusions on May 7, 10 3:39 PM
Same problem! What do I do????
 
 
 posted in Love Chronicles: The Spell Collector's Edition on Apr 23, 10 11:55 AM
I'm reading these reviews at work and can't wait to get home to try it. I usually don't buy CEs, but this may be an exception (depending on how long it is). Will let you know what I think.
 
 
 posted in Haunted Manor: Lord of Mirrors Collector's Edition on Mar 27, 10 11:41 AM
Way too easy! No challenges at all - the HOs are easy to find and the player is guided to the right answer. I won't buy this game.
 
 
 posted in Doors of the Mind: Inner Mysteries on Mar 17, 10 4:03 PM
Terrible game. Very disappointed. Who tested this?
 
 
 posted in Nightfall Mysteries: Curse of the Opera on Feb 10, 10 3:39 PM
I got the moons, feathers and spiders. How do I get to the spot where I pick up the brick and use the pliers? I'm lost here!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator