Posts created by giddiup101

 
 
 posted in Flower of Immortality on Mar 15, 12 7:19 PM
Can't find 2nd coin.
 
 
 posted in Flower of Immortality on Mar 15, 12 6:12 PM
Found the burnt torch and oil put can't locate the cloth for it.

Nevermind... Found it !!

It is spoiler right next to the oil on the right. Click on it, dip in oil to get torch.
 
 
 posted in Silent Nights: The Pianist Collector's Edition on Mar 15, 12 2:19 AM
Well I played the demo and I found myself really enjoying the game. As I commented earlier I thought the game started off pretty easy but it did get better the more I played. I think everyone should at least give it a try.

However, I've now decided to wait for the SE to come out before I buy as I don't feel it's quite worth the CE price. I have been spending way too much $$ on these lately and I really have to start limiting myself and be a bit more choosy.

Happy gaming everyone !!!
 
 
 posted in Silent Nights: The Pianist Collector's Edition on Mar 15, 12 12:57 AM
Is it just me or does this game seem too easy? And I am playing the complicated mode. Although I haven't played the whole demo, so I am hoping it will be more complicated further on. I will probably buy as I always do
 
 
 posted in Between the Worlds II: The Pyramid on Mar 3, 12 10:28 PM
lauder wrote:I find that in the clouds, there are a few items that you can see are there, but when you hit on them they dont move.


If you hold your mouse buttons down, it will make the clouds move so you can pick up items.
 
 
 posted in City of Secrets on Feb 8, 12 3:07 PM
This site has a great walkthrough. BFG won't allow me to type other site but if you type City of Secrets walkthrough (Removed by moderator) it will come up.

(Removed by moderator)

 
 
 posted in City of Secrets on Feb 8, 12 3:17 AM
Where do I put the Bowl of Grain to obtain hamster ?

Never mind I figured it out !!!! You have to combine bowl and grain, then put on sign to get hamster,,,
 
 
 posted in Grim Tales: The Legacy Collector's Edition on Jan 16, 12 11:32 PM
It has been 10 days since I've reported the crow and boomerang issue and sent a felix report. I cannot believe they have not fixed this problem yet. It's unacceptable, therefore I have requested to exchange for a different game and pray it doesnt have any bugs or glitches also. I did enjoy playing this game and really wish they would test these games better before putting them out. It has been so frustrating and it tells me that they are not showing their customers the respect they deserve. I don't have the time nor energy to spend waiting for them to fix something that should have been done correctly to start off with.
 
 
 posted in Grim Tales: The Legacy Collector's Edition on Jan 7, 12 2:28 AM
rebeccas1 wrote:Am having the same problem with the crow. Now the hints, map and guide will not work and I can't get out of the game. Help!


I am having the same problem. I started over and it happened again. Not sure which mode you are playing in, I am playing advanced mode.... Very Frustrating !!
 
 
liltrixter wrote:i can no longer 'see' the back wall of the 1st maximum security cell where the 'blue handle' picture is said to be.... so how do i trigger it so that the handle will be at the base of the fountain so i may proceed? I can't access the window via the ladder any longer i guess cause i already finished the time lock.

any suggestions? I've clicked all over the cell in hopes that something might trigger access to the picture. I did get a look at the crow from the neighboring cell...but no picture of something blue to be found.


You need to go in the office where all the camera screens are and click onto camera that shows nurse, change the channel until you see screen that shows security code. Use code to open Charles fathers cell.
 
 
I tried but it won't let me.
 
 
Okay.. I found the red handle but still having trouble with the blue. If it's in the cell that Charles' father was in (the one that needs a code) I must have already seen the picture because I can no longer get in that room. I don't know the code and the game won't let me go back up the ladder to see code. I've tried looking at fountain for handle but it won't let click on fountain, i only get the up arrow.
 
 
you didn't lose them..use the arrow key for Inventory, they are on previous screen.
 
 
Spoilers welcome in finding the pictures for red and blue handles

Thanks
 
 
 posted in Mystery Stories: Mountains of Madness on Nov 19, 11 10:38 PM
Inanga wrote:Love it, bought it, now stuck at the dots and glyphs puzzle to open the round door. I just don't get it LOL! Can anyone help me here please?


Set the dots according to Book of entrance (5) in your notes.
 
 
 posted in Azada® : In Libro Collector's Edition on Nov 17, 11 1:21 AM
Maybe try using Paypal to have it taken out of your bank account instead of using your debit card. I've used this method in the past and it worked.
 
 
Don't think it will be a buy for me as a CE, as it is only 334 MB which is a pretty small file size for the money.
 
 
 posted in Resurrection, New Mexico Collector's Edition on Oct 27, 11 12:56 AM
cll1950 wrote:I came fere looking for a review and instead I fund two threads about flippin' downloads.

What;s the point of these threads? If you mind a long dowload, don't do it. If you can deal with it, then download and play,

Do any of you who posted these posts realy think your problem will be solved by multi complaints about the same thing over and over?


No...but it helps with our frustration !! Besides, what else is there to do..it's not like we can play this game.
 
 
 posted in Resurrection, New Mexico Collector's Edition on Oct 27, 11 12:46 AM
Same here...can't give a review if we can't download the game....
 
 
 posted in Resurrection, New Mexico Collector's Edition on Oct 27, 11 12:28 AM
I'm stuck at 5%... Never had a problem like this before....It's horrible
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator