Posts created by georgiarealist

 
 
 posted in Adelantado Trilogy: Book One on Oct 12, 12 11:52 PM
As far as I can tell, a Level 3 watchtower will indeed scare off the caveman, but not until he begins attacking a building in range of the watchtower. Since there are several actions you can't do until the caveman is scared off, it is often better to do it by clicking him instead of waiting. (On another thread, someone said you can click the red text that tells you a caveman is attacking to be taken to the right place, which is helpful.)

For the future chapters, I'd like to suggest that not only worn out buildings be available for demolition but that smashed barrels and the fences the prisoners are kept in should also be recycled. For that matter, I don't see why buildngs can't be repaired - maybe not the woodcutters if the trees are gone, but others shouldn't just wear out.
 
 
 posted in Adelantado Trilogy: Book One on Sep 23, 12 10:10 PM
I agree with many others here and hope the developers pay attention. It's annoying that the game keeps telling you to upgrade things before it will actually let you do so, as well as during play later when it tells you to upgrade buildings where the resources are used up. I also didn't like having to wait for the prompt to repair buildings at the beginning of later levels - most of us can figure it out, even if it's a higher level building. And it would greatly improve things to be able to demolish buildings once they wear out, or if you find you've built the wrong thing (for example just before a new area is unveiled by a watchtower or totem and you find a building needing repair right after you built one). I don't really mind the extra/hidden areas.
 
 
 posted in Adelantado Trilogy: Book One on Sep 23, 12 9:50 PM
One was in the trees near a woodcutter that needs to be restored, another behind a fence around the bend from there (next to a character you need to talk to), and the third doesn't show up until another totem pole or watchtower is built (I forget which) - it's visible when the new area is visible. Sorry I'm not more precise, but I got thoroughly twisted around on this level. I have no idea how to do the level in the allotted time, either.
 
 
 posted in Aladin and the Wonderful Lamp: The 1001 Nights on Aug 14, 12 3:15 PM
I don't think it's worth buying even as a DD. The arrows to move from screen to screen are annoying, but having to wait for the cutesy dialogue to come up and then click an arrow to continue each time is just too much to deal with.
 
 
 posted in Farm Fables on Jul 19, 12 8:53 PM
weralacroix wrote:Hi guys, I am the game's developer. Thanks for playing Farm Fables. Glad you like it.
I tried to make it very strategic even though I know some people may not like this.

If you have time, when you're done playing and if you want of course, please review the game because the two very negative reviews are destroying its rating.

Also it will help me understand what you want and how to make it (or the sequel) better.
Just be honest on the review.

Thanks!


I'm not done by any means, but I will make a point of posting a review. I'm enjoying the game because of the strategy aspect - I really dislike the tm games that are very clicky and extremely fast paced, perhaps because I'm older and my arthritis makes it hard to do the fast clicks. This game makes me think about what order to do things - it's almost as much a puzzle or strategy game as it is tm. I agree with those who say the description doesn't do it justice.
 
 
 posted in Dragon Keeper 2 on Apr 12, 12 1:16 PM
I haven't quite managed to get 5000 in expert time yet, but you have a lot more than 1 day - it was over 20 days (sorry, I've forgotten the exact number, but it shows at the top of the screen). Good luck - the bandits come faster & in greater numbers as you go on.
 
 
 posted in Dragon Keeper 2 on Apr 12, 12 1:10 PM
Since I had finished all the caves before I got the voodoo doll trophy, I'm afraid my experience won't help figure out what the real next level might be to unlock the slot,
Daisy May. Once I got the trophy and realized the last slot was still not open, I went on to the next cave/island to see if it worked there - I think it might even have been the bonus level (which for some reason I don't understand is under the "Survival" tab in the menu).
 
 
 posted in Dragon Keeper 2 on Apr 11, 12 12:02 AM
Thanks - I didn't think about that doll as something I might be able to manipulate. It's a bit tricky to get loose, since the left screen thingy keeps opening up if you get too far over that way, but I finally got that trophy! The last jewelry slot doesn't seem to open until the next cave, though.

 
 
 posted in Dragon Keeper 2 on Apr 10, 12 3:51 PM
It's a cute game with some interesting twists on the original. On the whole, I like the added characters and the individual tasks, but I agree that the "school" isn't quite as satisfying as the shop. Some of the tasks depend a bit too much on the evidently random appearance of available jewelry items, for instance - unless I missed something, there's no way for the player to make 3 of an item if it doesn't show up. In the original version, exiting the jewelry screen and then going back in would sometimes give different items to be made. This one seems to continue bringing up the same ones even when they require jewels you need to accumulate for a task, for example.

I'm not as satisfied with the way the gold stars for tasks accumulate. Replaying a chapter seems to add gold stars to your total even if you still don't get expert for all the tasks. This probably only bothers those of us who are obsessive, though.
 
 
 posted in Dragon Keeper 2 on Apr 10, 12 3:38 PM
The third egg is for the white dragon - the egg itself isn't exactly white, but more white with blue on it.
 
 
 posted in Dragon Keeper 2 on Apr 10, 12 3:34 PM
For those of us who are a bit OCD, this version of expert isn't quite as satisfying as the original. Getting the "Expert" sign on an island in DK was clear. In this version, replaying a chapter appears to get the game to add expert stars to your total regardless of which task you earn them on so that you may end up with 21/21 gold stars even when you know you didn't get expert on every task.
 
 
 posted in Dragon Keeper 2 on Apr 10, 12 3:26 PM
OK, maybe I'm blind, but I can't find a voodoo doll much less figure out how to cut it loose. This is the only trophy I don't have, and of course therefore can't unlock the last jewelry slot. I'd guess it should be somewhere in the second or third cave, but I sure can't find it. Help?

PS- Watch out for that lizard - it gives negative gold!
 
 
 posted in Dragon Keeper 2 on Apr 10, 12 3:21 PM
To replay a cave/island, go to the map screen and click the
replay chapter" sign on the island. It will ask you if you really want to reset that, click the green check, and then click the glowing cave on that island to start. (If you click the Play button, it won't take you to that island - just as the original DK didn't,)
 
 
 posted in Jewels of Cleopatra on Nov 1, 11 10:03 AM
For me, it goes past the Big Fish screen to the Boom Zap one and then sits there with the hourglass forever. I can't get it to do anything else, but I was able to get out with just the escape key. Don't know what's wrong, but I won't bother with it any further.
 
 
 posted in Wild West Quest 2 on Apr 1, 11 9:36 PM
Me too - I'm not sure when it disappeared, but it was around 20+ hints. I'm at 27 now, but no hints button will appear.
 
 
 posted in Sushi To Go Express on Feb 26, 11 10:46 AM
The game works until the end, but the last level or two is frustrating in that the helper won't take the fish to the far end restaurant that's closed because it's run out unless the near end restaurants have totally full fish meters. It drops the fish at the first one it comes to that needs any fish at all. After completing the last level, the cursor begins multiplying and the game won't close down without doing ctrl-alt-del and shutting it down via Task Manager. I see other posts in a different thread about this same problem. I'm running this on an XP computer, so it ought to work.
 
 
 posted in Dream Chronicles: The Book of Air on Jul 16, 10 7:57 AM
I have to agree with the others. This was such a disappointment after the others. It's far too short, with very little you have to think about. The mini-games were repetitive and just mechanical stuff, most of which can be skipped. While it's nice that the dream jewels actually turn into useful aids, they also make the game too easy. At least in the last one, you had to determine which ones to use and how to position them. These are sort of glorified hint buttons. As to what this game is worth, I'm not even happy to have gotten it free with a coupon code. I can't imagine I'll ever play it again.
 
 
 posted in Dream Chronicles on Jun 5, 10 12:58 PM
By trial and error, I got this to work. It appears that my problem was caused by my Adobe Flash & Shockwave being linked to my default browser (Firefox) when the game wanted it to be the IE version. Once I downloaded the updated IE version, the game worked fine. Hope this helps others.
 
 
 posted in Dream Chronicles on May 26, 10 9:22 AM
My system exceeds the stats in the reply that claims the minimum requirements are too low, so I don't think that's the answer. I'm having the same problem - the game runs fine until I try to go out onto the balcony. Then I get a black screen with a frame and no response from the diary or the pause button. If I use ctrl-alt-del to stop the game and open it back up, it won't let me in under my same player name - the entry page just sits there. I haven't tried a new user name, but it doesn't look like that would help. This isn't exactly a new game, so I can't understand why I'm having a problem - I'm running much newer and larger games without a problem.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator