Posts created by Jorie10

 
 
 posted in Rita James and the Race to Shangri La on Mar 31, 12 3:29 PM
Cut scenes are only showing a black screen. If I ctrl-alt-del, I can then choose Cancel and then choose the game's taskbar button to see the cut scene. If I recall correctly, the same thing happened with the last game from this developer that had the monkey in it.

Passing on this game for this reason.

Win7x64 - but I suspect my very pricey HD graphics card is the culprit.



 
 
 posted in Crossworlds: The Flying City on Mar 15, 12 4:08 AM
Loved this game. One of my favorites because it struck me as different at the time. Enjoyed the various locations.

I keep track of what games I have played and if I want to play them again in a year or so. I have this one marked as 'Definitely Play Again!'. Plus, it is one of those games that stayed with me. I can still recall scenes from it.

For what it is worth, I highly recommend it!

Of course, please try for yourself...

Have a great day, everyone!
Jorie


 
 
 posted in Pahelika: Revelations on Mar 6, 12 3:54 AM
Thanks for responding, ironcode!

I'd rather not have fuzzy graphics. Will stick with the small cursor. Please consider a cursor option next time around. There are quite a few of use with large monitors who play these games.

- Jorie

 
 
 posted in Pahelika: Revelations on Mar 4, 12 7:43 AM
Thanks for the suggestion, bootsie21!
Unfortunately, no option to use the system cursor.
 
 
 posted in Pahelika: Revelations on Mar 4, 12 7:23 AM
Any way to increase the size of the cursor? Usually, I feel a game cursor is too large, but for me, this cursor is awfully small. I tried selecting/deselecting the 3D cursor option, made no difference. I'm using a 24" monitor, so maybe that is the reason. Will try changing my default system cursor to a larger size to see if it carries over to the game.

Meanwhile, any suggestions are welcome!

Thanks,
Jorie

ETA: Changing default system cursor to a larger one had no impact.

Am enjoying the game, so will likely buy despite cursor size.
 
 
 posted in Curse at Twilight: Thief of Souls Collector's Edition on Feb 11, 12 3:14 PM
Same thing happened to me. Thankfully, the suggestion above worked for me. I exited the game and re-entered it. Could put the crown on the frog and continue with the game.

Thanks for posting the info!
 
 
 posted in Relics of Fate: A Penny Macey Mystery on Jan 27, 12 3:39 AM
Jan 27, 2012
Unfortunately not fixed. I just tested this today and I was back at the beginning of the scene when I started the game again. Not sure I'll get the game even as a DD due to this Save method. As mentioned above, I, too, do not always have the time to complete an entire section every time I sit down to play for a while.
 
 
 posted in Romancing the Seven Wonders: Taj Mahal on Jan 9, 12 5:09 AM
I had this marked as 'DD Only' in my notes from when it was released. Just tried it now on a Win7x64 machine that replaced an XP machine. Apparently, the game is not compatible with my graphics card. Screen flickers. I cannot select any of the game buttons on the first screen, so could not even play the game.

Any suggestions to make this playable? Otherwise, I'm just going to cross this one off my DD list.
 
 
 posted in 9: The Dark Side Collector's Edition on Jan 8, 12 8:06 AM
Just finished...finally. Became quite tedious for me, so I did not play straight through. Only played the bonus since I paid for it. Was so ready for the game to end. (I can never leave any game unfinished...)

I agree with what Megwoman25 and Valdy had to say above. Like Valdy, I often left to go do something else to allow the puzzle skip to become available. Too many of the puzzles were just a variation on a theme.

I also have to agree with what someone else wrote in a separate thread that was locked. For me, the storyline really could have been clearer/better - more of a story that got my interest and attention. This game just never clicked for me.

On the plus side, I did like the quality of the graphics and many locations in the game.
 
 
 posted in The Secret Order: New Horizon on Dec 18, 11 5:55 AM
Thanks, DLO! This helped me with another game I found had not downloaded after purchase.
 
 
 posted in Hallowed Legends: Templar on Dec 11, 11 6:30 AM
Same issue as jgracinfan. Cursor almost uncontrollable - either jumpy or freezing. I had to Ctrl-Alt-Delete to end the game because I could not navigate to the Menu at the bottom left.

Had this issue before with Elephant Games games, but not with what was the latest before 'Templar'. I was thinking that whatever the issue was was resolved. Sadly, not so.

I'm bummed because I really like games from Elephant Games.

Edited to add:
Just read that Gyongy reported a similar issue in the CE Technical thread with a new Dell computer. I have a fairly new Win7x64 Dell with a very good (and updated) HD graphics card. Might the graphics card not be compatible with this game?

Edited to add:
Turning off custom cursor helps a bit. Cursor control is okay, but screen still has frequent flicker and there is often a hesitation after completing an action or H0 scene.

Edited to add:
Darn. I just noticed that Win7 is not a supported operating system for this game. I may try it on my old XP machine.

re: burf90's comment below: I do suspect the graphics card is the issue, not the OS. I know other Win7x64 users have been able to play Elephant games in the past with no flicker issue whatsoever. Just something to do with Elephant Games and the HD card, I guess...
 
 
 posted in Time Mysteries: The Ancient Spectres on Dec 4, 11 2:42 PM
Very dissatisfying ending. I dislike 'To Be Continued...' endings.

Besides that, pretty much enjoyed it. Very long. By the end, the H0 scenes did get tedious as someone else mentioned. I, too, just started to use the very generous hint system just to get through them more quickly.
 
 
I, too, think it would be great if the above-mentioned threads were automatically created when a game is released. But, to differ with someone else's suggestion, a thread I'd definitely like to see kept is Welcome To.

I actually use the Welcome To thread to find out what date a game was released. When there is a DD or COTW game for which I want to check my notes, I get the date from Welcome To and then go to the relevant page in my notebook. For me, that is always the definitive date for the release date. Very helpful IMO.
 
 
 posted in Oddly Enough: Pied Piper on Oct 4, 11 4:47 AM
Cursor is very sluggish for me if I have the custom cursor enabled in Options. If I deselect that option, the system cursor moves just fine.

Since I prefer to play with the custom cursor, I'm going to hold off on buying this game for now. I am hoping someone in the pond may have a suggestion to improve custom cursor movement.

- Jorie
 
 
 posted in Twisted Lands: Insomniac on Sep 25, 11 7:06 AM
I just finished the game. Very confusing and disjointed. And my out loud comment at the end was "HUH?".

SPOILER:
I think Angel was the teacher since her photo was added to the sheet with all the children's photos. And, at the end, I think she was driving off and saving them.

There are so many loose ends that were not explained or resolved.

What was up with the monster aspect? Hallucination or real?
How did all the diary pages and that story line tie in?
How did the mayor (major?) figure in with the woman's story?
What was the resolution with Mark?
What was the horrible thing Angel did?
Who was 'real' and who was not?

I would have come away from this game feeling a lot more satisfied if there has been some sort of explanatory wrap-up. Now, I sort of feel that I wasted my time. I just did not get this story line. Too convoluted for me.

ETA:
Maybe if I had recalled more of the first Twisted Lands, this follow-up game would have made more sense. I may have to replay that one to help clarify this one.
 
 
 posted in Urban Legends: The Maze on Sep 24, 11 1:10 PM
Excellent game! Hated to see it end. Great storyline. Lot of various areas to 'play'. Wonderful length. Loved when I thought it was over that there was still more to play. Satisfying ending. I do hope there is some sort of a sequel.

I was one of the folks who ran into the pickaxe handle issue in the dungeon and could not continue with that profile. So very glad I started over with a new profile and got to enjoy the entire the game.

I keep a list in a notebook of games I want to play again and this game went on that list. I will just wait a year or so before replaying.

I highly recommend the game. (Just watch out for the pickaxe handle issue. Be sure to pick it up before doing the H0G scene for the treasure chest.)

Elephant Games, thanks for a great game!
 
 
Was playing demo just fine, but then...

Finished everything that was to be done with the greenhouse. I returned to the house. From the piano room, tried to enter the door to the office. Access Violation and game terminated.

I restarted the game and was able to continue. Did not play any longer, though, as I want to save my demo time in case there is a fix.

Just not willing to buy the game in case I get that error again and cannot continue to play the game. I am hoping the Devs have a fix, otherwise this will be a No Buy for me.

On a positive note, I experienced no lag time at all. Game was moving along very nicely until the error.
 
 
 posted in Urban Legends: The Maze on Sep 19, 11 4:05 AM
rjohn82677 wrote:Has anyone had a problem with getting the pickaxe handle? I went to the chest. I got the scroll from the skeleton hand. I was able to complete the puzzle on the chest. But I did not get the pickaxe handle which I need to open the wall.

Also, the HOP is stuck. I found all objects, but instead of ending, the puzzle still shows sparkles like something is not found.

Very frustrating. I am really enjoying this game, but because of its length, I really don't want to start from the beginning.

Help!

RJ


I'm with RJ. I cannot get that pickaxe handle. When I click anywhere in the area of the skeleton, the visual zooms in on the open chest and the already-completed H0G scene. When I exit that scene, I'm back to the center of the dungeon. No matter where I put the cursor, all the magnifiy icons are labeled 'Chest' and cause a zoom in to the H0G scene.

I have closed/reopened the game numerous times in the hope that this glitch would resolve itself. (I knew there was little chance of that, but felt I had to try something.)

I added my 'me, too' in the Technical thread where others have run into the same issue. But, I fear the issue will get lost amidst the more prevalent (and serious) 'cannot play the game' postings.

This glitch is just frustrating because, like RJ, I really don't want to have to replay the first 3+ chapters just to get beyond the issue.

Any other advice from the Pond is very welcome.

Best,
Jorie

ETA: Well, I decided to start again with a new profile and zipped through the beginning chapters as fast as I could to get back to the dungeon chapter. I picked up that pickaxe handle as soon as possible! Continuing on with the game...
 
 
 posted in Urban Legends: The Maze on Sep 18, 11 3:27 PM
rexred54 wrote:There is a glitch in level 4 at the skeleton with the chest. I had the same problem as Micral. The HOG scene in the chest wouldn't end so I could get the pick-axe handle. I had to restart the game with a new profile. This time I picked up the pick-axe handle and map before doing the puzzle to open the chest. Everything proceeded normally after that, but it is a pain to have to restart the game so far into it.


Darn. I just ran into this issue. I see by the postings that a few of us did. Very frustrating not to be able to continue with the game. I really do not want to have to replay the game with a new profile just to get beyond this point.

Any chance of a fix?
 
 
queencate wrote:maybe i played for too long at one time , but i got tired of looking for jewelry pieces and emblems , and putting them together


I'm with you queencate. I split the game over two days and just finished it. Was so tired of all the FROGs that were so darned similar. I have marked this game in my notebook as 'Do not play again' all because of the this. Otherwise, the graphics were stunning and the storyline interesting.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator