Posts created by moonweaver

 
 
 posted in Nancy Drew Dossier: Lights, Camera, Curses on Nov 26, 08 8:30 PM
I agree; the smoothie game was very annoying. I kept breaking glasses, until I caught on that I had to see the "shadow" of the ingredient before dropping it in the glass. There was no way to skip the game, and I couldn't move on until I solved it. It took me SEVERAL times to finally get through it.

I don't mind the matching "Concentration" type game; I'm pretty good at those, because you don't have to be a quick clicker with the mouse. These old fingers are not very fast. But now I am stuck on decoding the Pharaoh poster. Help?
 
 
 posted in Nancy Drew Dossier: Lights, Camera, Curses on Nov 25, 08 10:13 PM
I also want to send kudos to the tech staff. I first contacted them because I had trouble with another game: when I downloaded the demo, it said my 60 minutes had expired. This has happened with a couple of other games, but I never contacted them about it. This time I did. So they issued me a coupon code. I decided to use it to purchase the Nancy Drew game, and when I downloaded what was supposed to be the full game (they don't offer a demo), it said I had 60 minutes. I figured it was a mistake, but when I had played an hour, the screen went black, and it said my demo had expired. So I wrote to them again, and they told me how to reinstall, and this time it worked, and I have the full game. Weird, though, that this happened, since there really isn't a demo version.
 
 
 posted in Fairway Solitaire on Nov 24, 08 10:38 PM
I picked one who looks my age (white hair), but she's skinny, and I'm not.
 
 
 posted in Treasure Seekers: Visions of Gold ™ on Nov 19, 08 12:41 AM
Thanks, Lizzie, for all your help!
 
 
 posted in Treasure Seekers: Visions of Gold ™ on Nov 18, 08 7:45 PM
I finished the game last night, but only after skipping the last puzzle in frustration. I also skipped a couple of other puzzles.

I had already solved part of the last puzzle, and exited because I was tired. When I came back to the game, it put me back at the beginning of that puzzle, and I couldn't even solve the part that I had already done: lining up the stone rings to make a pattern. The first time, I solved that part, and then put the brass coins in the dust, which turned them gold. But I didn't know what to do after that.

I will play the game again some time; I did enjoy most of it. So, any tips on that last puzzle?
 
 
 posted in Dr. Lynch: Grave Secrets on Nov 1, 08 11:11 PM
Last night I finished the game for the second time. This time I didn't skip any mini games; if I got stuck, I either came to this forum or to GameZebo for the walkthrough.

I was able to make the roses all grow this time by spraying them with short spurts, instead of holding the mouse button down the way I did the first time through.

And I found out on GameZebo that I should hold the mouse button down when turning the handle to make the fountain start working. It didn't matter that I hadn't found all the objects on the screen yet.

I enjoyed this game a lot in spite of the teeny objects.
 
 
 posted in Dr. Lynch: Grave Secrets on Oct 30, 08 11:07 PM
You don't have to actually put the mixture in the spray bottle. Once you have all the ingredients in the bowl, the game will put it in the sprayer for you. I started with the water; don't know if that makes a difference.
 
 
 posted in Dr. Lynch: Grave Secrets on Oct 29, 08 9:55 PM
I think there is a sun piece on a bookshelf on the right of the screen, but don't remember for sure. I do know there is one up near the ceiling, where it's dark.

The votive candles have to be placed in the form of a cross: in every space vertically in the center row, and across in the second row from the top. Then light them, and the shrine will open up.
 
 
 posted in Dr. Lynch: Grave Secrets on Oct 28, 08 12:38 AM
I finished the game last night, too. I had the same problems others had: some objects so miniscule it was hard for these old eyes to find them. I had to replay most chapters, sometimes three times. Also, as someone else said, I hate the clanging noise when you get down to two minutes left of your time. Makes me so nervous it's hard to find anything else.

I discovered that to clear the fountain, you just have to click the green growth in the middle with the cursor, which gets rid of it. I wondered why the fountain was just a trickle when I did turn the handle; guess it was because I hadn't found all the objects yet.

I had to skip several of the mini-games. The one that really stumped me was the roses in the garden. I could make them grow taller with the fertilizer I had mixed, but every time I got leaves to grow, they fell off. After trying all sorts of combinations, thinking they had to be done in a certain order, I finally gave up and skipped it, and then they grew tall.

Does anyone have the answer to this puzzle? Because I might try playing the game over, and trying to finish all the mini-games.
 
 
 posted in The Treasures of Mystery Island on Oct 24, 08 7:50 PM
I was having the same problem until I read a hint in another thread: instead of trying to aim the hammer at the part, actually click the cursor on each part, and it will work.
 
 
 posted in Musaic Box on Oct 22, 08 10:47 PM
JenRabbit: Go to photobucket.com, then type in a search for LizzieK

She has a long list of solutions for various games. Look for Musaic Box; she has the solution for Czardas. I enlarged it as much as possible, and then printed it out.
 
 
 posted in The Treasures of Mystery Island on Oct 22, 08 2:11 PM
I had played the demo of this game, and loved it, but didn't want to pay the money to Alawar for the full version. So I was very happy today to find that BF was offering it, and I bought an extra game credit to download it.
 
 
 posted in Magic Encyclopedia on Sep 23, 08 11:18 PM
Well, I went to GameZebo, as suggested, and printed out the walkthrough from Tips and Tricks. So I was able to move forward from the Indian Village. Now I am stuck at the Oasis/Graveyard, because I gave the sword to the ghost before using it as a lightning rod, without thinking. Now he wants a shield, and I can't get the last piece of shield without the sword to attract the lightning. I had to peek at the walkthrough to find the pieces of sword; I don't like to use the walkthrough unless I'm stuck. But now what do I do.....start the game over? I hate to do that, especially because some of the mini games are hard; I hate the ones with beams of light. The only way I can solve those is through trial and error, and I can never remember how I did it.
 
 
 posted in Magic Encyclopedia on Sep 20, 08 8:25 PM
I just downloaded the demo version of this game tonight, and am still on the first screen, the Mayan temple. It tells me I have found everything, I just need to put them in the right places. I cut the branch and tickled the statue's nose, and now I have the square set of carvings that says it looks like a key. When I try to put it in the square space that says it needs something square, it won't stay. Also, I have assembled the top of the stone, and when I try to put it where it says the stone used to be higher, it won't stay. So I don't know what else I'm supposed to do, because clicking on hints doesn't help now that I have found all the pieces.
 
 
 posted in Azada ™: Ancient Magic on Sep 10, 08 9:44 PM
Thanks for the congratulations, Cesse. Actually, I only thought I was finished last night. Tonight I went back and found out there was one more book, The Creature. I solved that, so now I really have finished. Again, it was the mini game that was holding me up for a little while, but it finally dawned on me how to do it.

When I feel refreshed again, I'll try Azada 1 again. That darned robot!
 
 
 posted in Azada ™: Ancient Magic on Sep 10, 08 12:25 AM
Well, I finally finished the game, and I did it on my own. I went back for one more try on the ball in the maze in The Invisible Man book, and by some miracle, or just dumb luck, I solved it. Then I got the Genie book, and for a while I was stuck in the maze from Hell. I couldn't seem to get anywhere that wasn't a dead end, so I reset the book, which meant I had to do the pipes puzzle again, which was harder for me the second time, for some reason. Maybe because it was late, and I was tired. Anyway, I finished, and now I may tackle the first Azada again. I gave up on it because of the frustrating robot, as some others said. But I'll try it again, now that I've conquered the second Azada.

Thanks to everybody who gave me suggestions.
 
 
 posted in Azada ™: Ancient Magic on Sep 9, 08 7:41 PM
Thanks to the person who helped me with the gears mini puzzle. The suggestion to place the gears to the right, left, top and bottom worked, and I finished that book. Now the only obstacle is solving the ball in the maze in the Invisible Man book. Slow doesn't work when I get really close to the center; I haven't been able to get my husband to help, and I don't have access to a child right now.
 
 
 posted in Azada ™: Ancient Magic on Sep 7, 08 11:18 PM
sandra53 wrote:It may be that I am tired but can someone give me a three letter word ending in the letter e???!!!


How about a word for something cold?

 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator