Posts created by barbaralbb

 
 
 posted in Escape the Lost Kingdom on May 6, 10 2:32 PM
Thought the game was kind of cute - playing as different characters with different "stuff" was a nice option. But, I won't be buying the game - was over halfway through at the end of my demo hour. Can't think that it's a good value when I would have less than another hour left to play. Thank you BF games that there is the hour option to make a decision regarding purchase.
B
 
 
 posted in Magic Encyclopedia: Illusions on May 3, 10 8:12 AM
It's important to remember that the name of the game is "Illusions". The red and blue bottles switch your view back and forth, exposing/hiding items. I do find that a bit confusing. The butterfly and key parchments work in the different views. The key parchment can be used on the padlock in the upper righthand corner. I finally got it to give me a missing part of the wand .....unfortunately, I tried so many things so many times that I can't give a step-by-step.

I'm about 15 min into the game and can't decide if I like all the "illusion" stuff or not - at least it's different and challenging! Can't complain that I'm over half way done by the end of the demo.....

Don't give up - just change the view back and forth and try all the options, that's what worked for me.
B.
 
 
 posted in Master Wu and the Glory of the Ten Powers on Apr 26, 10 9:14 AM
Tiny hidden objects, fuzzy focus on the scenes, not very interesting game, music not great. All in all, no sale on this one - only played about 20 min and got bored with it. We'll see what tomorow brings - maybe the next game will be more interesting - not a great week, from a new game standpoint......
 
 
 posted in Dark Parables: Curse of Briar Rose on Mar 29, 10 12:57 PM
Here's what I've realized since my earlier post:
.The hard version is exactly like the regular version just without any "hints" or "skips". Had to reference the walkthrough a couple of times when I could not find a teensy little piece of something.
.The ending of both versions says " Now that your city is safe, the princess hands you a small crown and urges you to stop another imminent threat. Holding a map left by a carrier pigeon, you begin your next investigation in search of the fabled Frog Prince."
.I did the Golden Rose of the hard version and all I found was a Frog Prince statue with some pictures of the art development - pretty but not much of a reward for the harder play.
.Never found anything about the "map left by a carrier pigeon...". Clicked on the pigeon in the Briar Rose bedroom and message just says "A carrier pigeon is standing by the window." Like I couldn't see that already.... Went through the whole game again, just to make sure I hadn't missed "pigeons" someplace but no map and no clues.

So, I guess that's the end. If there is anything else, I didn't find it. Liked the game, just hated the ambiguous last message....
 
 
 posted in Dark Parables: Curse of Briar Rose on Mar 28, 10 1:32 PM
Finsihed the regular game then finished the hard version and, again, the ending references finding a map from the pigeons and the Frog Prince. Is this a "promo" for the next edition or is there something else in this game that I'm missing?
 
 
 posted in It's all about masks on Mar 24, 10 12:14 PM
Tried it and deleted it. Didn't seem to have a plot and the hidden object scenes were cluttered. Just didn't see the point and I love hidden object games! This one didn't make the "cut".....
 
 
 posted in Vampireville on Mar 16, 10 1:49 PM
Finished today, too - enjoyed it very much. The game is written with a sense of humor, fun to play, and it ENDS! No silly "to be continued.....". This game actually ends and the characters tell you what they did next. Also, it isn't so dark and muddy colored that it's impossible to find items on a laptop screen.

 
 
 posted in The Tarot's Misfortune on Feb 18, 10 7:47 PM
Go back to East Town. Go to the far right side of the screen. Use the hammer to smash two (2) sets of barrels. The Wand Icon, plus other items you need, are in those barrels. Just found it and am now ready to exit through the gate. Like the game - it is different and interesting.
Good luck!
 
 
 posted in Be Richer on Sep 7, 09 7:07 PM
Okay, I have no idea why I was successful, this time. It seemed to have something to do with the type of building I chose to start with. And, I think, there needed to be a connection between the lower and middle streets..... for whatever reason, I just finished the level.
 
 
 posted in Be Richer on Sep 7, 09 6:51 PM
Have had no problem with roads, until this level. Tried road building every way I can figure, but continue to get the message that my property has no road access and building vans cannot get there. In looking at the roads, they all have a curb that I didn't notice on earlier levels. Also, on earlier levels, the access seemed to be automatic.

Know this must be something simple, but I'm stumped..... Anyone have a solution?
Thanks,
barbaralbb
 
 
 posted in National Geographic ™ presents: Herod's Lost Tomb on Nov 15, 08 8:37 PM
I agree with the above comments. I did buy this game and I'm sorry I did. Screens are so monochromatic that many items are almost impossible to find. I used the hints way more than I like to 'cause I just could not see the items. And it's very repetitive..... Not as interesting as I'd hoped, with National Geographic as a sponsor.
 
 
 posted in Hawaiian Explorer 2: Lost Island on Nov 3, 08 6:35 PM
Found the PDF and It's slightly right of center on the plane consol. Looks like a small TV screen. Counld swear I'd clicked on that thing several times, but at least I've moved on to the next level. Don't think I'm going to buy this one. Items are a pain to find and I really like hidden object games. Too monocromatic for me......
 
 
 posted in Hawaiian Explorer 2: Lost Island on Nov 3, 08 6:18 PM
I'm stumped and cannot find the PDF in the crashed plane. Even turned my computer upside down to see if that helped....it didn't. HATE that the timer is so unforgiving and there are only 15 seconds. Guess that means it isn't that hard, but I'm not getting it. Anybody got a hint?
 
 
 posted in Samantha Swift and the Hidden Roses of Athena on Oct 8, 08 3:44 PM
I ran in to an error on the last section (Japan) that locked up my system and I had to reboot. Happened every time I tried to load the game..... (I'm running Vista, but don't know that mattered). Today I deleted the game and downloaded again. Thought I'd have to start over, but I was able to start right where I stopped and completed the game without a problem. Love this game!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator