Posts created by Julayne

 
 
 posted in The Revenge on Mar 26, 11 8:29 AM
How do you do this puzzle? Someone said you have to get rid of the arrows & pay attention to which direction they go before your next move. I can't get any arrow to do anything. HELP
 
 
 posted in PuppetShow: Souls of the Innocent on Jun 19, 10 1:26 PM
I didn't pick up the valve in the puppet workshop. Now I can't pick it up. Anyone any suggestions how I can get it?
 
 
 posted in Mystery Cruise on May 12, 10 5:07 AM
I missed picking up the green wing seal in the theatre, went to next room, now I can't get back into the theatre. Any suggestions besides starting all over again. I'm on the demo.
 
 
 posted in Insider Tales: Vanished in Rome on Jan 11, 10 11:19 AM
when I click on hint for the axe, it shows me up above on a bucket. It looks like there might be an axe handle behind it. When I click on it, nothing happens. I have clicked all over that bucket & can't get the axe. Can't go on until I get it. Anybody have any ideas?
 
 
 posted in Alabama Smith in the Quest of Fate on Dec 27, 09 12:22 PM
I can't find the spot to click on so I can solve the puzzle. Walkthrough said lower right corner. I've tried every corner there is. HELP
 
 
 posted in Relic Hunt on Aug 24, 09 4:51 PM
I have tried Relic Hunt on several web sites & haven't been able to see any of the screens. I hear music but nothing else. Something seems to be wrong. At least, for me!
 
 
 posted in Cate West: The Velvet Keys on Apr 25, 09 3:57 PM
I uninstalled the game & reinstalled & everything went just fine from there. At least until my demo time ran out. Those are awfully junky scenes! Julayne
 
 
 posted in Cate West: The Velvet Keys on Apr 25, 09 5:35 AM
I'm playing the demo & I have activated the ossuary. However, nothing happens. I have only a man's face in a tank. Nothing to tell me what to do, no hints. I have clicked around. HELP!
Julayne
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator