Posts created by JKPHEP

 
 
 posted in The Serpent of Isis ™ on Sep 20, 17 8:59 PM
Never kicked a game off my computer, but I did this one. Reason is I didn't click on anything but it took the # of help off when it got to zero i stopped when it was flashing red. I saw red also. What I had for years was this game. OK I blew sorry.
 
 
 posted in The Secret Order: New Horizon on Dec 20, 11 12:50 PM
How sure are you about that? If so that means a follow-up game. I hope you are right, but maybe not.
 
 
 posted in Revenge of the Spirit: Rite of Resurrection on Dec 10, 11 7:21 PM
You use it to get to the keys I guess at the nurse's station. BUT use it on the little door by the keys first. If you don't and use it to get the keys in order you won't get to finish the game, like me. Good luck
 
 
 posted in Revenge of the Spirit: Rite of Resurrection on Dec 10, 11 7:03 PM
The one thing I don't like about some games is, if you screw up you are locked out of the game and have to start over. The good or better games don't make you start over. They make it where a dummy like me don't have to do everything over just because I put something before another. I will get down now. Thanks
 
 
 posted in Revenge of the Spirit: Rite of Resurrection on Dec 10, 11 6:53 PM
I think I have really messed up. I don't know why you have to follow the walk through so close. But you do, or are smarter than I am . I got the key card under the bed and went to the keys and slid it through the slot. Put all the keys in the right place then went to open Jones' locker and went to get the key for 205 and the keys are locked up again. I looked at the walk through and was suppose to go to the lock box before the key game. Could anyone help me? Maybe someone from fish. If so just tell me I have to start over. I am about 1/2 way through. Thanks to anyone that can help. PLEASE. I hate doing games over. I if I have to I will probably trash this one. By the way the key card went away. Never mind. I went back and done things different and got the key. I am so happy. I apologise spelling to the makers of this game.
 
 
 posted in Dream Chronicles: The Book of Water on Dec 2, 11 6:12 PM
I am having the same problem. I don't think the dream pieces have anything to do with it. It is they just don't stay where we put them. I am mad. Oh well won't worry about it. If you find anything out let me know OK> I will do the same.
 
 
 posted in Resurrection, New Mexico on Dec 2, 11 1:20 PM
Did it work? JKPHEP
 
 
 posted in Resurrection, New Mexico on Dec 2, 11 1:18 PM
I can't get that far either. If you ever get a answer let me in on it to. PLEASE Thanks
 
 
 posted in Resurrection, New Mexico on Nov 29, 11 6:34 PM
Put the rope and magnet together. To do that just put them in the same box and they will tie together. Hand the magnet and rope into the water and with any luck the key will come out. Good luck. JKPHEP
 
 
 posted in Dream Chronicles: The Book of Water on Nov 29, 11 9:55 AM
I hate to complain but it seems like there are glitchs in every game now. If I deveate from what the gamers want us to do thangs lock up Well not lock up but you just can't go to where you are suppose to. I don't like to follow the walkthrough all the way. But saying that if I don't then I can't do something on down in the game. Am I alone in this or do others have that problem too. I know people do because they have the same problem as I do. WHY do they make games like that. It wasn't that way a couple of years ago. Thanks now I will get down from my soap box.
 
 
 posted in Resurrection, New Mexico on Nov 28, 11 7:29 PM
I got the key like you said to do. With the rope and the magnet. I had tried it with just the magnet but it didn't work. Like I said I am in your debt for ever. If I can help you just PM me and I will do my best. I think your best would be a lot better. Thanks so much.
 
 
 posted in Resurrection, New Mexico on Nov 27, 11 6:41 PM
I am trying to get the key to the electrical box in the tunnel It is in the water and says to use the rod, I am guessing they mean the crowbar. It is the only thing I have that looks anything like it. If there anything that I am missing please let me know. I will be in your debt forever. Thanks so much.
 
 
Why would BFG change something that is working so well. I played the free hour and found out what it was and tossed it out. Everyone has been waiting for the Ravenhearst game and when it came all was happy. Now as I read they are disapointed in it. As was I was. When something is # 1 on the all time games leave it alone. This is my option, it is the only one I have.
 
 
 posted in Resurrection, New Mexico on Nov 25, 11 6:02 PM
There is already one at the other main game co. (Removed by moderator). Just goggle it.
 
 
 posted in Strange Cases: The Secrets of Grey Mist Lake on Nov 24, 11 1:39 PM
I am suppose to be looking for the sheriff. I am suppose to go to the crashed car and go to the hole in the tree to play a HOS but there is a spider there. Then I go back down 3 clicks but can't get but 1 click to the dress shop and play a HOS. I run into the ghost with a broken Carriage wanting me to fix his carriage . I try to go around him but I go straight into the dress shop and into the home part of the house. I have to catch a fly to feed a spider in the tree hole. But I can't find the HOS to get a jar. I would really thank you for any help or any way you done it. THANKS
 
 
 posted in Weird Park: Broken Tune Collector's Edition on Nov 20, 11 5:10 PM
Maybe they are keeping it from us until we buy because it is so bad. I will not buy because of this, I may not even use it but I want to know it is there and how good it is.
 
 
 posted in Dream Chronicles: The Book of Water on Nov 15, 11 11:18 AM
On the very end of the game you are suppose to put some I call them letters on the statue of the girl then watch the finish. I can't get the letters to stick. Would some one help me. There is a circle that comes up and I guess they go in there. I know someone has done this. Would you please tell me what happens. Thanks so much.
 
 
 posted in Dream Chronicles: The Book of Water on Nov 11, 11 2:00 PM
My problem is, I got through the game just fine but when I came to the end I can't get any of the magic letters to stick on the statue of the girl. I have tried to put them everywhere. They won't stick. I have 68 of the 70 dream pieces. Does that matter? Do I have to go back and find the other 2. Hope not. Any help please. Thank you so much. JKPHEP PS I tried to go back and get the dream pices but the game won't let me.
 
 
 posted in Dream Chronicles: The Book of Water on Nov 10, 11 8:15 PM
To get the hammer to weld, just leave it in the tray and hit the button.
 
 
I had 7 min. to play in the free time. It froze 3 min. un till the end. Tell me do you think I should buy it? Ha not on your life. There they missed a sale, because I liked the game. I got lucky this time. I think I will play the whole hour from now on. I think it will save me some head aches. JKPHEP
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator