Posts created by ALicd

 
 
 posted in Awakening Kingdoms on Aug 23, 14 4:39 AM
has anyone been kicked out of the game without warning. ive already had laptop checked out thoroughly so not that and it happens only with this game. I lose data
 
 
 posted in Awakening Kingdoms on Aug 12, 14 9:49 AM
its why I want all the rewards I earn need that money honey lol
 
 
 posted in Awakening Kingdoms on Aug 11, 14 9:14 AM
there is still a problem with quests not drawing on collection to complete quests.
also I don't know if anyone else is noticing when you are getting rewarded and its both a quest reward and reward earned you only get the one even if compter congratulates you for both. I have been watching the counter
 
 
 posted in Awakening Kingdoms on Aug 10, 14 4:57 PM
You still haven't fixed all the glitches. The quests are still not drawing from my collections entirely yet which slows the game up even more sigh
 
 
 posted in Mysteries and Nightmares: Morgiana on Aug 1, 14 6:56 PM
thanks hun that got me farther now I have the hankie, magic staff, chain and chisel lol
 
 
 posted in Mysteries and Nightmares: Morgiana on Aug 1, 14 4:36 PM
thanx hun this is the second that confused me frustrates me but im old with poor eyesight lol
 
 
 posted in Mysteries and Nightmares: Morgiana on Aug 1, 14 6:39 AM
Im in the gallery and only
access is top of the statue or the crossbow don't have access to either and next task is to find underground room. have explored other scenes through map and hint and nothing needs to be done know that im missing something but don't know what sigh
 
 
 posted in Mysteries and Nightmares: Morgiana on Jul 31, 14 7:57 AM
am in gallery and do not have handkerchief and cant find hidden entrance
help!!!!!











 
 
 posted in Awakening Kingdoms on Jul 29, 14 3:51 PM
anyone having a problem with some quests not accepting already earned quest objects and some going into minus that you have earn out of? very irritating sigh
 
 
I have the pieces the iron the lead and the goo but it asks for tin although it says on strategy guide I have all I need need faucet help!
 
 
 posted in Awakening Kingdoms on Jul 9, 14 11:01 AM
have uninstalled and reinstalled no treasure vault room
 
 
 posted in Awakening Kingdoms on Jul 3, 14 5:24 AM
anyone else lose the treasure room latest update?
 
 
 posted in Haunted Past: Realm of Ghosts on Mar 4, 12 1:01 PM
I just started to play this game but i started with the envelope. You click in the object missing in the picture and then pick up the item that appears until you end with a knife to cut the edge of the emily painting.
 
 
 posted in Dark Parables: Rise of the Snow Queen on Jan 11, 12 1:54 PM
loved the game but what happened to the poor frog stuck outside the gate with the remnants of his quest to get his son and wife back? only thing i found lacking.
 
 
 posted in My Kingdom for the Princess II on Jan 20, 11 10:21 AM
ok the few times that ive posted here i havent gotten a reply by here goes on this game. level 5-8 is just not doable. i have tried all suggestions but there is either not enough time or gold. I end up pausing with not enough gold or get to the last beat and not enough time. I am not a fast player as I have issues with my hands., its why i dont do time management. got the first game and enjoyed it but am not pleased with this one it requires to my dexterity to get through. Please can someone give a step by step on how to get this level done during the time limit or give me a skip option. I have checked all the cheats i can find by gamezbo my fave for walkthroughs doesnt take this to the 4 and 5 levels their instructions are easier for me to understand. I probably wont do another time management its too stressful. that is my comment on this game.
 
 
no it is not worth it i cant get the diagram and potato chips or the extra hidden objects so cannot advance so not worth the twenty dollar price.
 
 
 posted in Mystery of Shark Island on Jul 18, 10 12:45 PM
is there an end to this game? I have gotten all the statues but it doesnt give me an end game where the queen gets them back? Is there a number maximum i have to achieve?
 
 
 posted in Mystery of Shark Island on Jul 15, 10 2:14 PM
i just finished this game and i didnt get an ending to it where the statues are returned to the queen so that their reverse aging is stopped. Is there a game number you have to reach to get to the end?
 
 
 posted in Drawn: The Painted Tower ™ on Jun 3, 10 1:57 PM
loved the game but the ending sucked. could we not see iris reunited with her family and people?
 
 
 posted in Youda Legend: The Curse of the Amsterdam Diamond on Feb 10, 10 11:22 AM
okay anyone using the gamezbo walkthrough the fifth amulet is at the top of the map and not the bottom.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator