Posts created by Girldawn

 
 
 posted in Roads of Rome II on Jun 14, 11 2:49 PM
Hello fishies, I need some help please. Just purchased this game in May and have gotten thru the first two episodes in expert time, however on episode 3, levels 2- 4 I first finished before time ran out but after expert time expired. I went back and beat them in expert time but the marker for the level stays silver instead of turning red for expert. Level 5 (episode 3) I've played numerous times finishing in expert, but it won't let me go any further saying that level hasn't been finished, like i haven't been able to complete it before all the time ran out, which I have. I've looked thru the help topics, uninstalled and reinstalled - would appreciate any help, can't wait to go farther on this game!

Thanks Girldawn
 
 
 posted in Royal Envoy on Mar 6, 11 8:00 PM
Vingilot - Thanks!!! I wanted to beat this level sooooo bad and tried every way I could before looking for help. I followed your instructions to the T and made gold 1st try!!! Yeah thank you!!
 
 
 posted in Clutter on Feb 27, 11 10:18 PM
At first I thought this was just silly, but by the time the demo ended I could not hit the "buy" button fast enough!! Graphics are very nice and clear, like the mini games and I really appreciate the clutter advise Maybe there's hope for me with the help of this game! Thank you as always BF
 
 
 posted in Royal Trouble on Sep 11, 10 9:22 PM
Thank you prpldva!! For the welcome and the tip - I missed that for sure! Gotta go try it Thanks and have a great night or day - which ever applies
 
 
 posted in Royal Trouble on Sep 11, 10 4:38 PM
Hi everyone - I just started playing the demo and can't find the line or rope to attach to the hook. I'm guessing the Prince will climb up to give one end of the curtain to the Princess? I've read the hints even cheated and checked the walk through! What am I missing????? Help me please Thank you, Girl Dawn
 
 
 posted in Samantha Swift and the Fountains of Fate on Aug 13, 10 6:46 PM
Hello all, I really need help!!! A few days ago I was playing in Samantha at Midas Palace (outside back) and I had found all the objects in white, opened the crate for pick axe, got gold dancer and placed, got the star emblem and placed in stone figure to get what was there and Sam said , we're all done here let's take the exit at the back of the screen to the next place - well that's when I needed to leave,and instead of exiting to the next place first I just went to the main menu and exited the game! Wrong move on my part!! Now when I enter the game I am outback, the dancer is in place and the drawer is opened- empty. The axe is gone but the hint still shows it's in the rock and the "find it screen" says I still need to get the gold dancer. I've tried everything - even un and reinstalled the game! What am I missing here? Sorry this is so long, but I didn't know how to give you a short version - please help me if you can Thank you, Girldawn
 
 
 posted in Millennium Secrets: Emerald Curse on Mar 20, 10 5:21 PM
Thanks to all you fish's for your comments and opinions. I too just finished the demo and was surprised how fast it went. I am totally hooked on Hidden Object, and am really impressed with how the game playing has improved in the last couple of years. My concern was how long it was and if it was worth a game credit. Now I'm thinking yeah! The things I liked: not too much dialog, and moving from room to room to find things and then returning to a certain room to solve a puzzle. What's really cool is my memory's not so sharp so I think I'll be able to play this over and over with the switch from casual to the more difficult play mode and it will be like a brand new
game ha-ha

Thanks again, Dawn
 
 
 posted in Hidden Expedition: Amazon ™ on Jul 18, 08 3:01 PM
Can get the lights in order but not in the right position to light up? The "clue" I think is saying the colors have to be in specific places on the circle. Can't get them in those positions! Please Help Meeeeee Thanks
 
 
 posted in Hidden Expedition: Amazon ™ on Jul 6, 08 6:47 PM
Thanks scotcat. appreciate the help! I'll give it a try. By the way I've only seen one of "your cats" and didn't know what the heck it was! They are awesome!!!!
 
 
 posted in Hidden Expedition: Amazon ™ on Jul 4, 08 12:33 PM
Hi, I posted this question in the chat room too (I'm new and don't know correct way to do this-so here goes) Can't get the pipes in right positions to make the water into steam-appreciate any help. Thanks
 
 
 posted in Hidden Expedition: Amazon ™ on Jul 4, 08 12:25 PM
Help please? Cannot figure shape to put pipes into to turn the water into steam using lava?
Also do I have to shut sown the game every time I want to see the strategy guide? I tried without and now my game won't open in full screen. I t was fine before I started using the guide. Thanks for any help
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator