Posts created by PuzzlesRus

 
 
 posted in Agency 33 on Jul 17, 14 8:44 PM
I have dozens and dozens of foods..candy bars, cakes, salads, etc. but when I run low on energy and wish to use a food item, it won't let me. The "USE" buttons are never active. This has been going on over the last week or more. When I first started playing the game, I was allowed to use food items now and then, though not every time I wanted to.
Hoping someone can explain what I am doing wrong...
Thanks in advance.
Puzz
 
 
 posted in Faded Reality on Aug 6, 10 9:41 AM
I'm stuck at the one that says "check the time". I have looked by every timepiece I can find in both locations, but I must be blind! Please help.
 
 
 posted in Eden's Quest: The Hunt for Akua on Mar 5, 10 7:33 AM
I am alo stuck at the mill, I can't seem to finish the last challenge. PLEASE somebody tell me the code to open the chest, I have worked on this almost an hour now. Just go ahead and spoil it for me..tell me the whole answer, I bought all the hints, they aren't much help. For instance, if there are four numbers in the code, and one of them is a four, how can there also be TWO 1'S and TWO 3's??? HELLLLLLLLLLLLLp me please!!
 
 
 posted in Something Special on May 6, 09 8:19 AM
Overall I liked this game, there seems to be "replay-ability" given the fact that there are three difficulty levels, each with it's own set of objects. I am seriously considering biting the bullet on this one. But I have one huge question, how long is this game. I hate that sinking feeling I get when I play the one hour trial, rush to buy the game and then the game ends ten minutes after purchase. I feel like I wasted my money ..or basically got ripped off. I do wish there BF would state in the game briefing how many levels the game contains. It would be nice to know that BEFORE we buy it.
I guess I'll have to wait for the official "PoodleBear Approval" before I purchase this game (thanking you in advance, dear :angle
 
 
 posted in Alchemist's Apprentice on Apr 20, 09 7:15 AM
Thank GOODness for PoodleBear and LizzieK! If it weren't for the two of you we all would waste a ton of money on worthless games, and prolly end up in the nuthouse after going stark raving mad after being stuck (and horribly frustrated) on some seemingly simple puzzle in an otherwise enjoyable game.

FOUR FINS up to ya both..bless you.
 
 
 posted in Mae Q`West and the Sign of the Stars on Mar 2, 09 10:39 AM
Oh drats! I was coming here to find out how to get out of the shipwreck..it seems we are all stuck on the same spot.
 
 
 posted in Rescue at Rajini Island on Jan 27, 09 9:55 AM
The hands on the statue?

Click the hands.
 
 
 posted in Rescue at Rajini Island on Jan 27, 09 9:52 AM
On the download page it is spelled Raijini, but when you get the game, it is spelled Rajini..minus the I, so the forum matches the game..go look again.
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 22, 09 9:38 AM
Hi..
First I want to say, having read every post in this forum, I bought the game and have loved it so far. I have had no problems with it whatsoever. But, sadly..I seem to be stuck.
I just got off the ghost train and into the temple. How do I get the spear out of the hands of the statue? Everytime I click the Hint button, it just highlights the hands. I have clicked, tried drag n drop, tried everything my little brain can come up with, and still the dumb statue will not give me the spear.
Please, don't worry about "spoiling" anything for me..just tell me how to get the spear...PLEASE.
 
 
 posted in The Treasures of Mystery Island on Oct 27, 08 12:42 AM
tecami wrote:I'm stuck at the cave entrance/Waterfall/jungle waterfall. I can't find the piece of gold cup and a piece of stone is missing where the 5 red flashing pegs are. What do I do with the pegs? All I have is the hammer. Please help....

Never mind. I figured it out. You have to do the pegs in a certain order and after that everything makes sense and it is easy.


OK..but I haven't figured it out, so could somebody please explain how to do the red flashy light..from the above question?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator