Posts created by HighlandMax

 posted in The Inquisitor on May 31, 10 8:19 PM
I bought it, and am enjoying it. I agree there are a lot of cut scenes, but they can be skipped. It's not too dark for me either, nor am I having a difficult time finding the objects. The spot the difference, was a bit too much though, even using my magnified glass, it was difficult to find all the differences......but, after all, it is a hidden object game.
 posted in Millennium Secrets: Emerald Curse on May 30, 10 5:07 PM
Thanks Prpldva, when I replay the game, I'll try your suggestion. I really want to be able to solve it.

There was another puzzle, towards the very end, where you had to place colored gems of different shapes. The game help instructions said you could only place like colors or shapes, next to another gem of the same color or shape. But, that didn't work either. It said, " Or " shape, not " And " shape. I tried putting like shapes next to each other, and it wouldn't always take it.
 posted in Millennium Secrets: Emerald Curse on May 29, 10 1:13 PM
Don't know about the rest of you who have played this puzzle, but the walkthrough is wrong on the solution, I also went to gamezebo and looked at their solution, it's wrong too. I don't really want to skip this puzzle for the mere reason that I know there has to be a right way, but, I can't find it. Most aggrivating, because I generally like puzzles like this one. I'll try a few more times, and if I should get it, I'll edit this post with the solution.
I wasn't aware that this is an old game, but, I am enjoying it.
 posted in The Heritage on May 28, 10 10:34 AM
At this point, with all the technical problems involved with this game for so many other fish, I would say, there is a 50/50 chance that you too would have these problems. I was one of the few who had no problems what so ever. So, it is strictly up to you if you want to take that gamble.
 posted in The Heritage on May 28, 10 8:23 AM
Yes, you will need a larger key to open the barred gate, and then you can open the little chest.
 posted in The Heritage on May 28, 10 8:21 AM
When you click on the cutain with the ring, a close up view is suppose to show, just a small square close up showing the hole where the plug goes, click the plug onto the hole. That's all there is to it.
 posted in The Heritage on May 28, 10 8:17 AM
I simply clicked the Close button. But you are saying that only the help button works. Then, I guess it won't work for you, sorry.
 posted in The Heritage on May 27, 10 6:25 PM
Only if you want to read the letters within the locket, to keep up with the story. But in order to actually play the game, the locket is not used.
I am playing the second time around, and am by-passing the locket and having no problems.
Edited to add, that I just simply clicked the " Close " button in red at the bottom of the screen with the locket, and it would take me to the next scene.
 posted in The Heritage on May 27, 10 2:07 PM
There are 12 differences. Be sure and notice a smudge on the back upper side of the bowl, and a slender diamond shape smudge on the front bottom of bowl, then just look for differences in the mushrooms, some have more dots than others, some stems are different colors, and so on.
 posted in The Heritage on May 27, 10 2:04 PM
You're right, you triggered my memory. You find a curtain ring and click it on the curtain , it opens up and the tub/shower is behind that curtain.
 posted in The Heritage on May 27, 10 12:56 PM
How many keys do you have in inventory ? I can remember one time, trying to use a key and couldn't, only to find out, that it was the wrong key. I know at one point, there is a box or small chest that's locked but behind a set of bars. You have the key, but it won't work til you open the bars.
Wish I could help you.
Edited to add, that during my second time around playing this game, if you look in your inventory, you will see a shadow of 2 more keys that you will get later on. It will take one of those keys to open the drawer.
 posted in The Heritage on May 27, 10 12:51 PM
To be perfectly honest with you, I remember that part, and I do remember placing the plug, however, just where and when, I don't remember. Sorry, but most of the time, I'm concentrating on figuring out what to do next, and don't always remember how.
 posted in Hotel on May 26, 10 6:54 PM
Just in case someone else has this problem, you have to open your inventory and click the suitcase and then click it on the closet. True with anything else that you need to place.
 posted in The Heritage on May 26, 10 5:03 PM
It wasn't long enough is my only complaint. Never had any technical problems of any sorts.
The story must have been written by someone either on the verge of insanity, already insane or just a very wild cracked imagination......but no worse than some of the others. I liked it.....kept you wondering.
I'm not sorry I bought it, just not long enough for my taste.
I'm sorry so many of you had problems, or are having problems......just one of those unexplainable freaky things, that I had no problems............or could it be that it worked for me, cause I and the story are both ??????????

 posted in The Heritage on May 26, 10 3:50 PM
Funny, I haven't had any problems.........none, what so ever.......with the game, that is.
 posted in The Heritage on May 26, 10 3:46 PM
.......before anything else, when you first click the play button in the game manager, a black background will come on with 2 company logos. Click that black screen, then BFG will come on and the game will load. But unless you click that black screen first, you will never get any further than that page. least this is true when I started, and with each time I start back after quiting.
 posted in The Heritage on May 26, 10 2:54 PM
I noticed that some of you are saying you can't play this puzzle because there is no blank space to move a piece into. When I played it, my puzzle square had one spot that was darker than the others, it was not blank, but was darker. I discovered that it was this darker square where an adjacent piece was to be moved into. Try and see if the same is true in your game. Hope this helps.
 posted in The Heritage on May 26, 10 1:25 PM
Just to add my 2 cents worth, let it be known, that so far, I have had no technical problems with any part of the game......yet. I am about to play the rose puzzle in the garden, and have read that some of you are having problems with it. I will let you know if I do too.
 posted in The Heritage on May 26, 10 1:15 PM
Well, there is a story, but, IMO a rather odd one. One of those types that you have to read between the lines to understand, and one in which each player has their own interpretation. I'm seeing a twist to it. The man seems to think both his wives have drawn away from him, one ended her life in suicide and now the second one, according to him, is cheating on her, so he has now locked her up in the basement. Meanwhile, the wife can't understand her husband, so she blames their problems on him, and swears she has not cheated on him, it's only his imagination.
I'm only playing the game to find out just exactly what's going on. Haven't had any problems yet with the game play.
 posted in Hotel on May 25, 10 2:56 PM
Sorry Oregon I can't agree with you, because the ghosts and mummy are an entirely different thing.
But yes, it is a good game, I have played it twice now.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator