Posts created by Rozanne

 
 
 posted in Mystery Case Files: Dire Grove, Sacred Grove on Dec 28, 14 4:39 AM
I am playing the SE version, and I need to find the Sacrifice Whistle Scroll. Although I played the HO in the cabin, the scroll is not in my inventory or on my Evidence Board and I cant get back through the cabin door. When I click on "Hint", it directs me to the Evidence Board where there is still a space for the Sacrifice Whistle Scroll. I am obviously doing something wrong, but what???
 
 
 posted in Fright Collector's Edition on Jul 15, 14 10:53 AM
I was really enjoying this game till I got stuck - been stuck since yesterday - It must be something I am doing wrong. The Strategy Guide says "Return to second floor of the house and then walk left. Place the jack under the bookcase and turn the crank".

When I go up the stair to the second floor, there is no option to turn left. I can place the cursor on Mrs Henderson's door on the left and the game says "Now I just need some way of getting this letter to Mrs. Henderson." So I am very confused because I thought I had made the letter into a paper plane and thrown it at Mrs Henderson's window?? Meanwhile I can't progress further into the game.
 
 
 posted in Lost Souls: Timeless Fables on Jun 16, 14 12:38 PM
I have posted a stern complaint on the Facebook BFG page - Let's see if we get a reaction LOL!
 
 
 posted in Lost Souls: Timeless Fables on Jun 12, 14 11:01 AM
Why is there STILL no fix for this game? Come on, BFG, it's up to you now to tell the developer to get a move on. How much longer do we have to wait???
 
 
 posted in Lost Souls: Timeless Fables on Jun 7, 14 1:15 AM
Same black screen for me when I go to Robinson Crusoe Beach - Is there a patch for this game yet please?
 
 
 posted in Off the Record: The Italian Affair Collector's Edition on Apr 20, 14 12:41 PM
Thank you, endofmonth, with your explanation, at last I have got it. Used up lots of my trial time over this stupid puzzle grrrrrrr
 
 
 posted in Bluebeard's Castle: Son of the Heartless on Mar 7, 14 2:11 AM
This game is soooo frustrating - Each time I try to change direction in the game, I click on the arrow and then have to sit and wait a few minutes before it will do anything. I am now in the library and when I click on the various books, the game and my computer freezes up. Please when is there going to be an update to solve these many glitches?
 
 
 posted in Stranded Dreamscapes: The Prisoner on Nov 9, 13 11:59 AM
The very same thing has happened to me - Hint button no longer works - I even changed the game difficulty but still nothing.. Also I just cant find the last slider button I need for the mini game - Read through the walkthrough but still can't find it!! Yet another glitch??
 
 
 posted in Dark Sisterhood: The Initiation on Oct 13, 13 10:41 AM
Every time I press the Hint button, it tells me to use the door latch in my inventory on the church door - NO, the door latch is definitely NOT in my inventory - aarrgghh!! Is there an update for this game yet?
 
 
 posted in Dark Lore Mysteries: The Hunt for Truth on Feb 3, 13 7:49 AM
Tried to play the demo 3 times now and game just freezes at the place where the horse and carriage is! I give up.
 
 
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Jan 13, 12 9:59 AM
Duh! I saw this but I thought it was some sort of hieroglyphics - I really must get my glasses changed.

Thanks Mr Russ
 
 
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Jan 13, 12 8:24 AM
What chest? What book?

Like I said, I cant get into the chest until I solve the above puzzle!
 
 
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Jan 13, 12 7:38 AM
I am in the Lighthouse, still in the First Chapter I think, and this is what the walkthrough says:-

Look at the table; take the MAGNIFYING GLASS (1). Note the numbers on the book (2).

Examine the chest to activate a puzzle.

Using the plus and minus buttons, change the center numbers to reflect the code on the book.

The solution is random but there are a few steps that should work for everyone. Click on the buttons in this order: A x 2, B x 2, A x 3, C x 1, and A x 2. At this point the two left button should be at 6 and the two right numbers should be at 2.

Now click on the D button until the two left numbers are the same numbers as your solution. Press the E button until the 2 right numbers are the same as your solution to complete the puzzle.

Ok, now I did not make a note of the code on the book from the previous evening's play, and I cant find it in the Journal, so what to do??? : Does this mean that I have to start this game all over again??
 
 
 posted in Dark Tales: Edgar Allan Poe's The Premature Burial on Dec 24, 11 10:26 PM
This very same thing has happened to me on THREE consecutive evenings. I try to play the game from where I left off the previous evening, but it always just shoots me back to the closed City Gates, even though I have played 90 minutes beyond this point in the game THREE times now. Aaaaarrrrggghhhhhh!
 
 
Poor Customer Support seems to be inundated at the moment - the average reply back seems to be taking about 72 hours, according to BFG.
 
 
 posted in The Secret Legacy: A Kate Brooks Adventure on Jan 25, 11 10:58 AM
Well, I am only two minutes into this game and I just had to quit. From the start of this game, I am getting a grey box superimposed on my screen covering half of the screen which is simply flashing on and off.

I just need to ask a question here - How many beta testers do they send these games out to (because in my opinion many people should do the testing) , do the beta testers do their "job" properly, and do the developers ever take note of the beta testers criticims and observations, because so many games have glitches now - and this never used to happen.
 
 
 posted in Pathfinders: Lost at Sea on Mar 2, 10 11:43 PM
I downloaded this game at the weekend. When it got to 100%, it said Saving File in the Games Manager. It then said this for at least 24 hours, and the game was not installed so I could not play it. The next day I downloaded it again, and the very same thing happened for the next 24 hours.

Between the first and second downloads, I reinstalled the Games Manager. In the past week I have downloaded successfully many many large file games, and Pathfinders is the only game I have had this problem with.

Anyone else had this problem please?
 
 
 posted in Mystery Case Files: Ravenhearst ™ on Sep 10, 08 8:55 PM
Hee hee - I think there is maybe a gremlin in my game cos no matter how many keys I find, items are still flashing. I managed to get it down to just the one location flashing - but its a location where I know I have found all the keys, unless there is more than one key in each screen and if the keys move around!

Edit: Ok - I just googled this and here's what I found:

"This is a bug in the game. As far as I know, newer versions of the game (at the Game Socks site, etc.) don't have the bug.

If you go in the basement while looking for keys, the bug is triggered. The only solution is to let your time run out, restart the search, DON'T GO IN THE BASEMENT until you have all keys."

Hmmmm
 
 
 posted in Mystery Case Files: Ravenhearst ™ on Sep 10, 08 12:37 AM
I have managed to find all 7 keys, and the screen says "Go to the cellar and see if you can unlock the hidden door" - but I am only able to get back into the Grounds and the Third Floor and I cant see any way to the Cellar in these locations. I need help please!
 
 
 posted in Around the World in 80 Days on Sep 6, 08 7:16 AM
Yes, thats the exact level. Its the one where there is a separate grid at the bottom with all locked tiles. I have sailed through this game, but now I have got to Day 78, I dont even know what to do. I dont want the solution, I just want to know how to unlock those tiles please.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator