Posts created by mikedog

 
 
 posted in Luxor Amun Rising on Oct 11, 16 9:56 AM
This is an old game and there probably aren't many checking the forum for it, but in the off chance that someone may see the question, I was wondering how high can you go through promotions starting with tiller of the fields. If you keep it up will you eventually get to be Pharoah? There must be a top level. I've gotten obsessed with the idea of seeing how high I can go. I am presently at treasurer, polisher of silver.
 
 
OK - I figured out what I was doing wrong. You have to put the phone on the horse statue, then press the button. I was clicking on the statue; a picture of the phone would show up briefly, and I would click on that. I finally did it right and got my picture.
 
 
Thanks - I'll try that.
 
 
I can't get the phone to take the picture of the horse statue. I click on the horse statue and then click the button on the phone but nothing happens. I need the picture for the next step. Anyone have any suggestions?
 
 
I found the cocoon in the Inner Monastery section, in the LibraryTower. The guide instructs you to pick up a wrench near the stairs, and the cocoon is next to the wrench.
 
 
 posted in League of Light: Wicked Harvest Collector's Edition on Oct 24, 14 12:42 PM
I got it to work putting the scarecrow near the top just to the right of the bracelet.
 
 
 posted in Queen's Quest: Tower of Darkness on Oct 12, 14 1:19 PM
I have been through the game and have found all the crowns and all the hooks but am one short on the swords and the apples. Is there a list anywhere to tell us where the collectibles are or is there some way to go back to a section that has already been played and look some more? Thanks to anyone who may be able to help.
 
 
I'm having the same problem. In chapter one I've had to do a restart three times. I'm now at the beginning of chapter two and am undecided whether or not to buy the game. I'm running windows 8.
 
 
 posted in Christmas Wonderland 4 on Dec 21, 13 5:39 AM
Thank you! That was driving me crazy - I played the game all the way through twice and must have replayed that last scene 25 times. It still took me a couple of minutes but I found the figure in the tree. I can now boast of having a perfect score.
 
 
 posted in Christmas Wonderland 4 on Dec 20, 13 7:00 AM
You don't actually move the reindeer. You decide which deer belongs In which stall and click them in order; i.e., click the one in stall one, then the one in stall two, etc. If you click correctly the stall will light up. If you click one wrong all the lights go out and you have to start again.
 
 
 posted in Christmas Wonderland 4 on Dec 20, 13 6:55 AM
I found all the Nativity figures in all the scenes except the last one, Christmas morning. In that one I found eight:

1. Shepherd on gift bag bottom left.
2. White figure - not sure what it is, maybe an angel - outside, visible through first window to left of door
3. Joseph on mantle
4. Mary holding Baby Jesus on top of bottom package in stack behind woman holding plate of cookies
5. Baby Jesus on hearth to left of fire
6. Wise man on top of green package under tree
7. Angel above door to the right
8. Three wise men on card above mantle to left

Does ANYONE know where the ninth is? I've looked and looked; I even looked with a magnifying glass. If you know, please help!!
 
 
 posted in Evy: Magic Spheres on Jul 22, 13 3:28 AM
I was expecting a straightforward marble popper. I was somewhat disappointed that this was a more involved game. Not a BAD game; just not what I hoped for.
 
 
 posted in Evy: Magic Spheres on Jul 22, 13 3:26 AM
I was expecting a straightforward marble popper - something we see very little of now. I was disappointed that it was a more elaborate game. It isn't a BAD game, it just isn't what I hoped for.
 
 
I had the problem; did a restart and it happened again.
 
 
 posted in Infected: The Twin Vaccine Collector's Edition on Jun 25, 12 7:19 AM
I ran the Dr. Felix analysis software and got the report but I can't figure out how to send it - when I click on Contact Us I get a screen telling me to select a topic, but it won't let me select a topic and I can't send the the e-mail without it.

I got only about a third of the way through the game before the Strategy Guide froze. I spent two game credits for this game and it is essentially unplayable now. How likely is it that this situation will be resolved? If it isn't can I get a refund? I actually like the game but if it's really too complicated to play without the Strategy Guide.

If you'll tell me how to get an e-mail up and running, I'll attempt to send the Dr. Felix report.
 
 
 posted in Abandoned: Chestnut Lodge Asylum on May 7, 12 11:23 AM
Thanks for the advice re. the brochure stand next to the stairs. Was there an instruction in the strategy guide about the brochure stand? I've been through the strategy guide from the beginning twice and if it's there I'm skipping right over it. Anyway, clicking on the brochure stand and flipping the brochure to the second page worked and I'm moving on.
 
 
 posted in Abandoned: Chestnut Lodge Asylum on May 7, 12 4:26 AM
The briefcase by the fountain won't let me enter the code. The cursor just stays a magnifying glass. I backtracked to see if there was a place where I was supposed to have found the code and didn't find anything. Can anyone tell me what I'm doing wrong? I can't get past this point.
 
 
 posted in House of 1000 Doors: Family Secret Collector's Edition on Dec 24, 11 5:08 PM
I'd already put the ashes on the ouija board; I went back and clicked around until I saw the three sisters. Then Amanda was there when I went to her room. Now I can finish the game. Thank you!
 
 
 posted in House of 1000 Doors: Family Secret Collector's Edition on Dec 24, 11 3:55 PM
In the bonus section, after drawing the circle of death with chalk, the strategy guide instructs you to "go to Amanda." I go to Amanda's room and she isn't there - the illustration in the Strategy Guide shows her sitting on the side of the bed. Is there something I didn't do? I backtracked several screens to see if I had inadvertently skipped a step, but if I did I can't figure out what it is. I can't go any further until I find Amanda and get the key.
 
 
I am terribly frustrated!! I can get to the control panel at the light house, I can set the numbers at 5374, but they just make the strange noise and go right back to the top. All the little lights are green under each number, but I can't get past the control panel. Is there some step I'm supposed to be doing that I am somehow missing? What am I supposed to do now. I've restarted the game three times! HELP!!

This game desperately needs a REAL walkthrough!!

Thanks to anyone who may be able to help.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator