Posts created by cjpandie

 posted in Dark Tales: Edgar Allan Poe's Morella on Feb 14, 18 5:17 PM
Yes, there are two stones in the HOP to move items to, to get them out of the way, to reach the items you need to match to another item. If the warning that there is no room on a stone, you need to move one of the items on one of the stones back into the chest. Moving the snake or the flower or the leaves, or the fang out of the way you can find the hidden items below the others. It can be done with moving items one by one. Hope this helps someone.
 posted in Mystery Case Files: The Black Veil on Nov 9, 17 6:27 PM
I am having a lot of trouble with the vending machine. Was there a code that I missed for this? Trying to use the hints to get the right numbers and when I get four of the numbers it reverts back to the beginning one. Thanks for any help
 posted in Haunted Legends: The Black Hawk on Apr 16, 17 4:58 PM
Trying to complete the cannon HOS. Collected everything required except for one item which doesn't seem to want to go anywhere. When I hit "hint" it tells me to exit the HOS but when I hit "hint" again, it tells me to return to the HOS. Not able to use any of my inventory items in this HOS either like you can in some games.

Not sure if this is a tech glitch or am I just missing something...can't seem to progress any further until I finish whatever it is I'm suppose to do. I've found two chair legs and an assortment of wood. Any suggestions?
 posted in Haunted Legends: The Black Hawk on Apr 16, 17 4:49 PM
I am having the same problem. It is frustrating. I think I am going to say it is technical and report it.
 posted in Weather Lord: In Pursuit of the Shaman on Nov 18, 16 8:58 AM
Suppose to stand on a button where is the button? I keep trying by cursor over everything and can't find a button. Thanks
 posted in Nancy Drew: The Silent Spy on Sep 18, 15 3:30 PM
How come all the files on this forum are locked. I realize most have played this game a long time ago, but I just bought it and downloaded it and I can't ask anyone for help. Do I need to go to support to get help? Anyone?
 posted in The Promised Land on Sep 8, 15 6:00 PM
I keep running low on food. I start a new game and start over. Is there some way to not run low on food? I switch food items and it does help but not very fast. Any suggestions anyone?
 posted in Nancy Drew: The Silent Spy on Sep 4, 15 4:21 PM
I can't remember what locker is suppose to have the envelop in it and how do you open a locker anyway? Please help. Thanks
 posted in Twilight Phenomena: The Incredible Show on Mar 1, 15 1:02 PM
I cannot get the mixture done because when I try using the pipette it won't pick any liquids up. Anybody know what to do? Thanks all
I too am having trouble with the last item at the fountain. I "believe" I am suppose to put something on the frog's head, maybe the crown, but the game is not letting me do that. When I ask for a hint, sometimes it shows that option or it points somewhere else. I think this game has major problems. So what can I do? The SG doesn't help at all in this case. Help please.
 posted in Hope Lake on Jun 3, 14 12:22 PM
I finished the game and didn't have to use whatever was there at the entrance of the shed. So whatever it is, gals, you can forget about it.
 posted in Hope Lake on May 29, 14 3:31 PM
I too, am having the same problem. If anyone figures out what to do, please let us know. I sure wish these games would make things easier to navigate. Thanks anyone.
 posted in Tearstone on May 4, 14 11:00 AM
I am having the same problem. I can see from the posts on here that lots of people have had this problem. I checked the position of the knives they are in the correct positions, because thy can't be moved. I can't get the brush to brush. It just flies back to the inventory. guess I will count this as another I won't finish. I will be checking back to see if anyone really did get this to work eventually. Thanks
 posted in Crystals of Time on Apr 20, 14 4:37 PM
How do we get to the island? If we have to use the boat, where is all the items I need. right now the hint is showing a dirty mirror or window, can't find it. Need help. Thanks
 posted in Crystals of Time on Apr 8, 14 2:11 PM
When I tried this, it shows up a a magnifying glass and there is no way to click on anything. Tried clicking on the newspaper that didn't work. Thanks
 posted in The Happy Hereafter on Mar 8, 14 4:19 PM
Is there only one tree to chop for wood for building things? I keep running out of wood on the one I have been having the workers chop down.
 posted in Haunted Train: Spirits of Charon Collector's Edition on Mar 4, 14 9:36 AM
Aside from the complaints, bad or not, has the glitch been fixed?
 posted in The Happy Hereafter on Feb 8, 14 9:14 AM
I haven't found an alter, maybe I am thinking of it as something else? Where is the alter and what does it look like? Thanks all.
 posted in The Happy Hereafter on Feb 8, 14 9:05 AM
I found there are different levels of circus pillars. I too was manufacturing them, but not the right level so I switched to level two pillars and now I hope that helps. This game takes a lot of brain work, and some times mine doesn't work right. lol
 posted in The Happy Hereafter on Feb 8, 14 9:02 AM
I can't find any fake gold in the trade section. Are you trading it out or bringing it in? Can anyone else help with this? Thanks Fishies. I am loving this game more as I get into it. I still have too many personalities wandering around but and don't know what to do with them all.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator