Posts created by patscable

 
 
 posted in Rite of Passage: Heart of the Storm Collector's Edition on Feb 13, 16 12:30 PM
I put the eye of truth in and have a HOP of forms like volcano, whales and etc. I know you are suppose to match them but they don't move. What am I suppose to do to solve this HOP. please help.
 
 
 posted in Sable Maze: Forbidden Garden Collector's Edition on Jan 5, 16 10:05 AM
I had so much trouble with finding the 12th piece and I finially found it it is right under the Guide sign. Is it hard to find but just click under the guide sign and you will see it.
 
 
 posted in Emberwing: Lost Legacy Collector's Edition on Nov 2, 14 11:12 AM
By the dragon you start a fire by the gate and change the pipes. How do i change the pipes. i already started the fire so that mean i can not change the pipe? help i am stuck here and can not get past it. I have tried to use everyhthing in my inventory including the wrench. But nothing works. Help please so i can finish this game. thank you pat
 
 
 posted in Chronicles of Vida: The Story of the Missing Princess on Aug 27, 14 6:46 PM
never mind i found the last coin and red candle. you have to find the door that is open and go through the door into another world and you will find the candle and last coin.
 
 
 posted in Chronicles of Vida: The Story of the Missing Princess on Aug 27, 14 9:59 AM
I have all the coins but one and i can not find it anywhere and i moved to easy mode but it says every place is completed. So where is the other coin. i got the one in the maze. where are all the coins located at for missed one. i have been all over the place. i switched to easy mode because it would highlight the area where i missed the coin but still nothing. do i need to do something with the red candles i only have 5 candles. I still have them, but i think there are 6? if there are 6 where can i find the last candle? . ok i went back to all the places that the coins were in the entrance to the castle in gargoyole mouth, room where you find angela, and in labyrinth. but i am still missing a coin please help
 
 
 posted in The Veil of Mystery: Seven Little Gnomes on Apr 29, 14 10:59 AM
i do not know what to do in the grave yard. the hint told me to go to the grave yard and use the metal detector, but i tried and it will not take it. i tried everything i n my inventory including the mine pick and nothing? what can i do at the grave site and how do i get the metal detector to work?
 
 
oil
 posted in Haunted Hotel: Charles Dexter Ward on Apr 25, 13 12:51 PM
where is the oil. I have the aroma lamp but i did not see any oil. Where is the oil?
 
 
 posted in Dark Parables: The Exiled Prince Collector's Edition on Jun 5, 11 6:16 PM
I put the silver fountain emblem on the floor and activated the puzzle. I gave up on the puzzle and skipped it. I never got the gear handle piece. not sure important The doo;r opened and I went in but I don't have the secert tree disc> Where did I miss that???????? thank you pat
 
 
 posted in Mystic Gateways: The Celestial Quest on Oct 28, 10 11:31 AM
I know what you mean I have looked all over for two days looking for acorns. However when I read that you couldn't find them and they told you there was no acorns.. The berries are the acorns I finally figured out after reading your reply. Hope you found them. The berries look like acorns though pat
 
 
 posted in Eternity on Jun 4, 10 8:16 AM
Has anybody had trouble with this game??? I did fine till I got to the spot where you set down the mouse and open the bird cage. I did all that but there is no feather left. The bird took the mouse but no feather was left. I even cheated and look at the walkthrough to see if I could find it and no feather was left. Now when I try to get into the game it won't let me. It says it stopped working everytime. I am going to uninstall and reinstall and hope that works because I don't want to restart again a third time.
 
 
 posted in Deadtime Stories on Jun 4, 10 8:00 AM
Has anyone had trouble with this game? I played it till I got to the graveyard. I did everything but when I put the mouse down and opened the cage the bird fly out and grab the mouse but did not leave a feather. I even cheated to find the feather on the walkthrough but no feather was left. Then the game kept quiting on me everytime I tried to get into it. I am trying to un install and reinstall so I hope this works because although I like the game I don't have to restart again a third time.
 
 
 posted in Deadtime Stories on Jun 3, 10 9:04 AM
never mind I found the dolls head. The simple things that are right in front of you are the ones I seem to miss.
 
 
 posted in Deadtime Stories on Jun 3, 10 8:56 AM
I am stuck if anybody can help me. I am at the graveyard and swamp. I got the ball for the boy and got the block. I have the dolls body but where is the head? Did I miss it? Where can I find it? Will the carriage take me back to one of the house for the head if that is where I find it? Right now I can only go to swamp area and the graveyard gate.
 
 
 posted in Unsolved Mystery Club™: Amelia Earhart™ on Apr 23, 10 12:03 PM
I can not get this game to come up. It installed with no problems( I tried 2 times); however when I try to go play it it tries to open but it doesn't.(the screen goes black like it is trying to open then it just goes back to my home page.) Anything different I can try to try and play this game? I tried doing what you said in your help pages but still nothing. I hear it is a good game and would like to try it and probably buy ,if can. I have never had this problem before with your games so I don't know what to do. thanks
 
 
 posted in Magic Encyclopedia: Moon Light on Aug 11, 09 12:09 PM
Sorry I forgot that I still have things to get for inside (study like) I can't seem to do anything. I still some items to get inside. I still have to cut the chair,and do everything else in there however I can't find anything or do anything?? I did give the mondey his milk but still can't go in(I do get the lags to go in). It is because I still need to get the things inside the study like?????? HELP I'm lost now.
 
 
 posted in Magic Encyclopedia: Moon Light on Aug 11, 09 11:44 AM
I am at the hut and I have everything started the fire, got the coconut milk to the mondey and the door opened but I still can't go in??????? I checked on the walkthrough but it doesn't say anything that I haven't done already. I do get the little feet that says walk in but it won't let me. HELP!!!!!!!!!
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Feb 23, 09 6:52 PM
Help Help help

I had gotten a good ways into the games and I don't have a screw driver from the male statue and I have already done the hidden ojects. I need the screw driver so I started the game over again twice.
All three times I couldn't get the screw driver. If you forgot something you can't go back but do I have restart again? I got everything else except that. Can anyone help me? I hope I don't have to restart the game again. It gets flustrating. thanks pat
 
 
 posted in The Hidden Prophecies of Nostradamus on Jan 27, 09 11:42 AM
I also have trouble with the game freezing up. I get to the second fire ball game and it freezes. Anyone found out why let me know.
Seems that there should be an solution. I have all the download mentioned in the other chats but still it freezes and says error. ?????????
 
 
 posted in The Lost Cases of Sherlock Holmes on Jul 17, 08 8:16 AM
I am stuck on the family tree. Please any hints or help on this one. thanks pat
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator